1.    20 Sep 2017 #1
    Join Date : Jun 2016
    Posts : 16
    Win 10

    Permissions


    I am trying to install a Steelseries controller. When I download the software, I get, Windows cannot open the file you may not have proper permissions. When I check permissions on the drive. I have full permissions.
    I hit ignore while downloading. The file is on my computer.
    When I try installing the controller, it doesn't show up on the blue tooth (screen).
    I tried deleting it from the drive (with the uninstaller). It leaves the Steelseries file and well when I click on that. I have no permissions. WTF?
      My ComputerSystem Spec
  2.    20 Sep 2017 #2
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,042
    Windows 10 Pro

    What is the model# of the Steelseries controller? Where are you downloading the driver from?
    Have you downloaded it from here? SteelSeries Engine Software - GameSense Customization | SteelSeries. Save the file to your download location and right click the SteelSeriesEngine3.114Setup.exe file and choose Run As Administrator.
      My ComputerSystem Spec
  3.    20 Sep 2017 #3
    Join Date : Jun 2016
    Posts : 16
    Win 10
    Thread Starter

    Spunk, Yup, downloaded it from the same place. I can't run it administrator either. The box comes up but when it try to click it the check wont move, appear in the admin. box
      My ComputerSystem Spec
  4.    20 Sep 2017 #4
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,042
    Windows 10 Pro

    Enable the Hidden Administrator account. Log out as you and login as the Administrator. Try running it as Admin again.
      My ComputerSystem Spec
  5.    20 Sep 2017 #5
    Join Date : Jun 2016
    Posts : 16
    Win 10
    Thread Starter

    Finally got In the hidden admin account. Same thing. Then I tried to delete it got it all but one file, and then I need admin approval?
      My ComputerSystem Spec
  6.    20 Sep 2017 #6
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,042
    Windows 10 Pro

    Hmm Ok Take Ownership of the file.
    Right click the TaskBar and start the Task Manager, go to the Processes tab, and Make sure the program is not running in the background, if it is, End the Process before deleting the file.
      My ComputerSystem Spec
  7.    21 Sep 2017 #7
    Join Date : Jun 2016
    Posts : 16
    Win 10
    Thread Starter

    Spunk, I actually got it deleted thanks. I have a ticket in with Steelseries, maybe they can tell me whats wrong with the download.
    Then again, maybe you can.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Profile permissions
Hi I have a problem with one user profile on my Windows10 PC. Log into the other profile and everything works fine. I'm wondering if I could have inadvertently changed permissions, set to read only, or locked my main profile directory when I was...
User Accounts and Family Safety
Permissions
Recently I received a message from Windows 10 saying that there was an update for Java, and to click to install, so I clicked it and it came up with some permission error, so I manually went to the temp folder and installed it with privs and...
General Support
Permissions..
Hello guys I have an HTPC that it acts as a server too, i'm downloading movies, tv shows, music etc on my HTPC and others at home access that shared Drive. Thing is that I kinda want to setup specific permissions, I don't want them for example...
Network and Sharing
Solved 1.00.30 Permissions
Does anyone else have this, the permissions have gone when you select a file or folder (see image). 21270
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:38.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums