1.    18 Sep 2017 #1
    Join Date : Sep 2017
    Posts : 3
    Windows 10

    Changing from AHCI to RAID causes boot loop


    I have a MySN XMG U716 (Clevo P775DM1) that I got with two 256Gb Samung 951 NVMe PCIe SSD's, initially in RAID 1. I later decided to break this RAID array because I wanted the extra 256Gb for games etc, and I broke the array by setting them to Non-Raid but leaving RAID mode enabled.

    Somehow the BIOS has been set back to AHCI (possibly by the BIOS and KBC/EC Firmware Updates I've done, although I'm not fully convinced that it wasn't something else), but Windows boots just fine in AHCI mode, but I cannot see the NVMe Drives in Intel Rapid Storage Technology when they are in AHCI mode (because they're NVME PCIe drives that are designed to be used in RAID mode, not AHCI). So if I wanted to set up the SSD's in RAID 1 again I can't do it and keep my data by using the Intel RST.

    If I switch Windows to Safe Boot from MSCONFIG and restart and change the Controller Mode to RAID I get the XMG Logo with the spinning circle for longer than it normally takes to boot, and then it pauses for a few seconds before going back to the beginning of the boot sequence as through you hit the restart button.

    I had an issue with the Intel Extreme Tunrup Utility last year and Windows wouldn't boot afterwards, I couldn't figure out how to access the BIOS so I ended up pulling the CMOS Battery which reset to AHCI from RAID but back then I got INACCESSIBLE_BOOT_DEVICE" now I don't even get that, just an attempt to boot then restart.

    I tried using a bootable USB stick created with the Media Creation Tool but it cannot see the NVMe Drives when set to RAID, only the two SATA HDDs that I also have. I believe it is also nigh on impossible to get the Recovery Environment to load RAID drivers as well as or instead of AHCI.

    I'm at a loss as to what I can actually do to get these drives back in RAID mode so everything is as it should be, as the old registry tweaks (such as HKLM\SYSTEM\CurrentControlSet\Services\msahci) are no longer present in Windows 10 and the ones suggested for Windows 8 such as StartOverride for "iaStorAV" don't seem to be working either.
      My ComputerSystem Spec
  2.    19 Sep 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    Hi SergeantSteve.

    When you boot from from the media created with the media creation tool, and you already have the BIOS set to raid, do you create the raid when you see the Intel screen. You have to enter the software, CRTL + I, during the boot, before windows installation starts and create Raid. At least that is how I remember doing it.

    Maybe that is what you are doing but thought I would confirm.
      My ComputerSystem Spec
  3.    20 Sep 2017 #3
    Join Date : Sep 2017
    Posts : 3
    Windows 10
    Thread Starter

    I am not trying to create a RAID Array, I am trying to get Windows to boot with the SATA Controller set to RAID mode instead of AHCI.

    My reason for wanting RAID instead of AHCI is because the Intel Rapid Storage Technology Software does not recognise the NVMe Drives under AHCI, only under RAID mode.

    There is no "CTRL + I" screen for my Laptop and no Intel screen, you can create a RAID Array directly from the Intel RST settings in the BIOS.

    When I purchased my Laptop I asked for the two NVMe Drives to be in RAID 1. When I had issues with Windows refusing to boot because I messed up the BIOS using the Intel Extreme Tuneup Utility I had to pull the BIOS Battery. This resulted in the BIOS changing to AHCI mode and Windows gave "INACCESSIBLE_BOOT_DEVICE".

    Once I changed the Controller mode back to RAID Windows booted fine off one of the NVME drives as the RAID Array had been broken by me removing the BIOS Battery. However with the BIOS in RAID Mode I was able to see the NVMe Drives in Intel RST and I could then setup the RAID 1 Array from within Windows again and copy the data from the drive that it had booted to.

    Earlier this year I decided I wanted to use the second NVMe drive for storage, and I went into the BIOS and deleted the RAID Array and set both drives back to Non-RAID. If I remember correctly I believe I still had the BIOS in RAID Mode and I could still see the NVMe drives in Intel RST in Windows. Now I cannot boot in RAID mode because I get the XMG Logo with spinning circle for longer than it normally takes to boot, then it restarts from the beginning again.
      My ComputerSystem Spec
  4.    20 Sep 2017 #4
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,035
    Windows 10 Pro Build 1703

    Okay but why not repeat what "worked" before. Create the the raid 1 array using both drives boot, install windows and then break array.

    Have a look at this tutorial, in particular step 12. You may have to load drivers as part of the installation.

    Clean Install Windows 10
      My ComputerSystem Spec
  5.    20 Sep 2017 #5
    Join Date : Oct 2015
    Posts : 2,038
    Windows 10 Pro X64

    Hi,
    @SergeantSteve: on my machines the raid volume needs to be created from within UEFI/BIOS first. Controller set to RAID as well.
    When you install W10 you need to feed it the Intel RST driver and if you like Samsung's NVMe driver too.

    Cheers,
      My ComputersSystem Spec
  6.    20 Sep 2017 #6
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,041
    Windows 10 Pro

    When you change the HDD mode from AHCI to RAID, you have to reinstall the OS from scratch. You may be able to edit the Windows Registry to accept the change. Be sure to backup the registry and your files before attempting. How to: Change SATA Modes After Windows Installation
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Using an NVME SSD in AHCI vs RAID mode
I built my system with a Samsung 950 PRO m.2 NVMe SSD as the Windows 10 boot drive (C:), plus a pair of old-fashioned SATA-III hard drives configured in RAID1 as my data drive (D:). The SSD is plugged directly into one of the m.2 slots on my...
Drivers and Hardware
AHCI or RAID
Hi. I have just purchased a Dell XPS 15 Laptop with a single 512gb SSD. I am wanting to clean install Windows 10 but am unsure whether to place the BIOS in RAID or AHCI? I have heard the read/write SSD speeds are similar once in windows. Would...
Drivers and Hardware
Solved Switch from AHCI to RAID
I have Windows 10 Pro installed on an SSD in AHCI mode. I would like to add a RAID 1 array to this system for storage but I understand some registry tweaks must be made before I can change my BIOS from AHCI to RAID mode or I'll end up hosing...
Drivers and Hardware
Can't boot to Windows 10 after changing SATA mode and RAID
So at first, I was trying to resolve an issue with my BD-ROM drive described here: XPS 8700 - BD-ROM (HL-DT-ST DVDRW/BDROM CH20N) Not Recognized Windows 10 - Disk Drives (HDD, CD/DVD, Blu-ray) Forum - Disk Drives - Dell Community However,...
Drivers and Hardware
Windows in a boot loop after changing to Insider
Yesterday I decided to join and install windows 10 insider builds, when I changed it over it said it needed to restart, upon restarting it would show the windows logo then go to a black screen and sit there. If I move the mouse it shows up with a...
Windows Insider
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:03.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums