Windows 10: Windows not recognising USB hubs adatpers

  1.    17 Sep 2017 #1

    Windows not recognising USB hubs adatpers


    So i have no idea whats going on or how to diagnose this.I have 2 HUB adapters - a Dlink with 7 ports, and an Orico with 9 ports.
    Both are plugged directly into the motherboard.

    I've never had any issue for over a year since the first build. I had to reformat last night.
    After plugging various devices into both these ports - windows recognised them fine and installed the necessary drivers - i could see the devices fine in devices and printers.

    Then after disconnecting devices from these hubs, and switching them on an hour or so later - windows was not recognising them.

    Its not even recognising the hubs. I plug the hubs into a spare laptop - its fine - no issue at all.

    Going into device manager i right clicked on Universal serial bus controllers and scanned for hardware changes - and it worked - i heard the windows audio beeps as all of a sudden all the devices plugged into the hub adapters were found.

    Anyway, switched them all off again, went to bed. Now i have the same issue, and this time, scanning for hardware changes does not fix the issue.

    I've had both these hub controllers working fine before the format, what the hell is going on???
    I've tried reinstalling the USB 3.0/3.1 drivers that came with the motherboard and this has made no difference.

    I really really don't want to have to spend 2 hours formatting and installing everything again - what have i done wrong????
      My ComputerSystem Spec

  2.    17 Sep 2017 #2

    Give this a try. Open an elevated command or power shell prompt (admin). Press Enter after each command.

    diskpart
    automount enable
    exit
    exit

    See if that helps.
      My ComputerSystem Spec

  3.    20 Sep 2017 #3

    TrustMe said: View Post
    Give this a try. Open an elevated command or power shell prompt (admin). Press Enter after each command.

    diskpart
    automount enable
    exit
    exit

    See if that helps.
    thanks, in the end i just formatted. all appears to be working now even if i mix up devices with slots or plug the same device into any slots sequentially, recognises fine and loads drivers.
    don't know what happened before.
      My ComputerSystem Spec

  4.    20 Sep 2017 #4

    What is the make/model of each hub adapter?
      My ComputerSystem Spec

  5.   My ComputerSystem Spec


 

Related Threads
Solved Laptop not recognising usb in Drivers and Hardware
Just got a new Asus x540s and I tried to back up my files using a usb but when I clicked on "add drive" the system could not find the stick, if I go into the drives I can see my stick from there ! any ideas ?:confused:
I have been having severe HD problems and will be replacing. I have coaxed it back to some degree but have USB problems as all USB Root hubs show yellow triangle and Error 39. Rest of USB Host controllers show "working properly". I have my mouse...
Dell Inspiron 5000 series, brand new Originally the DVD drive would not show at all in File Explorer, despite Device Manager recognising, drivers up to date, etc. Dell diagnostics reported various feedback ranging from perfectly ok...
After updating to Windows 10,I had to re-register my laptop with sky go.Another change cannot be made for a month.Does anyone know if the very latest update will have the same effect;i.e.that Sky does not recognise the laptop again?John Phaff.
on windows 7, I had no problems but since updating to windows 10 it does not recognise my USB connection. I have tried various USB ports but as soon as I connect I get the notification " USB not recognised ".:confused:
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:40.
Find Us