1.    14 Sep 2017 #1
    Join Date : Oct 2015
    Posts : 47
    Windows 10

    Logitech wireless mouse no longer recognised; cannot uninstall drivers


    After every major Windows 10 update, I have experienced problems with my logitech wireless mouse (M235). When I've turned the computer on, the screen has frequently frozen with the spinning dots, but after I've removed the mouse dongle from the USB port, everything has proceeded normally; replacing the dongle and rebooting has restored normal mouse function.
    But following the latest update, my mouse is just not recognised. I still get the spinning dots when I turn on the PC, and it boots normally when I remove the mouse dongle, but after that I cannot use the mouse at all. I'm trying to remove the drivers so that I can reinstall them, but I can't get rid of them via device manager. I have also unsuccessfully tried to remove setpoint. Interestingly, when I go to Properties of the mouse, I'm told there is no driver installed. And yet if I go to the details of the drivers, there are two listed:
    C:\WINDOWS/system32/DRIVERS/mouclass.sys
    and
    C:\WINDOWS/system32/DRIVERS/mouhid.sys
    I figured that if I could remove all the previously installed (corrupted?) mouse drivers, I could reinstall them, even via plug and play.
    Can anyone offer some advice??
      My ComputerSystem Spec
  2.    14 Sep 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,050
    Windows 10 Pro Build 1703

    Hi Florio

    When you try to remove what happens? Nothing, error message, sound. Anything in event viewer recording the non removal.

    Are you using administrator account (sorry had to ask.) ?

    Before trying anything I recommend you make an Image with a tool like Macrium Reflect. You need a plan B if something goes wrong.

    Backup and Restore with Macrium Reflect

    First thing I would try is disabling Windows Fast Startup. See if this helps. The fastest way to test is by disabling hibernation.

    At command prompt(admin) or powershell(admin) enter

    powercfg -h off

    Test. To turn hibernation on replace off with on in command. If this fixes things you can get tutorial on just disabling Fast Startup.

    Are you comfortable using the Advance Startup Options to get to Safe Mode and attempt uninstall. If not wait until another member has a better solution.

    To get process started hold shift key down and restart.

    Boot to Advanced Startup Options in Windows 10

    Once all mice removed, I'm hopeful, then ALT + F4 will give you menu and you can use arrow keys to select restart.

    I know you want to use this mouse but I would not push it. Operating systems move forward and mice die.


    Ken
      My ComputerSystem Spec
  3.    15 Sep 2017 #3
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,438
    Windows 10 IoT

    Unifying receiver? I have several cordless Logitech keyboards and trackballs. They all work with Windows stock drivers. To the best of my knowledge as far as the PC is concerned, they are wired USB devices. It thinks its a USB keyboard or mouse. I almost never install the Setpoint software. About all I ever use is the Unifying software to link and unlink devices. I link my trackball to my keyboards Unifying receiver so I only need the one. You might try un linking your mouse, and then relinking it again. You might want to hunt up a corded mouse to do it though. It could be tricky accessing the menu with no mouse connected. Maybe your receiver or mouse has gone bad? Good batteries in the mouse?
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Mouse Properties Interfere with Logitech Gaming Mouse Settings
Win 10 Prof. I use a Logitech gaming mouse G900 for regular mousing and photography editing. It has a tilt wheel left and right which I've assigned to copy and paste. This works fine. However, when I use the scroll wheel to scroll, it often acts...
Drivers and Hardware
Solved Logitech LX-300 wireless keyboard freezes sporadically
Hello to all, my Logitech LX-300 (Y-RQ52) wireless keyboard freezes sporadically (in Win10). it stops working while writing any text, in any location, Office, notepad, internet - even while typing this post!! i can write a sentence but it...
Drivers and Hardware
Seagate Barracuda 3GB no longer being properly recognised, and beeping
I have a Seagate External HDD, srd00f2, that until yesterday was working perfectly. I can not think of anything that has changed, other than that the drive is no longer being recognised by Windows, and is beeping when connected. I have already tried...
Drivers and Hardware
Cannot Uninstall Drivers from Install/Uninstall List - Windows 10
I installed Arduino software, part of which included installing a number of drivers. I uninstalled the software using the internal software uninstall feature. Apparently it removed the drivers, but for some reason they still show up in the Windows...
Drivers and Hardware
Solved Logitech Unfying USB Key No Longer Recognized
FIX: In the list of USB ports depicted in the image below, you will notice that USB Root Hub (xHCI) has a specific icon appearing over it, indicating that it is disabled. Somehow during the update from Windows 8.1 to Windows 10 this happened, and...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 08:20.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums