Windows 10: Hardware Reserved Memory issue, common fixes don't seem to have worked

  1.    04 Sep 2017 #1

    Hardware Reserved Memory issue, common fixes don't seem to have worked


    Hey guys,

    I have the seemingly common Hardware Reserved Memory issue, wherein I have 32GB (4x8) of RAM installed, but the system is reserving 8.1gb.

    Click image for larger version. 

Name:	Capture.PNG 
Views:	58 
Size:	31.5 KB 
ID:	151977
    System specs:
    Windows 10 Enterprise, 64 bit
    Motherboard: MSI x399 Pro Carbon, CPU is Threadripper 1950x
    RAM: G Skill Trident Z 32GB (4 x 8), F4-3200C16Q-32GTZR

    I've tried some of the common fixes for this issue, such as forcing a pagefile dump at shutdown, making sure the maximum memory option is unchecked in the Boot tab of msconfig, and making sure the RAM is installed into the proper channels as indicated by the motherboard manual. BIOS is latest version.

    I will note that I have been unable to find any settings on my mobo BIOS that is/is not allocating memory, memory remapping, allocation to my GPU, etc., nor could I find anything to that effect in the manual of the motherboard. I'm not sure how relevant this is but some online posts have shown this could be an issue. Going into Device Manager and sorting by memory resource usage does show my GPU at the top of the list:

    Click image for larger version. 

Name:	Capture.PNG 
Views:	1 
Size:	45.4 KB 
ID:	151978

    CPU-Z shows all four slots with identical settings:

    Click image for larger version. 

Name:	Capture.PNG 
Views:	59 
Size:	19.4 KB 
ID:	151976

    Going into BIOS shows this; all four sticks are detected, but only 3 are usable/included in the DRAM.

    Click image for larger version. 

Name:	20170904_233858.jpg 
Views:	2 
Size:	1.31 MB 
ID:	151975

    Any help would be appreciated, thank you!
      My ComputerSystem Spec

  2.   My ComputerSystem Spec

  3.    06 Sep 2017 #3

    dalchina said: View Post
    Have you checked/tried everything in those?
    Yes, I have tried all of the common proposed fixes, none of them seem to have worked.

    I am using Win10 Enterprise, which should not have the 16 GB limitation (and my system currently works with 24 out of the installed 32GB). The motherboard/OS/CPU-Z/etc. recognizes all 32 GB installed but only 24GB are listed as usable.
    Maximum memory is unchecked.
    The motherboard does not have a memory remapping feature as far as I can tell, it's likely just enabled by default. There is no iGPU to disable since it's an AMD Ryzen (Threadripper) chip, so there is no integrated graphics.
      My ComputerSystem Spec

  4.    06 Sep 2017 #4

    Has it ever worked with 32Gb or have you recently added RAM?
      My ComputerSystem Spec


  5. Posts : 5,152
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       06 Sep 2017 #5

    I have a year-old Desktop that came with a single 8GB module [single-channel], later on I upgraded to 16 GB [2 x 8GB] and changed the BIOS to dual-channel memory, works good. My Hardware Reserved is showing 84.7MB.
      My ComputerSystem Spec

  6.    06 Sep 2017 #6

    dalchina said: View Post
    Has it ever worked with 32Gb or have you recently added RAM?
    This is a fresh build, all four RAM sticks were added together.
      My ComputerSystem Spec

  7.    09 Sep 2017 #7

    Giving this a bump, any insight appreciated.
      My ComputerSystem Spec


  8. Posts : 2,072
    Windows 7 Pro x64 Windows 10 Pro x64
       10 Sep 2017 #8

    You don`t say anything about a video card, the hardware reserved is for video.

    You need to buy a video card.
      My ComputersSystem Spec


  9. Posts : 585
    Windows 10 Home SL 64-bit, v1803
       10 Sep 2017 #9

    AddRAM said: View Post
    You don`t say anything about a video card, the hardware reserved is for video.

    You need to buy a video card.
    A screenshot on his post says he's got GTX 1080 Ti
      My ComputerSystem Spec

  10.    10 Sep 2017 #10

    Looking at the bios screenshot which is only showing 24576MB as useable I would suggest either a motherboard or ram stick problem, maybe try the A1 A2 B1 B2 combination and see what happens? As its clearly showing a problem in the bios looking at a Windows fix isn't going to achieve a lot.
    Reset bios to default settings? Ryzen boards seem to be a bit problematic regarding memory speeds.
    Could also remove each module in turn and find out which module or slot is causing the problem which would be the one that doesn't decrease the usable memory in the bios when removed.
      My ComputersSystem Spec


 

Related Threads
Common Faults / Fixes List in Installation and Upgrade
Hey Guys, There are a lot of commonly occurring issues appearing in the Installation sub-forum, so please take a look through the list here and see if these can solve your problem before creating a new one! Relevant Tutorials For a Upgrade...
ASUS Laptop with 4 GB RAM (2 slot RAM with each 2 GB) but only 1.6 GB usable & 2.4 GB (Hardware reserved). Even i reinstal this Windows 10 x64, this Hardware reserved still 2.4 GB. What can i do before replace / exchange position slot memory or...
Hardware Reserved Memory 5.5GB in Performance & Maintenance
I have a windows 10 computer that i did a clean install during the free upgrade. Now i went the Task Manager to see that , my hardware reserved memory is 5.5GB. I have a 8GB ram and i can only use 2.5 gb.. How can i fix this?40580
Windows 10 Anniversary Update can crash when you plug in Amazon Kindle
Hardware reserved memory issue in Drivers and Hardware
Hey guys. I have an evga p55sli motherboard and a gtx460 graphics card. I have 8gb of memory installed but in win10 and the bios it only shows 4gb usable. When going into the bios it shows 4096 mb available, and in win10 it shows 4gb usable and 4gb...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:34.
Find Us