Windows 10: W10 doesn't detect external drives when plugging, but does on startup Solved


  1. Posts : 8
    Windows 10 64-bit
       28 Aug 2017 #1

    W10 doesn't detect external drives when plugging, but does on startup


    Hi there!
    Thanks in advance for the help.

    Well, the problem is as simple to explain as the title of the thread sujests: when I plug my hdd drive on a usb, Windows doesn't even detect it (to the best of my knowledge it doesn't even show up on Device manager, even after hitting "Scan for hardware changes"). BUT when I shutdown or restart with the HDD plugged in, it does show up on This PC and is fully functional.

    The problem is exactly the same both for 2.0 and for 3.0 USBs.

    I think I have the latest drivers for everything, installed directly from my mobo manufacturer's page, also through the App Center (my manufacturer is Gigabyte) and through "AMD Software" application (I have a Ryzen 5 1600).
    Even so I'd be more than happy to provide you with the version of any driver you ask. Just want to get this sorted out as soon as possible.

    The only further information I can provide is that it worked at some point, but I don't know when exactly stopped working, because I did a lot of stuff in between.

    Oh, I also used DriverEasy to update some drivers.

    Well, hope I provided the information you need to start helping me and thanks in advance for your help.

    PS: I've just now thought of letting you know that I have Ultra Fast Boot enabled, just in case, even though I don't know if that has anything to do with it.
      My ComputerSystem Spec

  2.    28 Aug 2017 #2

    Try opening a command prompt (Admin) press Enter after each command.

    diskpart
    automount enable
    exit

    See if that fixes it.
      My ComputerSystem Spec


  3. Posts : 8
    Windows 10 64-bit
    Thread Starter
       29 Aug 2017 #3

    Nope, no luck with that unfortunately.
      My ComputerSystem Spec


  4. Posts : 8
    Windows 10 64-bit
    Thread Starter
       29 Aug 2017 #4

    Sorry for doubleposting but I have new information that I assume will come in handy for you guys, and it's weird as **** too.

    I have just plugged a pen and W10 automatically mounted it no problem (I didn't have one in hand previously to try), then I unplugged it to test the hdd drive for magics sake but nothing happened, and now I plug my flash drive and W10 doesn't recognize it. Wtf xD

    It's as if somehow my hdd drive messes with the USBs, I don't understand xD

    EDIT: After restarting I can plug in my flash drive and it work perfectly after removing and plugging it repetedly. It seems it's the hdd that does something weird to the usb ports or something, I wouldn't know.
    Could it be a power thing (voltage)? Though in that case I guess it shouldn't work even if it's plugged in when starting the computer.
      My ComputerSystem Spec


  5. Posts : 8
    Windows 10 64-bit
    Thread Starter
       29 Aug 2017 #5

    So, I'm thirdposting xD

    My external HDD has this format: HDD <- plug in cable -> PC (I mean, you plug it both ways).
    What I was doing all the time: cable already plugged in HDD, and plug it into the pc.
    What I did this time: cable already plugged in HDD, plug it in pc, unplug from HDD side, plug again the HDD.
    Now it works ALL THE TIME.

    I can't even xDDDDDD
    Well, I'll mark this as solved though I still have no idea what was causing this random ass bug xD
      My ComputerSystem Spec

  6.    29 Aug 2017 #6

    Thanks for letting us know how you solved it.
      My ComputerSystem Spec


 

Related Threads
Hello I have a Samsung T3 that worked fine on this pc. I use it for school, I've used it on a few systems. I've googled a lot for this but can't find a proper answer, but feel free to relist the answers since it might help me if I try it...
Hello I have a Samsung T3 that worked fine on this pc. I use it for school, I've used it on a few systems. I've googled a lot for this but can't find a proper answer, but feel free to relist the answers since it might help me if I try it...
My Windows 10 Home laptop will recognize all of my flash drives but won't recognize any of my external hard drives. They all use to show up but now they aren't. The hard drives show up in disk manager but won't show up in file explorer. I hooked...
Hi everyone. I have a MSI GS60 ghost pro gaming laptop which has Intel HD graphics 4600 and Nvidia GTX970M GPU, CPU i7 4720HQ, running Windows 10. I study abroad, several months ago i went back home and plugged-in my laptop to the TV via HDMI for...
My PC performance with Windows 10 is very good except when it isn't :) One of the things that is perplexing me is that my external hard drives seem to be impacting my startup performance. Following start up Task Manager performance tab shows one...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:20.
Find Us