Windows 10: Xbox 360 wired controller has button mapping all fubared. Solved


  1. Posts : 45
    Windows 10 Home 64-bit
       05 Aug 2017 #1

    Xbox 360 wired controller has button mapping all fubared.


    Well lets see my B button is somehow X, A seems to work, back = RB, various other buttons are mismapped, any idea how to fix this? As it is the controller is pretty much unuseable atm. Its a new install of windows 10 home 64 bit, I've already tried the configuration control panel for it, but that doesn't let you edit like the X button and such.
      My ComputerSystem Spec

  2.    05 Aug 2017 #2

    Solved? If yes, what was the fix?
      My ComputerSystem Spec


  3. Posts : 45
    Windows 10 Home 64-bit
    Thread Starter
       05 Aug 2017 #3

    It was the game itself and not the controller, It had weird as hell default button mappings, once I set them to the right ones, it was fine. If its messed up check the button mappings of the game, for example button 3 is X on the controller.
      My ComputerSystem Spec

  4.    06 Aug 2017 #4

    I had a feeling it was something like that. I hardly ever use my XBOX controller on my PC, and when I do its usually to play my XBOX games via the XBOX App.
      My ComputerSystem Spec


 

Related Threads
After update to Creators Update from Anniversary Update, it's a problem with Xbox One Controller, there is no more available 11th "Xbox Guide" button on controller as normal physical button. How to rollback older driver from Anniversary Update...
Hey friends, I've been trying to get an original Microsoft Xbox 360 controller to work on my main desktop PC. I'm running Windows 10 anniversary update, and when I first plugged the controller in, it recognized it, but didn't react at all when I...
As title says. My Xbox One wired Controller works great with all games I have, except for Gears of War. Any suggestion?
The feedback app is littered with reports of games switch between controller icons and mouse/keyboard. From playing with 360ce and durazno if seems to be an issue with deadzones as you can reduce the issue considerably by playing around with them...
when tested in game control settings (windows) RT button have step Acceleration but when test in game Dirt 3, when driving, RT button not have step Acceleration, when I hit the half or full result is the same what is wrong with my controller...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:32.
Find Us