Help identify usb device


  1. Posts : 4,594
    Windows 10 Pro
       #1

    Help identify usb device


    I didn`t have any issues in Device Manager with 1607, but Windows installed 1703 tonight, everything is fine but I found this small issue in Device Manager. Should I just start unplugging usb devices to see if maybe a connected usb device is causing the message ?

    Or does it look like it`s on the motherboard ? Or just a 1703 glitch ?

    Thanks, Brian
    Attached Thumbnails Attached Thumbnails Help identify usb device-capture2.jpg   Help identify usb device-capture3.jpg   Help identify usb device-capture4.jpg  
      My Computers


  2. Posts : 43,417
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #2

    From many years ago I recall this tool - valid for Win 10 - you could give it a whirl- no guarantees, no recent experience of it.
    Download Unknown Device Identifier - MajorGeeks

    also mentioned here e.g.
    3 Different Ways To Find Unknown Devices Drivers In Windows

    Another possibility is to scan using DriverMax, which may reveal sthg useful.

    See this:
    Fix USB Device Not Recognized Device Descriptor Request Failed in Windows 10/8.1/8/7 - YouTube
    - you don't need the audio- the 4 methods are quite well illustrated.

    And of course, you might even notice something isn't functional..
      My Computers


  3. Posts : 4,594
    Windows 10 Pro
    Thread Starter
       #3

    Ya so far everything seems to be functioning, it even says the device has the latest driver, but I'll look into your suggestions :)

    Thanks
      My Computers


  4. Posts : 4,914
    Windows 11 Pro 64 Bit 22H2
       #4

    In the properties go to the Details tab. Under the Property Heading, take the drop down arrow and select Hardware ID. Copy the ID and paste it into Google.
    Other then that, unplug one USB device at a time until the Unknown device goes away, then you will know which one it is.
      My Computer


  5. Posts : 4,594
    Windows 10 Pro
    Thread Starter
       #5

    I think it`s the Corsair liquid cooler usb cable that goes from the pump to the motherboard, because I uninstalled the device in Device Manager and removed the device from Devices and Printers.

    Device Manager now looks normal, but now the Corsair Link software does not show the pump speed, it was working fine with 1607, it also does not show the led logo color changer either, but yet it shows everything else, that is odd, how`s it getting the info if I removed the device.

    I suppose the cable from the pump to the motherboard just sends the pump speed and the led logo info to the motherboard and all the other info is magically sent from the board to the Corsair Link software.

    I connect my radiator fans directly to the PSU, so they don't show up in the software.

    So maybe if I uninstall the Corsair Link software and reinstall it, maybe I`ll get lucky :) Be back soon.
    Attached Thumbnails Attached Thumbnails Help identify usb device-capture.jpg   Help identify usb device-capture1.jpg  
    Last edited by AddRAM; 28 Jul 2017 at 05:00.
      My Computers


  6. Posts : 4,594
    Windows 10 Pro
    Thread Starter
       #6

    spunk said:
    In the properties go to the Details tab. Under the Property Heading, take the drop down arrow and select Hardware ID. Copy the ID and paste it into Google.
    Other then that, unplug one USB device at a time until the Unknown device goes away, then you will know which one it is.
    I thought of that but there was no hardware ID, it would not give it to windows, and maybe that`s why it displayed the descriptor failed message.

    Oh well, no luck I wonder if anyone else has this issue and does not realize it.

    Yep, seems like an issue with the CU.

    Corsair Link doesn't work with Windows 10 Creators Update - The Corsair User Forums
    Last edited by AddRAM; 28 Jul 2017 at 05:03.
      My Computers


  7. Posts : 43,417
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #7

    If so, and if MS knew about it, then theoretically you shouldn't have been offered the CU. But hey, that's theory, and it's been shown MS doesn't succeed fully with this- a Broadcom example comes to mind, and that was known by MS.
      My Computers


  8. Posts : 4,594
    Windows 10 Pro
    Thread Starter
       #8

    All fixed, all I had to do was disconnect the cable from the board then reconnect it :) So it had nothing to do with the Creator`s Update

    The suggestion to do that came from the Corsair User Forum I linked, thanks to all who tried to help, I appreciate your time :)
    Attached Thumbnails Attached Thumbnails Help identify usb device-capture.jpg  
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:09.
Find Us




Windows 10 Forums