Page 1 of 2 12 LastLast
  1.    25 Jul 2017 #1
    Join Date : Jul 2017
    Posts : 6
    windows 10

    Windows 10 doesn't see some Hard Drives


    OK Windows sometimes doesn't see some hard drives. I can take a HDD from another computer that is running windows 10. Put it in another computer and it will not pick it up. The drives are seen in the bios on all computers.

    I sometimes can fix it by making them 2nd boot before the DVD drive. The other thing I can do is use a powered USB adapter that see it. The other thing I'm working on is move everything from the HDD to another HDD. Then delete the partition.

    Then see if windows picks it up. The drive is setup to MBR just like the other two 1TB HDD's I have already in the computer. If it does then there was something on the HDD. That windows doesn't like. If this is true it really isn't windows businesses what I have on the drive.

    I have had this happen from day one of windows 10 launch. Plus on many different computers too. So it isn't just the new computer I just built. I have my computers set up to run 7 & 10. I have no problems with windows 7 just 10.
      My ComputerSystem Spec
  2.    25 Jul 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,077
    Windows 10 Pro Build 1703

    Hi dmdilks. Welcome to the TenForums @dmdilks

    When you put the HDD from one system into the other system, your newly built system, you say windows does not see the drive. Are you trying to boot from it?

    Are you looking in disk management or file explorer when you say Windows can't see it?

    If file explorer please open up disk management and see if it is there. If it is there, under disk management, you may just have to assign drive letter.


    Ken


    Ken
      My ComputerSystem Spec
  3.    25 Jul 2017 #3
    Join Date : Aug 2016
    S/E England
    Posts : 4,520
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by dmdilks View Post
    OK Windows sometimes doesn't see some hard drives....
    Welcome to TenForums @dmdilks


    Where in Windows 10 are you looking? In File Explorer? Try looking in Disk Management instead, you may well find your 'missing' drive is seen there. You can't see a drive or partition in File Explorer until it has a drive letter assigned to it. In Disk Management you can do that, just right-click on the partition you want to give a letter to...
      My ComputersSystem Spec
  4.    25 Jul 2017 #4
    Join Date : Jul 2017
    Posts : 6
    windows 10
    Thread Starter

    To both of you it doesn't show up in Disk Management. I have a new Ryzen with Gigabyte board it shows up on this computer windows 10. I have a older gigabyte 1366 board same thing it shows up in there windows 10.

    On the new computer X266 with a Gigabyte board it will show up using a power USB adapter. If I connect it with a sata cable and no matter what port either it doesn't show up. Plus it is showing up in the bios too.

    One thing I haven't check to see on the OS what the are on the other computers are setup on the SSD's MBR or GPT. The X266 SSD's is setup to GPT. I have even deleted the partition to see if it picks it up as a new drive still nothing. One other thing I'm going to try is connect it back to the USB and format that way and see what happen.
      My ComputerSystem Spec
  5.    25 Jul 2017 #5
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,077
    Windows 10 Pro Build 1703

    When you connect are you putting device to sleep or are you "Hot Swapping". If the later I believe you have to enable the feature in BIOS.

    If you are not connecting during sleep or "Hot Swapping" when are you connecting device.

    When you connect drive if you go into device manager and on the row of icons, (topof window below menu items) select the right most "Scan for hardware changes". Does drive show?


    Ken
      My ComputerSystem Spec
  6.    25 Jul 2017 #6
    Join Date : Jul 2017
    Posts : 6
    windows 10
    Thread Starter

    It has to be the drive because I can remove it and connect another drive and windows picks it up. The funny part is it works fine in two other computers with windows 10. At this time I doing a full erase on it with the WD software to see if that fixes it.

    For some reason on the X299 with windows 10 doesn't see it. Plus all the drives are setup the same in the bios. The only difference between the 3 computers is the X299 is running a M2-SSD. Where the other two have reg SSD's. Plus I'm running the M2 in the right port so I only lose one sata port.
      My ComputerSystem Spec
  7.    25 Jul 2017 #7
    Join Date : Jul 2017
    Posts : 6
    windows 10
    Thread Starter

    OK I did the full erase on the drive and now it works on the new computer. There had to be something on it that this new computer and windows didn't like. So if any body does have a problem like this do what I just did. The thing is the drive was always use for storage.
      My ComputerSystem Spec
  8.    25 Jul 2017 #8
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,077
    Windows 10 Pro Build 1703

    Excellent. Could you mark thread solved so others will find, folks like reading threads that are solved.
      My ComputerSystem Spec
  9.    26 Jul 2017 #9
    Join Date : Jun 2015
    UK
    Posts : 2,101
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    It seems your problem is solved but you might have tried this fix.
    Open an Admin command prompt then press Enter after each command:

    diskpart
    automount enable
    exit
    exit
      My ComputersSystem Spec
  10.    26 Jul 2017 #10
    Join Date : Jul 2017
    Posts : 6
    windows 10
    Thread Starter

    @ Steve next time I'll try thanks for the tip.

    Thanks for all the reply's. But I have been doing this for over 35 yrs. Plus Gigabyte has had their problems with hard drives on the X99 boards. There are a lot of people having the same problem when I did some research.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
How to set up new Windows 10 Pro PC with separate hard drives
From my latest posts you can see I've had my share of issues to deal with and thanks to you all here and other communities, I've managed to power through unto workable solutions. Still, the stress, hassle and too many hours lost to PC maintenance...
General Support
Start > Windows doesn't search for files in other hard drives
When I search for programs on the search function when you hit the windows button it only searches for files found on the same harddrive I installed Windows on (C: SSD 120GB). I have all my other files, pictures games movies etc on my E and F...
General Support
Flash drives recognized but external hard drives are not
My Windows 10 Home laptop will recognize all of my flash drives but won't recognize any of my external hard drives. They all use to show up but now they aren't. The hard drives show up in disk manager but won't show up in file explorer. I hooked...
Drivers and Hardware
Windows 10 Pro and External Hard Drives...
Hello, I recently bought a new PC with win 10 pro on board. I was disappointed to find that my Sabrent Dual Hard Drive bay as well as my Inateck external hard drive cable are not recognized by my laptop, a Lenovo Thinkpad. I had no issues with...
Drivers and Hardware
Heat doesn't kill hard drives. Here's what does
Read more: Heat doesn't kill hard drives. Here's what does | ZDNet
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:42.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums