1.    23 Jul 2017 #1
    Join Date : May 2016
    Posts : 20
    windows 10

    Lenovo w520 upgraded to windows 10 does not recognize any cam


    I have a Lenovo Laptop W520 which I upgraded 2 years ago from the original Windows 7 to Windows 10
    No cam problems at all - ie the Lenovo cam worked with Windows 10
    10 days ago the internal cam not recognize (see pic #1)
    Soon after I noticed also USB external Logitec 9000 web cam also not recognized on laptop (updated drivers installed for windows 10 and this cam works on another computer )

    Microsoft says now after removing and re-installing driver - that it will never work because the Lenovo drivers are only for windows 7. But it worked just fine until 10 days ago on windows 10 Click image for larger version. 

Name:	No cam error.jpg 
Views:	8 
Size:	46.1 KB 
ID:	145317Click image for larger version. 

Name:	Lenovo SN and Machine Type.jpg 
Views:	26 
Size:	30.8 KB 
ID:	145319Click image for larger version. 

Name:	Lenovo Web Cam driver (NOT windows 10).jpg 
Views:	5 
Size:	111.5 KB 
ID:	145320

    Microsoft says they cannot help because driver is only for windows 7 (even tho it worked for 2 years)
    Lenovo says they cannot help because they are not planing any upgrade for this integrated web cam to windows 10

    I tied unsuccessful restore - I tried returning to previous windows 10 build Nada

    Microsoft is now suggesting I return completely to windows 7 but I will loose all of my data programs links etc etc

    can I fix this myself?

    Is there anything I can do to FORCE my laptop to recognize the internal cam or a logitec cam?
    Perhaps a driver that is not exactly made for this computer but will force it to recognize the cam?
    Last edited by Shlaymeh; 24 Jul 2017 at 04:42.
      My ComputerSystem Spec
  2.    23 Jul 2017 #2
    Join Date : Jun 2014
    USA
    Posts : 1,603
    Windows 10 Pro x64

    Hi, Shlaymeh, unfortunately this is a perfect example of why it is a good idea to check for drivers prior to updating an OS.

    With that, what Microsoft is saying is that even though the camera worked under previous versions of Windows 10, Lenovo themselves never supported that notebook under Windows 10 and therefore provide no drivers for the OS. BTW your qualm would be with Lenovo, not Microsoft since vendors are responsible for their own specific device drivers.

    And before you get mad at Lenovo, realize they aren't the only PC vendor to do such things... Asus never provided Win 10drivers for my 2013 Ultrabook, even though I upgraded the notebook from Win 8 to 10. Fortunately I ran into no real issues since the notebook was built for Windows 8.

    Anyway, if you really want to keep Windows 10, but need a camera, you could try looking for a newer model with Windows 10 support. Otherwise you'll have to revert back to Windows 7 in order to get things working as they should.

    Sorry.
      My ComputersSystem Spec
  3.    24 Jul 2017 #3
    Join Date : May 2016
    Posts : 20
    windows 10
    Thread Starter

    So why did it work for 2 years!?


    I would like to pursue the fact that the internal cam and also the external Logitec cam DID work for 2 years under Windows 10 (even tho the drivers are only for Windows 7 and were never supported by Windows 10)

    Is there a way I can return to a specific build of Windows 10 that will not necessitate starting over with a brand new clean windows 7 For obviously there was a version of windows 10 that worked with the Lenovo Cam and the Logitec Cam?

    I myself tried to go back to a previous build of Windows but that in and of itself did not help?

    Lenovo has NO plans of updating the drivers to work with windows 10

    Is there another driver I can use instead? Perhaps a universal driver or something?

    I loath the idea of loosing all of my data and set ups and links
      My ComputerSystem Spec
  4.    24 Jul 2017 #4
    Join Date : May 2016
    Posts : 20
    windows 10
    Thread Starter

    To be super clear -
    1 The Logitec cam worked well on the lenovo without special windows 10 drivers until 10 days ago.
    2) The Logitec cam now works well on other computers
    3) The logitec cam does not work now on the Lenovo - just as the integrated cam does not work now.
    4) Even after updating the Logitec drivers to windows 10 - it does NOT now work on the lenovo


    I would like to understand why and perhaps take advantage of the reason to perhaps find a way to force my W520 to accept a previous windows 10 build or driver that will cause it to work.

    HELP
      My ComputerSystem Spec
  5.    24 Jul 2017 #5
    Join Date : Oct 2016
    Charlotte, NC
    Posts : 448
    Win10 Home x64 - 1709

    10 days ago the internal cam not recognize (see pic #1)
    Have you looked in Device Manager ...
    1. See if you can roll back the driver ?
    2. What exclamations it might be showing ?
    3. Would help to know what drivers are currently installed for each (Provider / Date / Version) ?
      My ComputersSystem Spec
  6.    25 Jul 2017 #6
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,048
    Windows 10 Pro

    As has been stated, Press the Windows key+X and choose Device Manager.
    Here, do you have a listing for Imaging Device? Do you have any devices with yellow exclamation marks? If so, right click them and Uninstall them. Then right click Any device and choose Scan For Hardware Changes. This should start the new hardware found. If you need your Logitech driver, then use the install CD or download from Logitech
      My ComputerSystem Spec
  7.    25 Jul 2017 #7
    Join Date : May 2016
    Posts : 20
    windows 10
    Thread Starter

    Apparantly problem solved - but WHY?!


    I worked with a Microsoft tech who did exactly what you suggested - but I believe she was not the first to try this uninstall - re-install. And of course re-boot. So we all immediately "knew" the problem was still not solved because of this: Click image for larger version. 

Name:	Cant start your camera.jpg 
Views:	4 
Size:	35.3 KB 
ID:	145606

    This app notice was always used at each step by everyone to "prove" the cam was still not working.

    However when looking again for the yellow triangle warnings in the device manager - basically to show those error messages to you - I noticed suddenly that they were all missing! So I tried the cam again and .... walla it worked. Even tho I was still getting this app error notice.
    I pointed this out to Microsoft and they tried to update this app - but that had no effect on the error message so far.

    So I am still getting this cam app error - yet the cam is now working - but then again - what do I care?
    How did this get fixed?
    I noticed this new situation after an automatic windows update that automatically caused my computer to re-boot.

    So I am not sure if it was the update OR the driver uninstall/reinstall

    One thing I am sure of is this: All those experts (Microsoft - Ten Forum - and Lenovo) They ALL stated categorically that there is NO WAY the cam will ever work because the driver was not made for windows 10 - only windows 7. They all were wrong (no complaints here) and the only tech who got it right and fixed the problem was the Microsoft tech who didn't know what the experts "knew" and just tried to uninstall / reinstall the drivers (or more exactly - uninstall the error message drivers and just let windows boot and re-install by itself!)

    OR the automatic update caused the windows 7 cam drivers to work with my present windows 10

    Any ideas?
      My ComputerSystem Spec
  8.    01 Aug 2017 #8
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,048
    Windows 10 Pro

    Even tho the cam is working just fine now - I am still extremely curious as to why.
    As I stated in my first post - the cam was working for two years after the windows 10 upgrade - even tho the drivers only fit windows 7 (if it was improper drivers - the problem should have appeared right away - no?)
    Was it the uninstall - re-install of those drivers by the Microsoft support tech? And then the problem was solved even though we didnt realize it because of the faulty notice which was later confused with the subsequent similar notice:
    Possibly the "cant find" was confused with the "cant start" and the cam was actually working much earlier than I thought.
    Or was it a regular update of windows 10 (that caused the computer to reboot) - for I suspect the problem also began subsequent to an earlier update and automatic re-boot 10 days earlier. Thoughts?
    It is hard to say, if the MS Tech uninstalled the driver, then Reinstalled it, they should have checked in the Device Manager to see if there were any yellow marks. If they did you would know if it was the tech, or Windows Update that installed the correct driver.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Why won't Windows recognize I have Powerpoint?
I have Microsoft Office 2010, I can open Word and Excel files by clicking on them but not Powerpoint, it wants to send me to the app store. I can run the Powerpoint program and open it from within. In Settings - Choose default apps by file...
Software and Apps
Windows 10 won't recognize VGA monitor
I have connected my new HP / Windows 10 laptop up to my VGA monitor (which worked with my last laptop under Windows 7). The monitor is not recognized by anything under the Control Panel or Windows + P or display preferences or anything I try. ...
Graphic Cards
Solved Upgraded to Windows 10, won't recognize as owner, settings dont save
Hi guys, I just upgraded from win7 to win10. Smooth upgrade, but I noticed all my textfiles on my desktop and sticky notes from win7 disappeared. So I decided to restart my pc. What I noticed is on the bottom right of the screen as I reboot, it says...
User Accounts and Family Safety
Windows 10 does not always recognize MP4 files
Sometimes the video streams, other times I get the message ... Can't play. Try playing something else. This items file format may be unsupported, the file extension incorrect, or the file may be corrupted 0xc00d36c4 (0xc00d36c4) I know that...
General Support
upgraded to win 10 on Lenovo G50
I upgraded on Thursday and it took over 5hours. during the process (of course) the Lenovo programs went. Not a great problem but I could not get the win 10 apps, edge, store and window pane search to work. Went down the reinstall route which worked...
Windows Updates and Activation
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:24.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums