Windows 10: sound blaster on build 10240

Page 1 of 2 12 LastLast
  1.    25 Jul 2015 #1

    sound blaster on build 10240


    I cannot get my surround 5.1 audio to work with this most recent build of 10240; and i cannot get into the enhancements that are supposed to be available for my card which is the x-fi titanium pci express sound card from creative. Is there any way to resolve this or do I just have to wait until creative gets off their rumpus and puts out the new drivers and software?
      My ComputerSystem Spec


  2. Posts : 8,801
    Windows 10 Pro X64
       25 Jul 2015 #2

    Matt, maybe the ones shown here will work for you.

    http://www.overclock.net/t/406538/yo...d-x-fi-drivers
      My ComputerSystem Spec

  3.    25 Jul 2015 #3

    Thanks dude. I will try that later on when I have a chance.
      My ComputerSystem Spec

  4.    25 Jul 2015 #4

    Dude; none of those links in that link you posted above work. I cant download any drivers from those links.
      My ComputerSystem Spec


  5. Posts : 8,801
    Windows 10 Pro X64
       25 Jul 2015 #5

    Wow, just noticed the date on those threads too. I will look around. Here is some more recent talk, but a quick read does not show if it will work with W10

    http://www.hardwareheaven.com/commun...fi-series.181/
      My ComputerSystem Spec

  6.    27 Jul 2015 #6

    Any luck on finding any other resources to solve this issue dude? Cause ive tried searching and so far no luck in finding anything. Its really odd; for some reason my audio was working fine in the previous build(s); but now in this 10240; Ive got jack squat even after uninstalling it from device manager and then rescanning for new hardware; it installs it; but all Im getting from my speakers is a high pitched whine like tone and very very faint windows system sounds; and no its not my speaker setup thats the issue as it worked just fine in some of the older insider preview builds.
      My ComputerSystem Spec

  7.    27 Jul 2015 #7

    Here's a list by Creative of supposed driver updates for various cards for Windows 10.

    Don't have a lot of faith or trust in Creative though as they've always had crappy driver support for their products and instead choose to release "new products" instead of supporting the old ones under new operating systems.

    Anyway hopefully they'll release some workable 10 drivers for my ZxR card in August as advertised on that list. Fingers crossed.

    Peace
      My ComputerSystem Spec


  8. Posts : 2,289
    Windows 10.3 Home 1703 x64 (Home per choice)
       27 Jul 2015 #8

    Official drivers do not work, I have used unofficial to get all the features working on mine.

    Find yours on their forums, maybe this one: SB X-Fi Series Support Pack 3.4 (07/08/2015)
      My ComputerSystem Spec

  9.    27 Jul 2015 #9

    TairikuOkami said: View Post
    Official drivers do not work, I have used unofficial to get all the features working on mine.

    Find yours on their forums, maybe this one: SB X-Fi Series Support Pack 3.4 (07/08/2015)
    The new "official" drivers haven't been released yet so we don't know if they'll work

    But yes, if you need something now, I suppose those may work
      My ComputerSystem Spec


  10. Posts : 2,289
    Windows 10.3 Home 1703 x64 (Home per choice)
       27 Jul 2015 #10

    Creative takes sweet time to release any drivers, as for the older hardware, it is more like never.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Solved No sound from sound blaster in Drivers and Hardware
I just installed the most recent windows 10 tech preview last night; but my sound blaster pci express sound card did not get installed correctly or something because i am getting no sound at all. Please help me fix this before I roll everything back...
I am currently running Windows 10 Build 9926 due to having issues installing Build 10162 using a USB. I had Build 9926 installed before and successfully updated to 10162 however a failed graphics driver install forced me to reinstall and since...
Solved sound blaster in build 10166 in Drivers and Hardware
I can not get my sound blaster x-fi titanium pci express sound card to give me sound through the right channels even though Ive uninstalled the support pack for 5.1 surround audio that was compiled from another sb user that did work in the last...
sound in build 10041 in Windows Insider
Is there sound yet in build 10041? (Realtec driver update)
No Sound after Build 10041 Update in Windows Updates and Activation
Sound on Build 10041 was working until after the recommended update - resolved by rolling back the drivers. Why provide an update which obviously isn't compatible with my system. uSoft just can't be trusted.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:48.
Find Us