Windows 10: [Desktop PC] UPS Connected, "Your battery is very low" every boot

  1.    13 Jul 2017 #1

    [Desktop PC] UPS Connected, "Your battery is very low" every boot

    TL/DR: This happens during boot when connected to a UPS, I'd like to stop it. =\

    Recently decided to connect a UPS (CP1500PFCLCD) to my PC that way it can auto hibernate if there is a power loss. I ran into a annoying bug though.

    Whenever I restart Windows takes 5-10 seconds to read the battery level (initially reporting 0%). And during this time it pops-up a fullscreen message and a broken explorer window that can only be closed by Alt+Tabing and clicking the X (see attached).

    Additionally also drops my PC into battery settings during the last phase of startup making every boot take about 10 seconds longer (it will stay on the battery powercfg settings until it is able to read the battery level).

    Steps tried: Googled the *insert expletive here* out of it. Disabled all notifications, Disabled Action Center and Un-hid all powercfg settings looking for a way to disable the Critical Battery Notification (the only one that exists is the Low Battery notification).

    P.S. I really don't care about ever seeing the critical battery notification, either I'll be at the PC during power loss and will shut down immediately or I won't and it will auto-hibernate. - As for switching to battery settings during boot, I guess I can change those to match the AC settings.
    Attached Thumbnails Attached Thumbnails Windows_10_UPS_Boot_Crap.jpg  
      My ComputerSystem Spec

  2.    13 Jul 2017 #2

    Are you using the Cyberpower PowerPanel application for the UPS or the built in Windows app? I have a Cyberpower and use the PowerPanel application and no problems. I have had two Cyberpower UPS over the years and never had an issue with low battery alert unless there was an actual problem.
      My ComputersSystem Spec

  3. Posts : 4,604
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       13 Jul 2017 #3

    I've gotten such warnings on both APC and Tripp-Lite UPS', replacement of the battery were the solution. I have had a couple of each fail after a few years that required replacing the whole unit.
      My ComputerSystem Spec

  4.    13 Jul 2017 #4

    The battery is a USB HID device, it doesn't need any drivers or a app. You can download the Cyberpower app, but it doesn't offer any extended functionality (well extended over what you can do with the buttons and the power control panel).

    I pulled out the batteries and checked their voltage and water level last night, both were fine. I'll run a full load battery test later tonight (have to round up some stuff that can draw 900W total).

    Anyway, thank-you guys for the reply's but to clarify this only happens until Windows goes "Hey whats the battery level" during startup. Once it see's the battery level is 100% the icon goes to normal. -- I can even hot-plug/ the UPS (USB connection) after Windows is started and it comes up as 100% right away (making me think this is a Windows bug, hence looking for a workaround).
      My ComputerSystem Spec

  5. Posts : 4,604
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       13 Jul 2017 #5

    One thing you might check is the USB ports. I'd use only the USB 2.0 unless the UPS specifies USB 3.0 and I'd check the BIOS that Legacy USB is Enabled and also check the power options in Control Panel to assure Windows isn't turning the USB ports off in the interest of saving power.
      My ComputerSystem Spec

  6.    13 Jul 2017 #6

    I would use the Cyberpower Power Panel app. Its unobtrusive and does not affect PC performance. I also use my PC for my recording studio and the Cyberpower does not interfere or cause any issues with the Replendence Latency Mon application.

    You should at least try it and see if you still get the battery notice with that program.
      My ComputersSystem Spec

  7.    16 Jul 2017 #7

    I have a solution. - It involves creating a custom task to disable the UPS Device during shutdown, reboot and hibernate. And re-enabling it 10 seconds after the system comes back online. It's a really stupid hack, but it should work. I'll post back in a few days once I make the tasks and test them.

    I might contact Cyberpower and hope they can with Microsoft (they're a huge UPS supplier). My reasoning on this is a single user filing a bug report using the feedback app will be ignored.

    Info/Stuff I tried:
    • Battery test passed and also ran fine under 50% load for almost the rated time.
    • Installing the Cyberlink app fixes the issue, but that is like installing a 3rd party WiFi network utility. I'd rather stick with windows power management.
    • All ports on Z87+ are routed through the xHCI controller, if there is a EHCI controller it is not exposed on any of the boards I've worked with. You do have the option to force the xHCI controller to run in EHCI mode but it's still a xHCI controller in the end.
    • Digressing a bit, I tried switching the controller port routing mode from Enabled (Pure xHCI) to Auto (All ports start as EHCI) and to Smart Auto (Board will remember what ports need xHCI/EHCI). -- This didn't help, and it's not worth disabling USB 3.0 completely, so I didn't test that.
    • As for Legacy USB Support and EHCI hand-off, those are for UEFI apps or Old OS's. The MB passes control of the USB controller('s) to the OS and the OS re-initializes everything. But for completeness I did flip both of them on/off.
    • Lastly I passed through the UPS to a Windows 10 VM, the same thing happens in the VM (and the VM only emulates USB 2.0).
      My ComputerSystem Spec

  •    09 Dec 2017 #8

    I have the same problem (Low batttery waning every few minutes) but it is because my laptop battery is bad and will no longer take a charge. I need to have it plugged in all the time, but it works fine for my use case. The notice started coming up after the "Fall Creator" update was applied. I would simply like to disable the alert/notification. I have look for setting and have turned off some, but can't seem to find the way to disable this.

      My ComputerSystem Spec

  •    09 Dec 2017 #9

    Your problem is unrelated to the UPS Battery problem. Do not try to revive and hijack an old thread. Start a new thread.
      My ComputersSystem Spec


    Related Threads
    I had to buy a new (SSD) HD and had trouble booting from a disc until I enabled Legacy Mode and disabled Secure Boot in BIOS. Now whenever I boot up I get a "No Boot Device Found" message until I hit "Enter" at which point i'm allowed entry into my...
    Hi there Clean install from Windows Media creator -- on a VM though Any idea why I'm getting in Searching for Display Driver -- a message about "Battery Life" -- this is on a Desktop (actually a Micro server). 77475 I need to install...
    hey guys I have a possibly terminal case here I've worked on and cannot resolve. Brother's Acer desktop running windows 7 64-bit, he took the bait and switched to windows 10, and he is not a technical guy. It ran into a bad device driver...
    Greetings. So, I would like to remove "Paste shortcut" and "Undo delete" from the right-click desktop menu. Wasn't able to locate either in the registry.
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 04:48.
    Find Us