1.    12 Jul 2017 #1
    Join Date : Jul 2017
    Posts : 3
    Windows 10 Pro

    Windows asks to format USB Drive when SD card is inserted


    I have SD card with Raspbian OS on it. When I insert the card using the card reader adapter, Windows asks me to format the E:\ drive, and it shows two different drives where it supposed to be just one (the boot with Raspbian OS on it). Recently it also shows the message: "Location is not available E:\ is not accessible. The parameter is incorrect." but the boot is on I:\ drive and this E:\ drive should not even exist.

    - When I format E:\ drive it shows empty E:\ drive and full boot on I:\ drive. When I eject the boot drive, both drives disappear, however, the I:\ (boot) drive is no longer working properly. (does not boot the OS on raspberry pi)

    - When I reinsert the SD card it does not show me any errors. When I then format the SD card (I:\) boot drive, the E:\ drive disappears and I'm left just with I:\ drive. (when I put fresh Raspbian on I:\ drive, the error to format E:\ shows up again)

    - When I put some files onto the SD card it does not seem to show any other drives when I eject and reinsert.

    It is only happening when I have an image located on the SD card.

    I tried:

    • Different USB ports
    • Different SD card readers / adapters
    • chkdsk /F /R /X I: (from the command line)
    • chkdsk /F /R /X E: (from the command line (is says that the file system is RAW))
    Last edited by uzier; 12 Jul 2017 at 07:23.
      My ComputerSystem Spec
  2.    12 Jul 2017 #2
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,399
    Windows 10 IoT

    Ignore the message, its because Windows can't natively see the second Linux Partition. You'll only be able to see the fat 32 Boot partition in Windows. If you want full access you'll need to install a third party program that handles Linux Partitions in Windows. I had a link to one I was going to try but can't find it at the moment. If you format the drive/card in Windows it won't work in your Pi anymore and you'll have to reimage it.
    What are you wanting to do with the card? Reclaim it for use with Windows? Or modify some of the Raspbian files. The config.txt file is on that boot partition and can be edited with notepad in Windows. There is a lengthy Raspberry Pi thread in the chillout room if your interested. The Raspberry Pi Thread [3]
      My ComputerSystem Spec
  3.    12 Jul 2017 #3
    Join Date : Jul 2017
    Posts : 3
    Windows 10 Pro
    Thread Starter

    alphanumeric, thank you for the response. On a fresh install of Windows 10, or previous versions of Windows, when I inserted the sd card it just showed the drive and the files which would be booted on Raspberry Pi (linux). Now it does not behave as expected. Normally you would insert SD or USB or CD or anything and you can look into it and see what's on that drive without any previous error messages. Mine is always trying to format the drive when I insert the SD card, I just do not want to see these multiple error messages each time I insert SD card. I perform multiple SD backups daily and these are critical, sometimes I accidentally format the SD card as the message appears straight in the middle of the screen when I insert SD card. Is there a way to repair it? It happens after latest update of Windows 10 (PS. this does not happen on any other PC in my company when I do the same operation). From what you said it seems like Windows need to ignore Linux system partition how do I disable that?
      My ComputerSystem Spec
  4.    12 Jul 2017 #4
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,399
    Windows 10 IoT

    I've always seen that message with my Raspbian SD cards, and just ignore it. If you insert a normally formatted SD card (one not used for Raspbian etc) you won't see that message. If I corrupt one of my Raspberry Pi SD cards I just reimage it with a backup or new image. NOOBS, and KODI Raspberry PI cards will through up the same error. It's just because Windows doesn't like the second Linux partition on the card. If your trying to reuse one of your SD cards for storage etc, you need to wipe it clean and repartition it. Do that, which will remove the Linux partition, and you won't get any more error messages. The SD Card Formatter will do it for you. https://www.sdcard.org/downloads/formatter_4/ Or just plug it into a camera and format it via the cameras menu system.
      My ComputerSystem Spec
  5.    12 Jul 2017 #5
    Join Date : Jul 2017
    Posts : 3
    Windows 10 Pro
    Thread Starter

    alphanumeric, I do not understand why it happens on certain PC's like yours and mine and not on others, if they run the same configurations and system versions, and why If I format none existing E:/ drive it still shows 2 drives, only when I repartition or format boot as you said then I get one, but when I put Raspbian on it, it shows me two drives again. And I do not understand why I did not have this issue 10 days ago and I have been doing this operation for 5 years never had an issue and suddenly now I do.
      My ComputerSystem Spec
  6.    12 Jul 2017 #6
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,399
    Windows 10 IoT

    It happens to me on any PC I plug that SD Card into. Except my Raspberry Pi. If I plug it into my Pi I get two prompts to open in file manager. One for each drive. Clicking format may be just formatting the Fat 32 partition, which won't get rid of the message. I've never done it myself, not that I can remember. Just doing a format will not repartition the drive, it just formats the existing partition, the Fat 32 one. Deleting all partitions lets windows use the full drive with just the one partition.
      My ComputerSystem Spec
  7.    12 Jul 2017 #7
    Join Date : Aug 2016
    S/E England
    Posts : 4,477
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by uzierek View Post
    ... I do not understand why I did not have this issue 10 days ago and I have been doing this operation for 5 years never had an issue and suddenly now I do.
    Could it be that you got the Creators Update 10 days ago?

    A little advertised change is that Windows 10 will now access multiple partitions on a standard usb flash drive.
    CU supports multiple partitions on a standard USB Flash Drive
      My ComputersSystem Spec
  8.    12 Jul 2017 #8
    Join Date : Jul 2015
    Posts : 9,329
    Windows 10 Pro

    Quote Originally Posted by Bree View Post
    Could it be that you got the Creators Update 10 days ago?
    That's true. Windows versions before the Creator's update would only see the first partition on the card, and if the first partition was FAT32, no error because it would not even see the second partition on the SD card.
      My ComputerSystem Spec
  9.    12 Jul 2017 #9
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,399
    Windows 10 IoT

    As far as I know I I've been getting that error message since I first started using My Raspberry Pi? Unless my mind is slipping? Anyway, my advice is still to just ignore it.
      My ComputerSystem Spec
  10.    12 Jul 2017 #10
    Join Date : Dec 2013
    Sydney, Nova Scotia, Canada
    Posts : 10,399
    Windows 10 IoT

    I also get a "There is a problem with this drive, scan it to fix it" message when I plug a thumb drive in that I have used on my raspberry Pi. I also ignore it. Those thumb drives only have the one fat 32 partition on them. Maybe that's the one I've been getting from day one? Starting to second guess myself now. Sucks to get old I guess, lol. I'm so used to just ignoring the message I don't read it anymore. I just close the message window.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
MicroSD Card drive cant open and cant format
Hey guys, I have ADATA MicroSD Card 64GB and it was working fine yesterday and I decided to format it. It does format good but I run quick format again and than its showing me the error below. 133598 Regards.
Drivers and Hardware
Solved Problem showing SD cards when inserted in card reader
Here's the thing: I have a multi card reader which has been working fine until the Anniversary Update. Now, when I insert an SD card, Windows doesn't show the card mounted. It remains as a hidden object which can only be viewed when I activate...
General Support
windows cannot complete format of usb flash drive
I have a 1TB usb flash drive that was Ex-Fat32 formatted. I want to put my System images for my laptop and desktop on this drive and when I try to format the drive to NTFS I get the same error every time "Windows could not complete the format of...
Drivers and Hardware
Inserted win10 boot USB flash drive to working Win10 system - problems
OK, maybe this was really stupid. I had a 32GB flash drive formatted with the Win10 media upgrade image on it (bootable). I was going to use it to upgrade another system but in the meantime I wanted to copy some programs between two systems. I...
General Support
Solved Windows 10 Pro (Format the Factory Restore drive D for other uses?
I Bought an HP Pavilion Slimline (s5310f) computer in 2010 with Windows 7 Factory installed OS. Than I upgraded to Windows 7 Ultimate OS. Installed Windows 10 Pro. I deleted Windows/OLD. What is in the Factory Image that shows up...
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:52.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums