Thanks Kbird. I have printed your suggestions for the next board. Actually, I returned the GA-AB350-Gaming & purchased the GA-AB350-Gaming 3 model as they are both the same price now + I didn't want to wait for an exchange that would turn around in a weeks time.

The whole swap was a nightmare. Not the installing but the "what to do, what's wrong" queazy feeling. After everything was installed I had only C: drive plugged in. The PC seemed to need a couple of on/off/on again to get to the selection screen for BIOS. All looked okay in BIOS. Fans were working, RAM was recognized correctly so I booted. Went thought the on/off/on again & finally got to the desktop. All seemed okay there. I took care of the Windows 10 product key having to call to India to do it. Then restarted.

Once again on/off/on again issue & finally went into BIOS to see what might be wrong. I've never worked with this type of BIOS before where the mouse is active. What struck me odd was, now that my other drives were plugged in, the boot drive was mis-identified for some reason & I could not "select" the correct drive to change it. I shut the PC down. When I looked up the specs it said there are 6) SATA slots on the board. True but two faced towards the front of the case & two were identified as ASATA. I assumed they were all backwards compatible (?).

Click image for larger version. 

Name:	board.jpg 
Views:	10 
Size:	71.6 KB 
ID:	143391

I finally got it to boot again & then read about new versions of BIOS thinking that might be my issue. At the Gigabyte website they recommend installing their APP Center. I found a download, installed & opened & it immediately indicated a newer version was available. Well, okay? Installed that then the APP Center wouldn't open stating a driver error. Couldn't uninstall completely either.

Gave up on the APP Center & tried to Q-flash in BIOS per their instructions. Got to about 90% & it suddenly it said it would reboot but when it did it was lost again. Eventually got to the desktop but after shutting down, I was unable to boot until I pulled the board battery & waited 20 minutes. After a few more on/off/on it did boot but failed after that no matter what. Perhaps @BIOS from the desktop is better. (?)

I do have Gigabyte's phone number now & will check with them for help as there were so many times I wasn't sure what to do. New board will be here mid-week for round two!