Windows 10: Not recognising any USB devices Solved

Page 5 of 6 FirstFirst ... 3456 LastLast
  1.    10 Jul 2017 #41

    OK, I might have missed it, but did you go into BIOS and make sure the USB ports are enabled ?
      My ComputersSystem Spec

  2.    10 Jul 2017 #42

    Idea - I am running W10 64bit. So maybe Gigabyte doesn't support 64bit?
      My ComputerSystem Spec

  3.    10 Jul 2017 #43

    According to Gigabyte Support it does. Version 4.90A
    GA-970A-DS3P (rev. 1.0) | Motherboard - GIGABYTE
      My ComputersSystem Spec

  4.    10 Jul 2017 #44

    Eagle51 said: View Post
    According to Gigabyte Support it does. Version 4.90A
    GA-970A-DS3P (rev. 1.0) | Motherboard - GIGABYTE
    Wait. But this link shows me audio drivers. What do I need audio drivers for?
      My ComputerSystem Spec

  5.    10 Jul 2017 #45

    Ooo. Now I got it. I had a wrong driver. Ok, I'll get the right one and rapport
      My ComputerSystem Spec

  6.    10 Jul 2017 #46

    The USB3 Drivers are there also.
      My ComputersSystem Spec

  7.    10 Jul 2017 #47

    I've got no idea what's going on here. I downloaded driver, the right one(at the top of the installer even reads "VIA XHCI HOST Controller Software Package V4.90A" and I have the same stop message.
      My ComputerSystem Spec

  8.    10 Jul 2017 #48

    Sorry you're having so much trouble with this. The only thing left I can think of is to ...
    1. Go into BIOS and make sure the USB3 ports are enabled (you never did say if you did this)
    a. XHCI-Handoff (default is enable)
    b. EHCI-Handoff (defalut is disabled)
    2. Install the Chipset Drivers for your motherboad from the gigabyte site (if you haven't already)
    3. Then try and install the VIA USB3 drivers.
      My ComputersSystem Spec

  9.    10 Jul 2017 #49

    I will, in a minute, but my point is.... why??? Why this god damn W10 do this???? One day it works, the next one it doesn't. And if I would change something in my system, I would get it. But I haven't! That's the part that's bugging me the most.
      My ComputerSystem Spec

  10. pepanee's Avatar
    Posts : 1,052
    Windows 10 Professional
       10 Jul 2017 #50

    Who knows. Maybe (with today's technology) your motherboard experienced some difficulty with a USB device and maybe decided to automatically disable all your USB devices. So it's a good idea to take a glimpse at the BIOS setiings. It's also a really good idea to check in there because Windows 10 sees your USB devices, yet the 'power' to them doesn't work. It's likely that your BIOS is saying to disable them.
      My ComputerSystem Spec


 
Page 5 of 6 FirstFirst ... 3456 LastLast

Related Threads
DVD drive not recognising CD in Drivers and Hardware
Hi all, my first ever post in my first ever forum so I'm sorry if I do things a bit wrong. I'm very frustrated. I brought a Video editing software package to put my old videos onto the laptop but my DVD driver is not recognising the CD. It sort of...
Solved Laptop not recognising usb in Drivers and Hardware
Just got a new Asus x540s and I tried to back up my files using a usb but when I clicked on "add drive" the system could not find the stick, if I go into the drives I can see my stick from there ! any ideas ?:confused:
I am using windows 7 64 bit on a brand new computer partly home made 32G DDR3 I have downloaded Windows 10 upgrade. Unfortunately it doesn't recognise my DVD player. Checking the internet I am not alone in this.
After updating to Windows 10,I had to re-register my laptop with sky go.Another change cannot be made for a month.Does anyone know if the very latest update will have the same effect;i.e.that Sky does not recognise the laptop again?John Phaff.
on windows 7, I had no problems but since updating to windows 10 it does not recognise my USB connection. I have tried various USB ports but as soon as I connect I get the notification " USB not recognised ".:confused:
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:52.
Find Us