Page 1 of 3 123 LastLast
  1.    01 Jul 2017 #1
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)

    Intel RST on Creators Update


    Have you managed to install Intel RST drivers on a fresh CU copy?

    I've just installed CU on my new XPS 9360 and when attempting to install RST, I'm getting "platform not supported error". I found some threads over the web saying Intel hasn't updated its RST drivers for CU, but no specifics nor way to overcome were given.

    I've tried with the 15.2 version officially advised by Dell but also with 15.7 version got directly from Intel's website. Both installers failed.
      My ComputerSystem Spec
  2.    01 Jul 2017 #2

    Where did you get IRST file from? Your laptop vendor or Intel?

    Download it from here. Make sure to download the 4th download down.
      My ComputersSystem Spec
  3.    01 Jul 2017 #3
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    I've actually got one file from Dell's support site and the other from Intel's download site. And it was exactly the exe file you named.

    What's stranger I've actually tried to install the Intel file on my old M4800 with Creators Update running and which already has IRST installed - and the effect was the same. The installer wouldn't run successfully on this machine either! It looks there's some conflict between CU and IRST...

    On the M4800 I can see this text in the installation log file, yet I can't say what it means:
    Code:
    2017:07:01 21:54:56:930: E Win32 exception occurred!!
    2017:07:01 21:54:56:930:     Error code: 0x4E24 (20004)
    2017:07:01 21:54:56:930:     Error text: ''
    2017:07:01 21:54:56:930:     Extended error text: 'Error in device matching'
    At the same time running this file on my 9360 doesn't leave a log file for a review...
      My ComputerSystem Spec
  4.    01 Jul 2017 #4
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    One more thing that may add value here - my Dell 9360 runs NVMe Toshiba SSD THNSN5512GPUK, so it uses PCIe interface. Some info I came across suggest IRST doesn't support those drives. Can this be the issue?

    But if it is so, then why I was able to install IRST on my 9550 with NVMe Samsung SSD drive? Logically, I shouldn't be able to install it on neither of those machines. And my M4800 runs Samsung SSD 850 connected via SATA, so here I should definitely be able to install IRST and I can't either...
      My ComputerSystem Spec
  5.    02 Jul 2017 #5
    Join Date : Jun 2015
    UK
    Posts : 2,091
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    I discovered this site a while ago about choosing IRST drivers http://www.win-raid.com/t2f23-Intel-...QL-v-WHQL.html

    Note the 'best' driver for your PC is not necessarily the latest version.
      My ComputersSystem Spec
  6.    02 Jul 2017 #6
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    Thanks Steve C, I've tried the drivers from the mentioned site but I failed.

    I've got super-puzzled here - I had no issues with IRST before, so I can only attribute the current issues to the current update...

    Plus, considering Dell list those drivers for the particular device (based on the service tag), it looks for me they should be installed and obviously therefore the given installer should run in the installed OS.
      My ComputerSystem Spec
  7.    02 Jul 2017 #7

    Side note, mine was installed on an NMVE drive,.
      My ComputersSystem Spec
  8.    02 Jul 2017 #8
    Join Date : Sep 2014
    Warsaw, Poland
    Posts : 62
    Win 10 Pro 64-bit (Creators 1703)
    Thread Starter

    Quote Originally Posted by swarfega View Post
    Side note, mine was installed on an NMVE drive,.
    Exactly, the same happened to me on my other XPS machine! So what's happening here?
      My ComputerSystem Spec
  9.    02 Jul 2017 #9
    Join Date : Oct 2015
    Posts : 2,031
    Windows 10 Pro X64

    Hi,

    I just installed the latest version from Intel's site successfully.
    Check the readme file on that site to see if your chipset is supported. NVMe is supported by those drivers.

    Cheers,
      My ComputersSystem Spec
  10.    02 Jul 2017 #10
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    "Platform not supported" is an Intel error message, is it not? Meaning the message comes up from the Intel installer, not a Windows error message.

    It means the installer does not find a compatible chipset for the specific IRST version.
    It is important to understand that newer versions of IRST driver are not always backward compatible to older chipsets. There will be one last IRST driver that will work with your chipset, and that is the last driver you will use for that chipset.

    One common problem to check for: go into UEFI/BIOS settings and check to be sure that your SATA controller is still set to AHCI (or RAID). If it is not then the IRST installer will not find a compatible device.
    Kind of obvious, but the setting could have changed with the CU upgrade. Highly unlikely that is the reason, but stranger things have happened.
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
Solved Windows Update with Metered connection fails: Creators Update 15063.0
It's dejŠ vu all over again. :doh: The correct behaviour of windows update over a metered connection is to offer the choice to download, or wait until on a non-metered connection. 128460 The initial build of the Anniversary Update broke...
Windows Updates and Activation
Intel Wireless-AC 7260 unstable since Windows 10 Creators update ?
Hello Since this Windows update the internet connection has become rather unstable - usually manifesting straight after booting up with exclamation mark on Network connection icon in toolbar (no internet connection). Using windows network...
Network and Sharing
Itunes PC APPS Simultaneous Update Glitch after Creators Update v1703
I updated to V1703 Creators update and when I update my IOS APPS on my PC, it will not all update when checking "Simultaneous Updates" in ITunes APPS update. Unchecking the "Simultaneous Updates" box results in all APPS getting updated on the PC. I...
Software and Apps
Windows 10 Creators Update and Creators Update SDK are Released
Source: Windows 10 Creators Update and Creators Update SDK are Released - Building Apps for WindowsBuilding Apps for Windows :arrow: Windows 10 Creators Update version 1703 (build 15063) now available from Windows 10 Update Assistant. ...
Windows 10 News
Visual Studio 2017 Update Preview and Windows 10 Creators Update SDK
Source: https://blogs.msdn.microsoft.com/visualstudio/2017/03/16/visual-studio-2017-update-preview-and-windows-10-creators-update-sdk/
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:17.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums