1.    28 Jun 2017 #1
    Join Date : Jun 2017
    Posts : 3
    Windows 10 Pro

    Unknown USB Device (Link In Compliance Mode) Gigabyte GA-Z170X-G 7


    Hello!
    I'm running Windows 10 Pro on a self-built desktop, and nearly every time I log in, I get a "The Last USB device you plugged in experienced an error". It's very annoying. I'm certain this stems from an Unknown USB device in my device manager. To be specific, it says "Unknown USB Device (Link In Compliance Mode)". I know that in normal situations, you'd simply unplug and re-plug whatever device was having the issue. Problem is, I can't figure out what device this is referring to! I've unplugged everything, one device at a time, to see if that listing removed itself. Nothing. I even made sure to test with the devices using internal USB headers for case USB ports, media card reader, etc. I can remove ALL my USB devices, and that device listing is still there. I'm guessing it's some sort of integrated motherboard USB device. My bios and all my device drivers, including USB drivers are up to date. The properties for this entry in the device manager says the following:----------Unknown USB Device (Link In Compliance Mode) Device Type: Universal Serial Bus ControllersManufacturer: (Standard USB Host Controller)Location: Port_#0022.Hub_#0001 Device Status:Windows has stopped this device because it has reported problems. (Code 43)The SuperSpeed link to the USB device keeps going to an error state Compliance. If the device is removable, remove the device and then disable/enable from device manager to recover.----------Under "Details" I checked the Hardware ID, hoping there'd be something, but all that says is: "USB\PORT_LINK_COMPLIANCE_MODE" If I uninstall the device, it shows back up shortly, even if I haven't touched my USB ports. I do suppose I could Disable the device. But I'd like to save that as a last resort. I'd like to think I did a decent job of digging on my own for this, but now I need some help!My basic PC specs are below, please feel free to ask me any more details you might need. Thanks in advance!

    EDIT: I've been told before that this is an issue with the Thunderbolt 3/ USB Type C port on this motherboard, and while I've attempted to flash the newest firmware updates, I'm unable to tell if they're successful, and the USB errors remain. Please help, thanks! PC Specs:CPU: Intel Core i7 6700KRAM: 32GB DDR4GPU: EVGA Geforce GTX 980MOBO: Gigabyte GA-Z170X-Gaming 7 (Rev: 1.0) With latest firmware)Boot SSD: Samsung 500GB SATAStorage HDD: Western Digital 3TB HDDCase: Corsair 650DOS: Windows 10 Pro
      My ComputerSystem Spec
  2.    28 Jun 2017 #2
    Join Date : Jun 2017
    Posts : 3
    Windows 10 Pro
    Thread Starter

    I apologize for the lack of formatting. I pasted this from another forum I tried to find the answer to this problem on, and in the process, it seems like most of my line breaks were lost.
      My ComputerSystem Spec
  3.    29 Jun 2017 #3
    Join Date : Jun 2017
    Posts : 3
    Windows 10 Pro
    Thread Starter

    Oddly enough, the problem seems to have solved itself. It'd been like this for ages, but no longer seems to be the case. No complaints here. Thanks for reading, in any case!
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Unknown USB Device (Device Descriptor Request Failed)
After installing Windows 10 anniversary update, I get the following error in the device manger: Unknown USB Device (Device Descriptor Request Failed) Tried uninstalling and restarting PC. Reinstalled Windows made from media tool. Nothing fixed...
Drivers and Hardware
Creators Update Broke My XBOX 360 Headset Device (Unknown Device)
I can no longer use the mic that came with my Xbox 360 wired controller on my Windows 10 PC after I upgraded to the Creators Update a few days ago. In the Device Manager it is listed as 'Unknown device' and if I try to 'Upgrade Drivers' then I get...
Drivers and Hardware
Solved unknown device in device manager
Hey guys , I thought I might ask here as I don't seems to be getting a solution on Dells forum . Unknown device ACPI\CPL0002\2&DABA3FF&0 is showing up with a clean install of windows 10 pro on a dell alienware 13 ,2015 model . Any ideas what...
Drivers and Hardware
Solved Unknown USB Device (device descriptor request failed)
Fresh install of Windows 10 and the last driver I need to sort out is the above. I believe it is my powered USB 3 hub to which I plug in my keyboard and mouse. Technically it is working but I don't like seeing yellow triangles on devices. So...
Drivers and Hardware
Solved Unknown USB Device ( Device Descriptior Request Failed )
Greetings folks I have a problem that bugs me for years, I never intentionally solved it, sometimes those errors disappears and all USB ports work fine, sometimes they do not. So anyone can help me please, it would be great. Some of my ports...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:06.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums