1.    26 Jun 2017 #1
    Join Date : Jun 2017
    Posts : 1
    W10-Pro-64

    W10 on my desktop only lets me safely eject one drive per boot...???


    Lately i've noticed that the 'safely remove drive' function has simply stopped working for me after i use it once to eject a usb, then it becomes somehow inert and won't function to allow me to eject any other drives. My current work around which doesn't always work (in the case of external HDD) is to click on the drive in windows explorer and right-click eject.

    Anyone else seen this, or have any suggestions? This is a clean W10 Pro 64 install. I'm also not getting the normal notification saying "its okay to unplug it now'...all notifications that seem related to this function are turned on.
      My ComputerSystem Spec
  2.    27 Jun 2017 #2
    Join Date : Apr 2016
    Manchester, U.K.
    Posts : 551
    Windows 10 Pro 64bit

    You could try this which should fix the no notification problem.
    • Press keyboard*"win + R"
    • Type "regedit"
    • Search the value "HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Notification\Settings\Microsoft.Explore r.Notification.{...}"
    • If you REG_DWORD 0x00000001(0) set "0" you can double click on value. Set the value*data to "1"
    • Click "OK"
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
For long, the problem of safely eject never solved
I have been researching on web and trying different third party tool but none of them actually works. A lot of time, not always though, I can't safely eject USB portable hard drive. However, I am 100% sure that no files on that drive is...
Drivers and Hardware
Cannot eject safely usb external drive
Hello, The problem of beeing unable to eject the usb drive safely still exists, the only way I found (temporarily) is to disable it in the device manager, but then the change asks to restart the computer, if I do not restart, the drive is unabled....
Drivers and Hardware
Cannot eject safely an external USB drive
Hello, Recently I bought one "WD Elements" 1TB external drive for data storage. When attachet it to the pc, it was found by the file explorer, it is already NTFS formated, one whole partition. On it found "WD Smartware pro trial" installer and an...
Drivers and Hardware
Solved Cannot safely eject Seagate usb Expansion Drive
I got my new Seagate 2 TB Expansion Drive and made the first image of my new laptop (running Win 10 anniversary build) using Macrium Reflect. All went well, and I closed Macrium, then attempted to eject the external drive from the notification area....
Drivers and Hardware
Have to safely eject thumb drive exactly twice every time
This amounts to an annoyance only, but I thought I'd ask in case someone has a solution. I find I always have to eject my thumb drive exactly twice. This happens on at least two laptops: A Toshiba Satellite with Windows 10 Home 10586.545 ...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:04.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums