1.    18 Jun 2017 #1
    Join Date : Jun 2017
    Honolulu
    Posts : 5
    10 (1703)

    1703 - scanner freezes


    My old machine wouldn't update to 1703 (and had other glitches), so I found a new-used i7 PC and put in a fresh install of 1703. Everything works fine except the scanner, an Epson Photo 3490.

    I used the same driver software installer as in the old machine, but when I open the scanner one of the follow happens in no predictable order:

    • It opens the scan app, then when I press Preview or Scan It tells me that the scan is starting, and then the app freezes. I need to use Task Manager to close it.
    • It tells me that I don't have a Twain driver installed
    • It tells me that it can't open the app.


    I've deleted the driver and software, tried to install it with Admin privileges, and I've used the compatibility utility to install it for an older Windows version (both 7 and 8).

    Does anyone have any suggestions to get this working?.










      My ComputerSystem Spec
  2.    19 Jun 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,924
    Win 10 Pro (1703)

    Hi, according to this there is a 64 bit Win 10 compatible driver:
    Epson Perfection 3490 : Drivers & Software
    Click image for larger version. 

Name:	1.jpg 
Views:	2 
Size:	48.9 KB 
ID:	140173
      My ComputerSystem Spec
  3.    19 Jun 2017 #3
    Join Date : Jun 2017
    Honolulu
    Posts : 5
    10 (1703)
    Thread Starter

    Thanks dalchina. I downloaded that driver, which could be the same one I got from the Epson support page, and it did the same thing. It opens the app and then freezes as soon as Preview or Scan is selected.

    I put a new USB cable in to see if that was the problem, but the same results.

    Device manager finds the scanner and says the device is working properly.

    Note that the scanner worked with no problems in the old machine with Win 10 1607. Somehow the new machine with a much faster processor doesn't like the driver.

    I would be able to scan through Irfanview without the Epson software if I could find a generic Twain driver.
      My ComputerSystem Spec
  4.    19 Jun 2017 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,924
    Win 10 Pro (1703)

    Sounds like the twain driver is the issue. Is that shown as missing in Device Manager?

    Sometimes in exceptional circumstances I've used DriverMax to find odd drivers successfully. (free for 2 drivers a day).
    We never recommend the routine use of driver updater programs.
      My ComputerSystem Spec
  5.    19 Jun 2017 #5
    Join Date : Jun 2017
    Honolulu
    Posts : 5
    10 (1703)
    Thread Starter

    Thanks again. DriverMax had two generic twain drivers, which I downloaded. Neither one, once installed, were recognized. After deleting everything related to the scanner and then rebooting, I again installed the Epson scanner software with compatibility set at Vista.. This time the scanner program came up and when Preview was selected, it actually scanned the page - and then promptly froze. When I opened the program again, it gave an error message that the twain driver was not installed or the scanner wasn't connected. All very frustrating.
      My ComputerSystem Spec
  6.    20 Jun 2017 #6
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,924
    Win 10 Pro (1703)

    This is an old scanner- looks like it dates back to 2005, which may be why it isn't fully supported. Against that is Epson's Win 10 driver.

    Re-reading your first post it sounds like it worked with the Anniversary edition (if that's what your post means) but not with the CU.

    You could try contacting Epson or posting on an Epson forum, or you could use it in a virtual machine- an older version of Windows.

    Otherwise, there is a program called Vuescan (not free) which provides support for many older scanners.
      My ComputerSystem Spec
  7.    20 Jun 2017 #7
    Join Date : Jun 2017
    Honolulu
    Posts : 5
    10 (1703)
    Thread Starter

    The machine where the scanner worked perfectly was using Win10 anniversary edition (1607) with a Pentium J2900. I've replaced it with a with a Intel i7 machine running Win10 Creators (1703).

    Irfanview recognizes the twain driver for the scanner, sometimes opens the scanner app, sometimes tells me it can't open it, and sometimes tells me I don't have a twain driver.

    I've never had the anniversary edition on this machine; I used a fresh install of Creators. So I don't know if its the new Windows or the much faster CPU that's causing this problem.
      My ComputerSystem Spec
  8.    20 Jun 2017 #8
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,924
    Win 10 Pro (1703)

    Check with Epson as to compatibility. Maybe they need to update the driver...
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Win 10 cant see Printer Scanner
I have a Canon all in one printer scanner MX535. It was working perfectly until I had to do a win 10 re install, completely cleared out c drive. I installed PSE9 which I use for all my photos and scans. It refused to work, so I uninstalled and...
Drivers and Hardware
Is my scanner/printer just too old?
The device in question is a scanner/printer by Epson, the Stylus NX415. I bought it in March, 2010 and originally used it on my Win 7 laptop. I just bought a tower with Win 10 on it and am in dire need of a driver. I've already scoured Epson's site,...
Drivers and Hardware
Connecting a Scanner
I have an Epsom RX560 (Printer/Scanner/Copier) When Connected to Windows 10, it recognised the Printer straight away. No need for the Install disk, it was up and running in just a couple of minutes and even without the install disk the...
Drivers and Hardware
Solved Using a scanner
I have an HP muliti purpose colour laser printer / scanner. I have the correct software loaded but my Windows 10 machine always tells me the scanner isn't connected. I've tried the Microsoft "Scan" application that came with my Windows 10 computer...
Drivers and Hardware
Scanner issue
I have a Kodak 5200 all in one printer. The unit prints but won't scan to my laptop. AIO error ... then shuts down. Does anyone know of a fix?
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:55.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums