ASMedia USB Root Hub Driver issue Solved

  1. Posts : 4
    Windows 10

    ASMedia USB Root Hub Driver issue


    Please can someone help me with this

    Since the last windows 10 update i am having trouble in particular with one driver called:

    ASMedia USB Root Hub Driver

    This USB keeps installing itself and never stops. I keep hearing the windows beep that usually comes when you insert a new usb input into your computer. I have also tried uninstalling this and installing it again, but still same issue.It only stops beeping if i completly uninstall this driver or disable it. But then obiouvsly the USB doesnt even work.To be honest im nto even sure which USB input it is? Is it motherboard based or external? Ive spent many hours scratching my head to no avail, please if you could help in anyway it would be really appreciated!!

    I have already tried installing the driver given above but still same issue even with


    Update: after uninstalling the asmedia usb hub I also removed the asmedia USB 3.1 extensible host controller.

    Since then I keep getting the blue screen of death and windows keeps crashing about 30secs after it enters desktop.

    I tried do a windows restore but that kept failing, luckily I had the driver for asmedia downloaded, so after I restarted I quickly installed it back before it crashed again. That solves the crashing problem but now those drivers are back again and keep trying to install constantly automatically. Also I believe it's a USB on my motherboard as that one doesn't seem to be functioning anymore.
      My ComputerSystem Spec

  2. Posts : 4
    Windows 10
    Thread Starter

    Ah dont worry about it, i actually just managed to solve it by uninstalling them both again, then removing the usb input and changing it around with another usb input. Took me a few good hours, but managed to solve it in the end
      My ComputerSystem Spec


Related Threads
I have noticed, that MS installs its own driver over ASMedia's, which might cause issues. Even, if you have automatic driver installation disabled, some updates might change it. Since ASMedia does not provide direct downloads, only 3rd party...
I am seeing several of these Warnings in the Event Viewer, Windows System logs. These are Event ID 219, Source Kernel-PnP. That said, I am not experiencing any crashes, freezes, BSODs, and everything on my PC seems to be functional. So perhaps...
Greetings TenForums, I have had this Dell XPS 13 2015, running Windows 10 Home (10586) to my dismay, in my possession since June 2016. I've been using it as a "back up", but i'm eventually looking to sell it. However, it appears it may be a bad...
Hi there! I'm in a desperate need of help. This is the situation (sorry for my bad English as always...). Yesterday I left my PC running with a download in progress through MiPony. I told the program MiPony (for the first time) to shut down...
I have a Aśus Maximus V Gene mob that has two Sata mob inputs not controlled by the Intel Sata driver. I am having difficulty installing the latest Asmedia driver downloaded from the Aśus support site. With Win 7 there isn't a problem, but win 10 TP...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:11.
Find Us