1.    16 Jun 2017 #1
    Join Date : Dec 2015
    Posts : 17
    Microsoft Windows 10 Pro x64

    Windows won't recognize my usb 3.0 external HDD


    Hi,

    I have 1TB transcend USB 3.0 external HDD.
    Windows did recognized it but no more.

    Here is what I've tried:
    1. Different OS: Ubuntu doesn't recognize it either
    2. Different computer: my Android device and another PC I have With Windows 10 do recognize it
    3. BIOS settings tried with/without legacy support
    4. Uninstalling the driver (picture attached) it's Microsoft generic since there is no driver to 9BC1 for Windows 10 http://pcidatabase.com/search.php?device_search_str=9cb1&device_search=SearchClick image for larger version. 

Name:	usv.jpg 
Views:	2 
Size:	168.1 KB 
ID:	139762
    5. USB selective suspend setting disabled in power options
    6. Regedit to the driver path and change EnhancedPowerManagementEnabled (it doesn't exist)
      http://windowsreport.com/usb-3-0-ext...ve-windows-10/


    My PC is HP Spectre x360 4003dx.
    I'm kinda of clueless right now.
    Any help will be greatly appreciated.

    Thanks
    Roey
      My ComputerSystem Spec
  2.    16 Jun 2017 #2
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    Often when an external hard drive can't be recognized on a certain PC, but can on others, the problem has to do with power. The problem PC does not put out the power needed on the USB line.

    One of the least expensive solutions to this problem is a Y-connector USB cable. This cable allows you to plug into 2 USB ports on the PC that go into 1 USB port on the external drive. One of the PC port USB connectors has only power pins, so you can double the power to the drive.

    If this is the problem, it is caused because either the external drive manufacturer is not adhering to the strict USB specs, or there is under-spec power being delivered by the PC (common on laptops), or simply a bad cable.
      My ComputerSystem Spec
  3.    16 Jun 2017 #3
    Join Date : Dec 2015
    Posts : 17
    Microsoft Windows 10 Pro x64
    Thread Starter

    Yap it was the cable. How trivial though it was the original one...
    TV2 thanks for the explanation and support.

    Best
    Roey
      My ComputerSystem Spec
  4.    16 Jun 2017 #4
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    The least expensive option. Nice!
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Why won't Windows recognize I have Powerpoint?
I have Microsoft Office 2010, I can open Word and Excel files by clicking on them but not Powerpoint, it wants to send me to the app store. I can run the Powerpoint program and open it from within. In Settings - Choose default apps by file...
Software and Apps
Solved Suddenly Windows Will Not Recognize My 2TB Seagate USB External Drive
Before I recently upgraded my computer from Win 7 Pro to Win 10 Pro, the drive was working fine. But now Windows will not recognize the drive.......although it does show up in Disk Management, there is no content. I then ran the utility EaseUS...
Drivers and Hardware
Realtek doesn't recognize external microphone.
Hi all. Recently I purchased a Logitech h151 headset which has only one single jack, as my ASUS laptop has only one jack used for a headset. However, upon connecting the headset, although the sound plays through it perfectly and without issue, the...
Drivers and Hardware
How do I get Windows 10 update to recognize my external drive?
Early on in the Windows 10 update process, I was able to upgrade an HP Stream 7 and a Stream 11 to Windows 10. Both had the same 32GB RAM and nominal 32GB eMMC as the Stream 14 I am wrestling with. Both came to a point where they told me the device...
Drivers and Hardware
Windows does not Recognize me as Administrator
I only have one account. When I check my account status it shows Administrator. Yet when I try to do certain functions Windows tells me I need to be an Administrator to do that function. Like tonight. I tried to save a bat file to my root...
User Accounts and Family Safety
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:44.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums