1.    13 Jun 2017 #1
    Join Date : Jun 2017
    Posts : 7
    Windows 10

    Creative Soundblaster xfi Titanium Windows 10 Creators update problem


    Hi all, since the creators update was installed my sound from my xfi dedicated card is borked....when i say borked, i mean the quality is terrible; sound is muffled...there is too much volume at low volume levels, and when clicking on the audio devices the "output" level meter is always at 100% even at low volume.

    Im not sure how Microsoft has managed to bork an external sound card so much, but it has. I have tried removing drivers completely, using ccleaner to clean registry of sound drivers, and have reinstalled the latest driver on windows 10 which worked fine previous to this update. Nothing works.

    Aside from uninstalling this painfully bad update (one of many recently) is there anything else anyone has found that solves this problem?

    Thanks for any help in advance.

    Nb the sound coming through the usb/motherboard is absolutely fine. Just the sound card is now broken. I have tried several drivers now and nothing works....even the standard windows 10 loaded driver shows the same symptoms. HEEEELP!
      My ComputerSystem Spec
  2.    13 Jun 2017 #2
    Join Date : Jun 2017
    Posts : 7
    Windows 10
    Thread Starter

    Just to add some more details....it seems like gain was massively introduced to sound on this update. The bass is massively over the top; and everything sounds muffled. Its almost like there are 2 sets of drivers competing. With the volume on halfway on my speakers and the in windows volume set to 10 the noise is deafening, and the speakers cant take it. The speakers are semi decent logitech ones and this is definitely an issue from this Creators update.
      My ComputerSystem Spec
  3.    13 Jun 2017 #3
    Join Date : Jun 2017
    Posts : 3
    Win 10

    Have you tried Daniel k drivers
      My ComputerSystem Spec
  4.    13 Jun 2017 #4
    Join Date : Jun 2017
    Posts : 7
    Windows 10
    Thread Starter

    Yeh, thanks for the suggestion, but I have already installed those as well to try and remedy as a clean driver install; but something is definitely off with this creators update and the sound blaster drivers. They use the base modded latest driver for windows 10 anyway, so realistically is the same one as I was using before (that worked before the creators update). Nothing seems to help anything sound like it did....apart from rolling back the update. I have reinstalled it and the issue still remains. I think Microsoft need to do a hotfix or something.
    As the creative card is old...maybe my only choice is to buy a new soundcard, which quite frankly is ridiculous. Hoping for a fix...and wonder if noone else has noticed this same issue, as it definitely is the update that causes it?

    I have sent a "issue report" to MS on the feedback tool...whatever that might do.
      My ComputerSystem Spec
  5.    13 Jun 2017 #5
    Join Date : Jun 2017
    Posts : 3
    Win 10

    I did a search some else had problems with sound and there coment was disable the card in device manager and renable it
      My ComputerSystem Spec
  6.    13 Jun 2017 #6
    Join Date : Jun 2017
    Posts : 3
    Win 10

    It was the same sound card
      My ComputerSystem Spec
  7.    14 Jun 2017 #7
    Join Date : Jun 2017
    Posts : 7
    Windows 10
    Thread Starter

    Hi thanks again, I saw that same post actually! I tried this and nothing seems to be working to help me. Ive noticed that it sounds a bit better when set to 2.1 stereo instead of 5.1 (which is the speaker system I have) so Im not sure why that might be at all.

    Have checked the soundblaster software and Windows are both on 5.1 and they are. Just sounds....muffled; and at the same time far, far too loud. If I want it *very* loud I simply have to set it to 14 in Windows and not even half way on the volume control on the logitech speaker system. Before I would have had to put it to 40 in Windows on the same setting for loud music/games.

    If that was the only problem it would be fine, but the sound is distorted and something is wrong. I have adjusted the tone, and basically there is far too much bass at any setting; until it disappears completely....the range is all wrong. Im not sure what they have done, but Id like my old sounding Soundblaster back.

    Clearly as before its a problem with what they have done and Creative's drivers, but as this card is now eol; they wont be doing anymore drivers; just wish Windows wouldn't mess with this sort of thing. Am a bit surprised noone else has this issue or has reported it on these forums, makes me think something went wrong during the install...may try rolling back and installing again in the hope that this time it is better.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Creators Update - Account Problem
Since Microsoft 'creators update' about a week ago I have been getting the following message pop up daily; Microsoft account problem We need to fix your Microsoft account before you can use shared experiences. Select this message to...
User Accounts and Family Safety
Solved DISM problem , on windows 10 creators update , ver.1703
Hi , two days ago ( 2/5/2017) upgraded my windows 10 system from ver.1607 to ver.1703 , so called Creators update and immediately ran sfc /scannow ( no integrity violation ), DISM /Online /Cleanup-Image /ScanHealth ( component store repairable )...
Performance & Maintenance
Solved After Creators Update: Cant open Windows Explorer, themes problem
So I downloaded the new Creators Update over night and in the morning I tried logging into my account. First I had some problems logging in but I eventually managed to fix them. Then, as I log in, all that I get is a black screen and the only...
General Support
Creators Update Partition Problem
I made a thread a couple of months ago commenting on the fact that, when I had to reinstall windows 10, I messed up the installation by putting everything onto one main partition, leaving the other 2 partitions unallocated. I decided not to do...
Installation and Upgrade
Solved Installing Creative SoundBlaster Live! 1024 in Windows 10 64-bit
Hello! I have an old test PC where I recently installed Windows 10 Pro 64-bit to check the performance and compatibility with devices and applications. The onboard sound card is a Realtek AC'97 which as described in this thread will cause a BSOD...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:25.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums