Windows 10: Cannot Access New Seagate 2TB Expansion USB 3.0 Drive Solved


  1. Posts : 53
    Windowes 10 Pro 15063.332
       09 Jun 2017 #1

    Cannot Access New Seagate 2TB Expansion USB 3.0 Drive


    i just purchased a new seagate 2tb expansion usb 3.0 drive and no matter what i do i can not access it. when i first received it i plugged it in, open it once it showed up in pc, tried to copy files to it and was told to no disk in drive d, checked properties and they said 0 used 0 available. i opened partition wizard, wiped the drive, formatted, assigned name "universal two, and letter n and now when i click on it i get "please insert a disk into the drive". i think the below images below are pretty much self-explanatory. even thought disk management and partition wizard say it's drive n i still get "there is no disk in drive d. please try again. i'm completely out of ideas, please any ideas and or suggestions. thanks

    Click image for larger version. 

Name:	Removable 1.png 
Views:	8 
Size:	99.7 KB 
ID:	138681Click image for larger version. 

Name:	Removable 2.png 
Views:	7 
Size:	62.1 KB 
ID:	138682Click image for larger version. 

Name:	Removable 3.png 
Views:	8 
Size:	72.4 KB 
ID:	138683Click image for larger version. 

Name:	Removable 4.png 
Views:	6 
Size:	17.7 KB 
ID:	138684
      My ComputerSystem Spec

  2.    09 Jun 2017 #2

    Plug the drive into another computer and see if it is detected, or just return the drive as defective for a replacement.
      My ComputerSystem Spec

  3.    09 Jun 2017 #3

    If the HDD is detected by another PC (as suggested by NavyLCDR) and the first HDD plugin on the problem PC was recent enough, you might try restoring the problem PC to its state before the drive was first plugged in and start over.

    (I once had an external drive HDD that stopped being detected by one PC but still worked on other PCs. That situation was slightly different from yours, as the HDD worked on the problem PC for a while before it stopped being detected. As far as I could figure out, the registry entries on the problem PC for that particular external HDD apparently got corrupted somehow. I ended up using an obscure program to remove all USB registry entries and started over, but I don't recall the name or source of the program right now, and that approach would be more complicated than simply restoring to a recent date.)
      My ComputerSystem Spec


  4. Posts : 53
    Windowes 10 Pro 15063.332
    Thread Starter
       09 Jun 2017 #4

    got it figured out i also have a sata to usb device that even when a drive isn't connected it keeps a placeholder, so i assumed disk 7 was the seagate cause it was the last drive hooked up when it was actually drive 6 because i don't have anything connected to the sata device. thnaks for the input though.
      My ComputerSystem Spec

  5.    09 Jun 2017 #5

    Glad you got it sorted - thanks for posting back with solution!
      My ComputerSystem Spec


 

Related Threads
Hi, I am running Windows 10 Pro Build 1703, prior to my update I was using my external Seagate drive as my backup location, however since the update, backup is not finding the drive. The drive is working perfectly for all other tasks and is...
I've got a Seagate Expansion drive connected to my PC using a USB A - USB 3.0 micro B cable. I'm unable to find any "Safely remove" option, and at one point when unsafely removing I got a blue screen. I've tried: The tray. Nothing there....
I got my new Seagate 2 TB Expansion Drive and made the first image of my new laptop (running Win 10 anniversary build) using Macrium Reflect. All went well, and I closed Macrium, then attempted to eject the external drive from the notification area....
I have a perplexing problem. I have a Seagate 2TB external drive that when I plug it into my USB3 port it appears in Explorer and sometimes I can even navigate through some of its folders. However after 2-5 minutes it just disappears and a message...
I recently upgraded to Windows 10 and post that It was working fine without any issues. I have two external drive connected to it. 1. 1 TB Iomega powered drive. - now RAW 2. 2TB seagate external drive. The 1tb drive suddenly became RAW and I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:56.
Find Us