1.    05 Jun 2017 #1
    Join Date : Jun 2017
    Posts : 5
    windows 10

    Shift a not working


    all of a sudden the shift and a do not work at all (no capital a and no lower case a) this is from using the keyboard and the osk.exe on screen keyboard.

    this is for both shift keys. all other keys work fine using shift to make a capital letter.

    this seems to have started after updating the computer thru windows update this morning.

    any help would be appreciated
      My ComputerSystem Spec
  2.    05 Jun 2017 #2
    Join Date : Jul 2016
    Granite Bay, CA
    Posts : 712
    Windows 10 Professional

    Reinstall your keyboard driver.

    1) Search for, and open, Computer Management
    2) Click Device Manager > arrow next to Keyboards > right click your keyboard > Uninstall device
    3) (if you see a check box to delete the driver files, check it) Press Uninstall
    4) After so, restart your computer
    5) Once your computer starts up, Windows should automatically install your Keyboard driver
    6) Try out your keyboard's Shift & A
      My ComputerSystem Spec
  3.    05 Jun 2017 #3
    Join Date : Jun 2017
    Posts : 5
    windows 10
    Thread Starter

    reinstalled the keyboard driver with no change
      My ComputerSystem Spec
  4.    07 Jun 2017 #4
    Join Date : Jul 2015
    PA, USA
    Posts : 476
    Windows 10 Pro (Mix of Builds) / Linux Mint

    Interesting, can you check the update history and see what was installed?

    If it were just the KB and not the OSK I'd go for hardware right away, still a good idea to look at your KB.

    Another option is to try an external USB KB as well.
      My ComputerSystem Spec
  5.    07 Jun 2017 #5
    Join Date : Jun 2017
    Posts : 5
    windows 10
    Thread Starter

    only the following were installed, don't see that any of them would have affected the kb:

    2017-05 security update for adobe flash player for windows 10 ver sion 1702 (KB4020821)

    Qualcomm communications driver update for dell wireless 1705 802.11b

    Windows malicious software removal tool (KB890830)

    Tried another usb KB and same problem
      My ComputerSystem Spec
  6.    07 Jun 2017 #6
    Join Date : Aug 2016
    S/E England
    Posts : 4,520
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Do you have any 3rd-party software for assigning hot keys? Has Shift-A accidentally been made a hot key? Something like that could explain why it also happens for osk.exe.
      My ComputersSystem Spec
  7.    07 Jun 2017 #7
    Join Date : Jun 2017
    Posts : 5
    windows 10
    Thread Starter

    no i dont have any such software
      My ComputerSystem Spec
  8.    07 Jun 2017 #8
    Join Date : Jun 2017
    Posts : 5
    windows 10
    Thread Starter

    oops it was dual monitor tools, tks I sometimes am such a knucklehead working fine now
      My ComputerSystem Spec
  9.    07 Jun 2017 #9
    Join Date : Aug 2016
    S/E England
    Posts : 4,520
    10 Home x64 (1709) (10 Pro on 2nd pc)

    Quote Originally Posted by ddubbler View Post
    oops it was dual monitor tools, tks...
    Had to be a software issue, what with it affecting the osk. Glad you found it.
      My ComputersSystem Spec
  10.    08 Jun 2017 #10
    Join Date : Jul 2015
    PA, USA
    Posts : 476
    Windows 10 Pro (Mix of Builds) / Linux Mint

    Cool, glad you found it as well.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Shift for selecting multiple Files not working
First of all I would like to say how well laid out this forum is. Just joined and hope to find some solution to my problem. Windows 10 has many little problems, her are some with "Shift"! If I want to let's say select 10 Files in Windows...
Customization
Night Shift greyed
Hello, I cannot enable nor use Night Shift. I tried restarting the computer. I tried updating the drivers which temporarily fixed the issue. I tried updating Windows which again temporarily fixed the issue. I tried turning off Location...
General Support
Contol + Shift key combinations functions not working
I have just purchased a new HP Envy Laptop model 15-A E05SA. and have upgraded to Windows 10 from 8.1. However, for some reason the Control + Shift key plus other key combination functions do not seem work. For example Ctrl+Shift+f9 should remove...
General Support
Windows 9: Much ado about little, given cloud shift
Read more at: Microsoft's Windows 9: Much ado about little, given cloud shift | ZDNet
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:44.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums