1.    02 Jun 2017 #1
    Join Date : Jun 2015
    Posts : 236
    Win10 Pro x64

    IDE->USB/SATA->USB adapters no longer working after Creators Update


    I have an R-Driver III USB 2.0 to SATA IDE Cable (Comes with an AC adapter) and a SODIAL USB 3.0 to SATA III Cable (USB power only). I have tried to format 2 IDE drives on the 2.0 cable and one drive on the 3.0 cable. Using the 2.0 cable I have incessant disconnecting and reconnecting. I was able to get a folder of pictures off of one drive in pieces during the reconnecting, and eventually I did get it to do a low level format after grabbing the latest updates from WU and rebooting. The other drive disconnects immediately when i try to format it. The 3rd drive using the USB 3.0 cable also disconnects when I try to format.

    I am at a loss here. i have no idea why all the drives and both cables are being so finicky. I did not have this trouble before the latest update.

    EDIT: I also forgot to mention there is nothing physically wrong with the drives. All 3 came out of old but perfectly functioning machines.
      My ComputerSystem Spec
  2.    02 Jun 2017 #2
    Join Date : Aug 2014
    Forever West
    Posts : 3,926
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    EDIT: I also forgot to mention there is nothing physically wrong with the drives. All 3 came out of old but perfectly functioning machines.
    That's what I thought with a PATA drive in a USB case but turned out as it warmed up things started going bad. I now have a new WDC 320GB SATA drive in a USB 2.0 case that works fine. Both SATA and PATA use the IDE interface, IDE is a hold-over term from the changes away from MFM/RLL drives. As far as USB goes, even though many things with USB 3.0 say it is backward compatible with USB 2.0 that may not always be true in the real world. And many times I see USB ports not providing sufficient power for external devices, always has been curable by using a Self-powered USB Hub. I've also had issues with the USB cases involving the 2.5" drives that take more than 0.5A-0.55A current [on the label], they usually have a Y-cable, one leg for a USB port for data and power and the other leg for additional power which usually works good.
      My ComputerSystem Spec
  3.    02 Jun 2017 #3
    Join Date : Jun 2015
    Posts : 236
    Win10 Pro x64
    Thread Starter

    I literally ran all 3 computers that these drives came out of within the past week. They all ran their respective OS/programs fine. The 2 drives I used with the 2.0 cables came out of desktops, they are powered through the AC adapter, so USB power isn't an issue there. The other drive came out of a laptop which was again functioning normally. I have never had any issues with 2.5" drives not drawing enough power.
      My ComputerSystem Spec
  4.    02 Jun 2017 #4
    Join Date : Aug 2014
    Forever West
    Posts : 3,926
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    I had just Upgraded from Version 1607 to Version 1703 Build 15063 today and checked one of my small portable USB drives, works fine but I am using a Self-Powered USB Hub to assure sufficient power.
      My ComputerSystem Spec
  5.    02 Jun 2017 #5
    Join Date : Jun 2015
    Posts : 236
    Win10 Pro x64
    Thread Starter

    Even if I had a power issue with the 2.5" drive (Which i don't think i do, but for arguments sake we will say i did), that still doesn't say anything about the 2 desktop drives that are plugged into a power strip.

    My case is a rosewill stealth and it has one of those fancy docking bays on top, I am gonna give that a shot in a bit. I don't think i hooked it up to the motherboard when i put my computer together :P
      My ComputerSystem Spec
  6.    03 Jun 2017 #6
    Join Date : Jun 2015
    Posts : 236
    Win10 Pro x64
    Thread Starter

    UPDATE: The 2.5" drive is formatting fine so far in the HDD dock.

    I really just want to write this off as microsoft borked the usb drivers again, I find it hard to believe that both sets of my cables are suddenly bad. Anyways, that is 2 drives down, the last one is the most troublesome though.
      My ComputerSystem Spec
  7.    03 Jun 2017 #7
    Join Date : Feb 2016
    Phoenix, AZ
    Posts : 243
    Windows 10 Pro 1709 16299.19

    I use a RCW-608 Rosewill Sata or IDE to USB 2.0 adapter that's been working with either Sata or IDE drives under W10 1703. I also have several 2.5" Usb 2.0 enclosures that use the "Y" cable and have IDE drives inside of them that work flawlessly. Maybe you do have a problem with those cables.

    Note that these units were plugged into USB 3.0 ports only.
      My ComputersSystem Spec
  8.    03 Jun 2017 #8
    Join Date : Jun 2015
    Posts : 236
    Win10 Pro x64
    Thread Starter

    I went through device manager and cleaned out all the instances that were created in the usb/volumes/shadow volumes sections and rebooted. The 3rd drive no longer rapidly connects/disconnects. It still refused to do a low level format using the format option in Disk Management. Using diskpart I made sure the drive wasn't set to read only. I tried to use the clean command in disk part with the all flag set, it did not work. I have no idea why this drive is giving me so much grief.

    Edit: The 3rd drive is garbage. Which is surprising because the computer it was in still ran fine, but whatever. The drive is muddled enough and I don't care, it's getting recycled as is.
    Click image for larger version. 

Name:	image.png 
Views:	3 
Size:	47.1 KB 
ID:	137829
    Last edited by Carsomyr; 03 Jun 2017 at 11:35.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
With Creators update monitors no longer actually turn off?
After updating my Win 10 to CU I find that when I leave my PC for 10 minutes or more (control panel power options set to disable monitors after 10 minutes of standby) my displays just display black color instead of actually going into standby mode....
Drivers and Hardware
Solved Creators Update Files in explorer no longer highlighted when selected
After the latest Creators Update, when I open a folder and select a file (Or select few or all files) the selected files are no longer highlighted like before. You can't see what file is selected. Even in "my computer" selecting a drive C: D: etc...
General Support
Shut down takes longer after Creators Update
After the Creators Update was done on my PC, I shut the PC down but it took considerably longer to shut down than usual. I then started it back up to see if anything was running or something and I had nothing but a black screen with a scrambled bar...
Performance & Maintenance
Self-Signed Certificates no longer working since update
Morning all, annoyingly Windows decided to update itself over the weekend and rebooted my PC. This also happened with a few other work PCs and left users unable to login for an hour while it forced the update on us. Luckily we only have a handful...
General Support
Solved SATA ports not working after windows 10 update
Hello folks, I cloned my C drive and updated to windows 10 a week ago. Yesterday SATA ports 2 and 3 stopped working (on MOBO gigabyte GA-Z77M-D3H-MVP). I think it is a windows 10 problem because I have: swapped my drives between SATA ports....
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:40.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums