1. Joined : Jul 2015
    Posts : 243
    Win 10 Pro 64bit
       20 Jul 2015 #1

    Line 6 POD Studio UX2 - Current Drivers Do Not Work With Win 10


    This isn't a request for help just a heads-up.

    The Line 6 POD Studio UX2 audio interface does not work with Windows 10.

    The latest available version of the driver is 4.2.7.1 and it hails from 2013.

    Despite being listed for Windows 10 in the Line 6 download section it does not allow the device to function. Neither do previous versions of the driver.

    The UX2 will appear to install correctly and appears to be fine in Device Manager and the Control Panel Sound & Line 6 applets. However when you try and use it is non-functional. No one has managed to get the UX2 to work in Windows 10.

    So, if you need to use the UX2, don't install Windows 10 until Line 6 release a confirmed working driver.
      My System SpecsSystem Spec


  2. Joined : Jul 2015
    Posts : 243
    Win 10 Pro 64bit
       27 Jul 2015 #2

    Update:

    4.2.7.1 drivers are partially working with 10240 64bit and all updates.

    WDM, ASIO & WASAPI drivers are fully functional within DAWs. Direct X & Wave Out drivers are not.

    Generic Windows sound system output only works on 16bit 48000Hz setting. Input is still non-functional.
      My System SpecsSystem Spec


  3. Joined : Jan 2014
    Inverness
    Posts : 720
    Win 10
       27 Jul 2015 #3

    Just for info, My Roland Edirol PCR 500 MIDI keyboard will not install on Win 10, but works perfectly on Win 7 and Win 8.1.

    I have POD Farm 2, I hope it works when I upgrade 8.1 to Win 10. The Get Windows 10 app does not flag any software as incompatible. (I have a Sonar Platinum recording studio).

    All my other recording hardware, including a Roland Studio-Capture work OK in Win 10.
      My System SpecsSystem Spec


  4. Joined : Jul 2015
    Posts : 243
    Win 10 Pro 64bit
       28 Jul 2015 #4

    fireberd said: View Post
    Just for info, My Roland Edirol PCR 500 MIDI keyboard will not install on Win 10, but works perfectly on Win 7 and Win 8.1.

    I have POD Farm 2, I hope it works when I upgrade 8.1 to Win 10. The Get Windows 10 app does not flag any software as incompatible. (I have a Sonar Platinum recording studio).

    All my other recording hardware, including a Roland Studio-Capture work OK in Win 10.
    POD Farm 2.5 VST, and stand alone app, seem to be working OK with the UX2.
      My System SpecsSystem Spec


  5. Joined : Jul 2015
    Posts : 243
    Win 10 Pro 64bit
       29 Jul 2015 #5

    Update:

    Input is now working with generic Windows sound system on Windows 10 Pro 64bit Official Release.
      My System SpecsSystem Spec


  6. Joined : Jul 2015
    Posts : 2
    Windows 10 Pro 64bit
       30 Jul 2015 #6

    Nus said: View Post
    Update:

    Input is now working with generic Windows sound system on Windows 10 Pro 64bit Official Release.
    Not working here. UX2 and W10 Pro 64bit Official Release as well..

    Playback works fine at 16b/48kHz, Input just won't work outside ASIO/WASAPI exclusive mode (haven't tried WDM, but since I'm trying to get Open Broadcaster Software and Skype to work with the input for streaming purposes my priorities lie elsewhere).

    Tried everything I could think of so far, any ideas appreciated.
      My System SpecsSystem Spec


  7. Joined : Jul 2015
    Posts : 243
    Win 10 Pro 64bit
       30 Jul 2015 #7

    Dywas said: View Post
    Not working here. UX2 and W10 Pro 64bit Official Release as well..

    Playback works fine at 16b/48kHz, Input just won't work outside ASIO/WASAPI exclusive mode (haven't tried WDM, but since I'm trying to get Open Broadcaster Software and Skype to work with the input for streaming purposes my priorities lie elsewhere).

    Tried everything I could think of so far, any ideas appreciated.
    In the Control Panel Sound I've got the UX2 set to default device and default communication device and recording format set to 16bit 48000Hz.

    Also check the Line 6 Control Panel applet has input set to what you are using.
      My System SpecsSystem Spec


  8. Joined : Jul 2015
    Posts : 2
    Windows 10 Pro 64bit
       30 Jul 2015 #8

    Nus said: View Post
    In the Control Panel Sound I've got the UX2 set to default device and default communication device and recording format set to 16bit 48000Hz.

    Also check the Line 6 Control Panel applet has input set to what you are using.
    I've tried that, sadly it doesn't work. Input's set to mic1, the meters on the UX2 pick up the mic just fine if I have them set to Input or on the Send channels.. but it just gets messy at some point and it doesn't light up the bars on the Control Panel Sound options or on the apps I'm trying to use the microphone with (OBS being the most important here).

    I can use Mumble in WASAPI, haven't tried Skype yet but I'm guessing it's going to fail.

    I'll retry installing the drivers and checking permissions as some of the other stuff I've tried to run in w10 that failed boiled down to silly permissions issues. Would be greaaat if it were that.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Favourite Current TV Shows
Apart from being on the PC the TV is another thing I spend to much time watching As a big Stephen King fan I was pleased to see the start of Series/Season 2 of Under the Dome start this week (not sure if its finished or not in the US now) I...
Chillout Room
AMD released new drivers which should work with Windows 10 build 10122
601809947274452992 https://www.tenforums.com/tutorials/4807-windows-update-check-install-windows-10-a.html
Windows 10 News
Are you going to get windows 10 or keep your current os or
Are you going to get windows 10 release or keep your current os or something else.
General Support
HTML: What's wrong with this line?
Want to use an image as a link to an image but nothing shows. Paths are correct. There's not even that broken image icon to show that it can't find the images... it just shows nothing. And I know this works cos I did it before but somethings...
Chillout Room
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:27.
Find Us
Twitter Facebook Google+



Windows 10 Forums