1.    30 May 2017 #1

    ASM106x SATA Controller in Win10 Device Manager


    Hi,
    I am struggling with a PCI -E x 1 expansion card. The card provides SATA-3 connectivity and I cannot get my Win10 system to recognise it properly (I think). I have connected an external hard drive (which is in a SATA supporting enclosure) to one of its sockets, but the hard drive is not recognised by my system. If I use a USB-2 connection instead, the drive is recognised. The expansion card is an ASMedia 1061and I have installed the latest Win10 driver for it. Having done so, I see that in Win10 Device Manager an 'Asmedia 106x SATA Controller' is now listed under 'Storage Controllers', whereas the driver installation instructions from ASMedia insist that it should appear under 'IDE ATA/ATAPI controllers'. When I left click on 'Asmedia 106x SATA Controller'/Properties, all seems to be well - the Events tab shows that the device Configured, Installed and Started. No errors are shown.
    Should the item really be under 'IDE ATA/ATAPI controllers' and if so, how do I get it there? My motherboard is a Gigagbyte GA-P35-DS3L using AHCI (which is demanded by the installation guide for the card).
    Any suggestions would be appreciated - ultimately, if I can get the thing to work at all, I want to connect a SATA SSD to one of the internal connectors on the expansion card.
    Last edited by jameswesthead; 30 May 2017 at 11:08.
      My ComputerSystem Spec
  2.    31 May 2017 #2
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    I don't think you will normally see 'IDE ATA/ATAPI controllers' in a modern system. Maybe you do if you connect an old optical drive or something. So I don't think that the new SATA device showing up in Storage Controllers is a problem.

    You say you are trying to connect a "SATA supporting enclosure". I'm not clear on what this is. You could be referring to an external hard drive in it's own case, or an actual external enclosure- one that allows you to connect multiple hard drives. Please clarify this.

    It would be best to simplify your setup to test the card. This means connecting a single bare hard drive directly to the card using a standard SATA data cable, and powering the drive from one of the PC's power supply SATA connectors.
    This eliminates a lot of connectivity problems. You just want to know if the card is installed and works.
      My ComputerSystem Spec
  3.    31 May 2017 #3
    Join Date : Jul 2015
    Posts : 9,356
    Windows 10 Pro

    Quote Originally Posted by TV2 View Post
    I don't think you will normally see 'IDE ATA/ATAPI controllers' in a modern system. Maybe you do if you connect an old optical drive or something. So I don't think that the new SATA device showing up in Storage Controllers is a problem.
    I'm curious if you looked in your device manager before posting this?

    Click image for larger version. 

Name:	Capture.JPG 
Views:	1 
Size:	59.2 KB 
ID:	137480
      My ComputerSystem Spec
  4.    31 May 2017 #4
    Join Date : Jul 2015
    Posts : 9,356
    Windows 10 Pro

    I don't have one of these cards/controllers, but the readme file for the driver says:

    6. From the Device Manager, look for an entry named
    'Storage controllers'.
    If this entry is present, expand it and look for one of
    the following controllers:

    - 'Asmedia 106x SATA Controller'
    If the Controller above is present, no further action
    is required.

    - If this controller is not present, then your system
    is not in AHCI mode. No other modes are supported by
    the Asmedia 106x SATA Host Controller Drive software and you
    should continue with step 7 below.
    When you connect the drive to it, are you connecting the hard drive itself to the SATA port, or are you connected it through the enclosure? I would try taking the hard drive out of the enclosure and connecting the hard drive itself directly to the controller card, and, of course, a power cable from the power supply. It might be the enclosure that is interfering.
      My ComputerSystem Spec
  5.    31 May 2017 #5

    Many Thanks


    I feel rather embarassed.

    The device came with documentation for an old driver that referred to Windows Vista - and in that documentation the instruction was to look for the installed controller to be mentioned in Device Manager under 'IDE ATA/ATAPI controllers'.
    When I downloaded the new driver and its documentation, I didn't check that particular bit of the document, and so didn't see the change
    .

    So, yes, it does appear under 'Storage Controllers'.
    It had not occurred to me that the enclosure for the hard disk might be at fault - I have used it with an external SATA lead to connect it to a SATA 2 expansion card in the past with no problems. Now, of course, it is SATA 3.

    I will disassemble the thing and do as you suggest.
    Thanks for the help.
      My ComputerSystem Spec
  6.    31 May 2017 #6

    Even More embarassed but grateful


    Thanks Guys .. I have just connected my 'C' drive to one of the internal headers on the expansion card, and it works just fine..
      My ComputerSystem Spec
  7.    31 May 2017 #7
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    Great!
    Now on to figuring out what's up with that external drive. Could be just a cable.
      My ComputerSystem Spec
  8.    31 May 2017 #8
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    Quote Originally Posted by NavyLCDR View Post
    I'm curious if you looked in your device manager before posting this?

    Click image for larger version. 

Name:	Capture.JPG 
Views:	1 
Size:	59.2 KB 
ID:	137480
    I did!
    I'm all SATA here baby!
    *
    Click image for larger version. 

Name:	Capture.JPG 
Views:	16 
Size:	42.2 KB 
ID:	137540
      My ComputerSystem Spec
  9.    31 May 2017 #9
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    I have an older desktop with a P6T motherboard, running the same version of Windows 10. It has the IDE/ATAPI Controllers.
    I think it just has to do with the chipset architecture.
    *
    Click image for larger version. 

Name:	Capture.JPG 
Views:	12 
Size:	47.5 KB 
ID:	137552
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Xbox One Controller Not Working, Not In Device Manager
Hey so I am having a bit of a problem here. I got a new Xbox One over the weekend and decided to use it on my PC for some of my PC games as well. However, it simply does not work. It was listed in Device Manager, so I decided to right click and...
Gaming
Solved USB capacity incorrect in Win10 Explorer-Correct in Device Manager
Hi- Got a weird issue...8GB usb drive shows 7.8 GB free in Device Manager, but only 45mb available to write to in Explorer. I have tried every formatting/reformatting option available in Paragon Partition manager with zee-ro luck. I work in...
Drivers and Hardware
No SSD boot from external SATA 3 controller
Hello, Nice place here :) My problem is as follows: I have a flawless AHCI installation of Windows 10 Home on Samsung 850 EVO SSD plugged to SATA 2 native port/controller at my motherboard Gigabyte GA-E7AUM-DS2H (GeForce 9400 chipset, F4...
Drivers and Hardware
ASM106x Sata Driver
Hello I have an ASUS Maximus VII Hero... It would seem ever since installing the Asmedia SATA Controller Driver V3.1.6.0 driver my 1 TB internal has issues.... as in it will be I quote from the event viewer "Disk 1 has been surprise removed" ...
Drivers and Hardware
Second SATA drive showing in BIOS but not Device Manager
I've just added a 2nd HD to my Dell system with Win 10. It shows in the BIOS and Seagate tools finds it. It does not show up in Device manager or Computer Management/Storage - Disc Management or anywhere. Not sure if this si Won 10 specific. Anyone...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:02.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums