1.    29 May 2017 #1
    Join Date : May 2017
    Posts : 4
    Windows 10

    [solved] drive/partition totally missing after errant diskpart clean


    I think like other folks who've come here, I have a relatively similar issue: I wanted to wipe a flash drive (in my case, because the 16GB drive had been formatted on mac os, so it didn't work w/ windows), went to diskpart, selected what appeared to be the small flash drive and did "clean." This for whatever reason instead made my 2TB "file install" drive disappear.

    The reason I created a new thread is because I haven't seen my case elsewhere: I've actually lost the drive letter, the partition, and any sign that the drive exists. it no longer appears in device manager, in my bios boot menu, and so on. It DOES appear when I boot via the MiniTool Power Data Recovery Boot Loader (as in, when I boot that executable from a flash drive)--and not within that MiniTool's Windows version, nor within EaseUS Partition Master. Same goes for Testdisk; when I load that, it only shows my Windows system drive (along with any USB stick I have inserted), not the 2TB drive.

    I thankfully had all important files on my 2TB drive backed up, so losing them wouldn't be the end of the world. But now I can't even use the drive! I would love some help figuring out what exactly I did and how to at least access the drive again, if not recover any/all of its 2TB of data. I only did "clean," not "clean full," so my hope is the drive's data (which is apparently not being touched by computer, since it doesn't exist) has been sitting unperturbed for the past few hours while I've been wondering what the heck is going on.I'm happy to send screenshots or other info as needed/requested. I'm relatively knowledgable about computers, but clearly I'm not a genius, since I dabbled with diskpart :-0 and would probably benefit from some ELI5 (explain like I'm 5) help. I have Hiren's Boot CD ready to do tests/etc, but I don't wanna start messing w/ that when I'm unsure which of its apps, if any, would be of use.THANK YOU IN ADVANCE!

    (x-posted from sevenforums.com since I technically run win10, but have seen the issue at both forums)

    UPDATE: After unplugging and replugging the drive with different cables, it was recognized by Windows again. I booted straight into testdisk, let it run a deep analysis, then simply booted back into Windows and had the drive back. Perhaps an electrical or connection issue happened when the "clean" command was issued. Unsure what happened. Will leave this up for anyone else who runs into my exact twist on the issue. Thanks, all.
    Last edited by samred; 30 May 2017 at 12:00. Reason: solved
      My ComputerSystem Spec
  2.    29 May 2017 #2
    Join Date : Jul 2015
    Posts : 9,411
    Windows 10 Pro

    I would look at data recovery software such as:
    Recover deleted or lost hard drive partitions by 3 steps

    The clean command just erased the partition table on the drive - which is supposed to have a backup that data recovery programs can access.

    If you repartition the drive, and reformat the newly created partition you will have access to the drive itself again, but that will ruin your chances of restoring the previously existing partition.
      My ComputerSystem Spec
  3.    30 May 2017 #3
    Join Date : May 2017
    Posts : 4
    Windows 10
    Thread Starter

    Quote Originally Posted by NavyLCDR View Post
    I would look at data recovery software such as:
    Recover deleted or lost hard drive partitions by 3 steps
    The problem w/ that software is the same that I have already listed with other things I've checked: the drive doesn't APPEAR. I see my C: drive and any USB drives I've plugged in, but my original D: drive doesn't exist for the Easus Data Recovery Wizard. So, I don't even have an option of overwriting my old files this way. Thanks for the suggestion, though.
      My ComputerSystem Spec
  4.    30 May 2017 #4
    Join Date : Jul 2015
    Posts : 9,411
    Windows 10 Pro

    If you run:

    diskpart
    list disk


    Does it show up there?
      My ComputerSystem Spec
  5.    30 May 2017 #5
    Join Date : May 2017
    Posts : 4
    Windows 10
    Thread Starter

    Quote Originally Posted by NavyLCDR View Post
    If you run:

    diskpart
    list disk


    Does it show up there?
    no, it does not. the only place I've seen the 1.84TB drive appear, with that capacity confirmed, is when I boot my PC via the MiniTool Power Data Recovery Boot Loader (as in, when I boot that executable from a flash drive).
      My ComputerSystem Spec
  6.    30 May 2017 #6
    Join Date : May 2017
    Posts : 4
    Windows 10
    Thread Starter

    Well, this is interesting: A friend suggested I switch my drive cables after this all went down. I did so and..... voila, the 2TB drive returned, as evidenced by the BIOS. I didn't even let Windows boot, I booted straight into testdisk and am running a deep scan on the drive right now, which will hopefully be done by the time I wake up. I gotta figure out the next steps after this part...
      My ComputerSystem Spec
  7.    30 May 2017 #7
    Join Date : Apr 2017
    Posts : 8,839
    windows 10 professional version 1607 build 14393.969 64 bit

    This is information from Microsoft technet on diskpart clean versus diskpart clean all:

    clean

    Removes any and all partition or volume formatting from the disk with focus. On master boot record (MBR) disks, only the MBR partitioning information and hidden sector information are overwritten. On GUID partition table (GPT) disks, the GPT partitioning information, including the Protective MBR, is overwritten; there is no hidden sector information.

    clean [all]

    Specifies that each and every sector on the disk is zeroed, which completely deletes all data contained on the disk.

    DiskPart Command-Line Options


    If your 2 TB drive is GPT then you need software that can restore GPT partitioning information and the overwritten MBR. It was not clear to me but I think the GPT partition was also ovewritten.
      My ComputerSystem Spec
  8.    30 May 2017 #8
    Join Date : Mar 2016
    India
    Posts : 197
    Windows 7 Ultimate 32bit

    Restoring a Disk after an accidental diskpart clean


    Restoring a disk on which diskpart clean is accidentally performed is a fairly simple task. We have done this in many cases in Seven Forums. What I was wondering when you posted it in Seven Forums: How on earth can a disk vanish by just performing a diskpart clean? Impossible. That cannot be the reason for your disk totally vanishing and becoming invisible. Thank your friend who asked you to change the cable and bring it alive on the system. The cable had become faulty with your handling. Diskpart clean did not do the damage to the cable.

    While TestDisk also can do the job of restoring sector 0 , it is very difficult for a novice to handle. I wouldn't advise a novice or someone who is not acquainted with TestDisk to go with TestDisk.

    Restore using Partition Wizard Free 9.1:

    1. When a diskpart clean had been performed, the disk will appear as Unknown, Not initialised and Unallocated in the Windows Disk Management and ask to be initialised. Do not initialise. Just cancel.

    2. Run Partition Recovery Wizard - Quick Scan in MiniTool Partition Wizard Free 9.1, and it will find all the lost/deleted partitions. Put a tick mark to select the partition/partitions and click on Finish. ( Version 9.1 can be downloaded from here http://www.filehorse.com/download-pa.../old-versions/ In later versions Partition Recovery is not free - you have to buy a license.).

    3. In the main screen, right click on the partition/s and assign a drive letter.

    4. Click on Apply in the top menu bar. Done. Your disk is restored.

    Click image for larger version. 

Name:	31-05-2017 08-00-28.jpg 
Views:	1 
Size:	287.0 KB 
ID:	137406
    Attached Thumbnails Attached Thumbnails 31-05-2017 08-18-38.jpg   31-05-2017 08-35-38.jpg  
    Last edited by jumanji; 01 Jun 2017 at 22:22.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
How to sign an existing partition to EFI partition with diskpart
I was trying to install linux on my UEFI mode windows 10 laptop couple days ago, unfortunately there's something went wrong during the installation process, the grub directly wrote data in my win10 system boot partition. Luckily I saved my data and...
Drivers and Hardware
Windows 10 partition/drive missing after merging
During merging 2 drives my laptop took a force restart. Then after merging the drives with easeus My drives are not showing in My computer and also cannot access it through disk management. How to solve the problem? 68707
Drivers and Hardware
Drive partition is missing
So here is my issue I had Windows 10 installed on my Asus which I had Upgraded from Windows 8. However lately my computer was running slow and unresponsive at times. I figured I would do a Factory Reset and start new on it to try and fix these...
General Support
Solved I Have a new Boot partition on my c drive after clean install
After a complete re-install of win 10 I noticed I had this new boot partition. this is on a MBR drive BTW In my BIOS I can choose to boot to either the drive or the boot Manager. Both work ! So what is the reason for the boot manager ? ...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:41.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums