Logitec K750 Keyboard

Page 2 of 2 FirstFirst 12
  1. Caledon Ken's Avatar
    Posts : 20,109
    Windows 10 Pro x64 Version 1909
       #11

    Sounds like you have tried albeit through a different method.

    When I install in compatibility mode I right click the exe, then properties, then compatibility tab. I set to mode and click Apply, then okay. Then I execute exe.

    I think your best bet will be a logitech forum as there will be a concentration of owners experiencing this as Creators Update rolls out.

    I wish I had more to offer.

    Maybe another member will have additional ideas.


    Ken
      My Computer

  2. TairikuOkami's Avatar
    Posts : 4,116
    Home 2004 x64 10.0.19041.264
       #12

    Have you tried Intel USB port? VIA does not officially support 10, it might theoretically cause issues.

    In regards to that, make sure, you have all drivers updated. Driver Easy Free is good in detection.

    I had problems with Setpoint after CU related to outdated VisualC, it would not hurt to update it.

    Visual C++ Runtime Installer Download
      My Computer

  3. sygnus21's Avatar
    Posts : 4,032
    Win 10 Pro (x64) 1909 18363.836
       #13

    Agree about visiting the Logitech forums, though in all honesty, I find the Logitech forums completely useless at times since many posts go by unanswered.

    I also agree there needs to be an update to the Setpoint software which can be buggy at times. I won't lie and say I've never had issues, though nothing like what the OP is experiencing.

    Anyway despite my misgiving see what Logitech's forum has to offer. And that's a good idea about updating C++. Couldn't hurt.

    Peace
      My Computers


  4. Posts : 1
    Windows 10
       #14

    Hello, just found same exact issue here after upgrading to Win 10 from Win 7.

    While tweaking around I discovered that unpairing and re-pairing the keyboard to a different USB port seems to make Solar App behave.
    I just tried to attach the keyboard to the same port it was connected to before the re-pair, still no go.
    So, on Win 10, it seems some chemistry between pairing and specific USB ports type (probably more the latter).

    I'm on a Dell Latitude laptop, the port on which the kb works is on the side of the PC while the one on which it doesn't work is on the back of the PC. Windows 10 Pro Fall Creator Update.

    Hope it helps,
    Mario
      My Computer


 
Page 2 of 2 FirstFirst 12

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:25.
Find Us




Windows 10 Forums