Page 1 of 3 123 LastLast
  1.    18 May 2017 #1
    Join Date : Aug 2016
    Posts : 373
    Windows 10 64 bit, 1703

    Asmedia USB 3.0 drivers installation failure.


    On a clean installation of Win 10 1703 I'm having an issue with the installation of the ASmedia USB drivers provided by Asus for my Z97-A mobo. The exact error message during installation is the Asmedia USB Host Controller was not found.

    I can't see any evidence manual or otherwise that the Z97-A actually has Asmedia USB controllers but because the driver is offered I assume it does...

    Microsoft appears to have installed "their" USB drivers as seen in Device Manager but I cannot verify whether these drivers are allowing full USB functionality, i.e. USB 3.0 etc. AIDA64 reports the controllers as

    USB2 Controller Intel Wildcat Point PCH - USB 2.0 EHCI Host Controller 1 and
    USB3 Controller Intel Wildcat Point PCH - USB 3.0 xHCI Host Controller

    I have the program usbtreeview and if I'm reading things correctly (not certain) all of the USB ports on my board are only doing USB 1.0 speeds.

    I don't recall having any issues with mobo supplied USB drivers prior to Win 1703. Has anyone got any ideas? I'm not certain as to what USB drivers Microsoft has installed but there is a reference to Asus in one of the driver details boxes in Device Manager for USB Root Hub (USB 3.0) USBHUB3.SYS and ASUSFILTER.SYS.
      My ComputerSystem Spec
  2.    18 May 2017 #2
    Join Date : Sep 2014
    DFW Area
    Posts : 439
    Windows 8&10

    There is a Z97-a/USB3.1 which would be the newer board. Do you know which one you have?

    New builds can introduce problems, but you may want to uninstall the current drivers and install again. They are Win 10 drivers and ASUS is normally pretty good about keeping their drivers current, although those are from 2016..


    Other drivers may also be needed. Chipset drivers may have the 2.0 drivers on which the 3.0 drivers ride.
      My ComputerSystem Spec
  3.    19 May 2017 #3
    Join Date : Oct 2014
    Trnava
    Posts : 2,857
    Windows 10.4 Home 1709 x64

    Quote Originally Posted by Kol12 View Post
    On a clean installation of Win 10 1703 I'm having an issue with the installation of the ASmedia USB drivers provided by Asus for my Z97-A mobo.
    You need to install Intel Chipset INF first, otherwise devices will not be properly recognized.

    Downloads for Intel® Chipset Software Installation Utility

    Download ASMedia xHCI Host Controller Driver 1.16.45.1 for Windows 10, Windows 10 64 bit
      My ComputerSystem Spec
  4.    19 May 2017 #4
    Join Date : Aug 2016
    Posts : 373
    Windows 10 64 bit, 1703
    Thread Starter

    That's interesting, I'm not sure how to identify my board and I can't find the release date of the USB3.1 board, but I'm going to guess mine is the older board just because 3.1 doesn't ring a bell for me.

    Under the spec page for the USB3.1 Z97-A it specifically states it having an Asmedia USB controller whereas the older Z97-A doesn't, but on the older boards driver download page it offers the Asmedia USB drivers dated the same as available for the 3.1 board. Maybe my board doesn't have an Asmedia controller at all, and maybe the drivers were put on it's download page by mistake? May need to contact Asus on this...

    If not a mistake then perhaps the drivers do have an issue with Win 10 1703 and need updating... Do the chipset drivers actually contain USB drivers or just some of the information needed? Do most boards generally require a dedicated USB driver?

    Any idea what USB drivers Microsoft has installed? Intel Wildcat would suggest the controllers are Intel no?
      My ComputerSystem Spec
  5.    19 May 2017 #5
    Join Date : Aug 2016
    Posts : 373
    Windows 10 64 bit, 1703
    Thread Starter

    Quote Originally Posted by TairikuOkami View Post

    My mobo page suggests I download Intel chipset version 10.1.1.7 dated 23/07/15 which I already have installed. Do I need the newer version?

    The ASmedia driver you linked to looks current, any idea why Asus don't have the updated driver? Is this driver likely to be more successful?

    Is it best to uninstall any currently installed driver version before attempting the new installation?

    Edit: If it makes any difference, all of my USB ports appear to be working, I just can't verify they're operating optimally...
      My ComputerSystem Spec
  6.    19 May 2017 #6
    Join Date : Oct 2014
    Trnava
    Posts : 2,857
    Windows 10.4 Home 1709 x64

    Quote Originally Posted by Kol12 View Post
    The ASmedia driver you linked to looks current, any idea why Asus don't have the updated driver?
    Motherboard manufacturers only post drivers, they have tested, they do not bother updating, since it takes time and money, especially on older products. They expect users to update them as needed.
      My ComputerSystem Spec
  7.    19 May 2017 #7
    Join Date : Aug 2016
    Posts : 373
    Windows 10 64 bit, 1703
    Thread Starter

    Does it seem odd that the Z97-A spec page doesn't mention Asmedia as a USB controller but has the Asmedia drivers? The Z97-A USB3.1 model that Saltgrass brought up does state Asmedia controller.

    I will try installing the Latest Asmedia drivers and see how it goes.
      My ComputerSystem Spec
  8.    20 May 2017 #8
    Join Date : Aug 2016
    Posts : 373
    Windows 10 64 bit, 1703
    Thread Starter

    I've had someone over at the Asus forums tell me there is no Asmedia USB controller on the Z97-A. The Asmedia drivers on it's download page must be a mistake. This is where all of the confusion started.

    I believe the Z97-A controllers are Intel. Windows has installed Intel USB drivers that appear to be current, dated 27/4/2017

    From this screenshot of USB Device Tree Viewer can someone tell me where my USB 3.0 ports are? I saw something that said H stands for high speed and S stands for superspeed. Would a 3.0 port only show as be connected if the device was USB 3.0 compatible?

    This is the from the Asus Z97-A spec page for USB:

    Intel® Z97 chipset :
    6 x USB 3.0/2.0 port(s) (2 at back panel, blue, 4 at mid-board)
    Intel® Z97 chipset :
    8 x USB 2.0/1.1 port(s) (2 at back panel, , 6 at mid-board)

    What does mid-board mean? I have 4 blue USB ports at the back of the board which should be USB 3.0. My Logitech G710+ and Corsair Sabre are plugged into these ports but according to USB DTViewer they obviously not USB 3.0

    windows - Verifying USB connection speed (USB 3 or USB 2?) - Super User

      My ComputerSystem Spec
  9.    20 May 2017 #9
    Join Date : Sep 2014
    DFW Area
    Posts : 439
    Windows 8&10

    I checked the drivers available for your system for Win 7 and 10. Since I believe ASUS owns ASMedia, it might be the basic drivers for Win 10 are in Win 10 but the 3.0 part is from ASMedia since that is the only USB drivers shown available for Win 10.

    On my X99 system I show an ASMedia eXtensible Host Controller. My X99 board does show ASMedia in the Specs..

    It should not hurt to try to load the drivers?
      My ComputerSystem Spec
  10.    20 May 2017 #10
    Join Date : Oct 2014
    Trnava
    Posts : 2,857
    Windows 10.4 Home 1709 x64

    I believe, it is used for USB Boost.

    Upgrade Your ASUS Motherboard For Ultimate-speed USB3.1
      My ComputerSystem Spec

 
Page 1 of 3 123 LastLast


Similar Threads
Thread Forum
(W10 AU)Asmedia USB3.0 Drivers failing to verify
i've had to disable driver signing before to get USB Support back when i switche dto this new ASUS Crosshair V Formula gaming motherboard, seems windows randomly on it's own re-enabled it. even after uninstalling the devices from device manager and...
Drivers and Hardware
Windows 10 Version 15063 Installation Failure
Just tried to install Version 15063 on my main machine and it failed. It got to 88% of the installation when the spinning circles stopped like the machine locked up. I left it for 20 minutes before giving up & hard rebooting. It did a repair to...
Installation and Upgrade
Kernel security check failure during installation
I've tried updating to 10 a few times over the last couple of months - I've tried updating all my drivers as I've seen that suggested elsewhere but it hasn't helped so far. Any help would be appreciated. 57148
Installation and Upgrade
Asmedia 1074 USB hub drivers
My Asrock X99 OC Formula uses Asmedia 1074 USB hubs to add USB3 ports. (These aren't USB3 controllers; they're simply hubs.) I believe that these include the USB3 front panel ports. I think that I have a problem with those. My Seagate external...
Drivers and Hardware
Solved Hyper-V installation causes boot failure
Hello all. James here. I'm trying to setup Hyper-V, using Kari's tutorial. After I select the modules, Windows installs them and asks for a reboot. I oblige and then the system loops. I have tried three times and have had to restore all three...
Virtualization
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:41.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums