Page 1 of 2 12 LastLast
  1.    13 May 2017 #1
    Join Date : May 2017
    Posts : 5
    Windows 10 Pro 64-bit (1703)

    Can't Rename Drive Label in Windows 10


    I have named my USB flash drives (G,H) in Disk Management, but they continue to be unnamed in Windows Explorer.

    Click image for larger version. 

Name:	Windows10DiskManagement.jpg 
Views:	3 
Size:	139.4 KB 
ID:	134904

    I've tried everything in this tutorial: How to Rename Drive Label in Windows 10 without success. The only thing that does work is to set a default label for each drive in the registry.

    Click image for larger version. 

Name:	Windows10RegistryEditor.jpg 
Views:	2 
Size:	40.5 KB 
ID:	134903

    I've read several Win7 articles stating various USB problems can be resolved by uninstalling all the controllers under Universal Serial Bus controllers in Device Manager. Then restart and let Windows reinstall them as needed.

    Click image for larger version. 

Name:	Windows10DeviceManager.jpg 
Views:	42 
Size:	53.7 KB 
ID:	134906

    Question: Would this be a safe/reasonable thing to do in Windows 10? Any other suggestions?

    Thanks in advance,
    Mike

    HP ProBook 450 G3
    Windows 10 Pro 64-bit (upgraded from Windows 7 Pro 64-bit)
    Intel Core i7-6500U (Skylake)
    16GB DDR3 PC3-12800
    Last edited by mcw53; 14 May 2017 at 00:01.
      My ComputerSystem Spec
  2.    14 May 2017 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,992
    Win 10 Pro (1703)

    Hi, try rt clicking the drive in file explorer.
    Properties
    Then fill in the label name (yellow field in my screenshot).
    Click image for larger version. 

Name:	Snap 2017-05-14 at 07.39.53.jpg 
Views:	34 
Size:	17.0 KB 
ID:	134908

    Note the name reverts to Removable Drive if you rt click the named drive, and click Eject.

    (The one useful trick with removable drives if you use them for backups e.g. in Disk Management is to assign a drive letter late in the alphabet so they are most probably assigned the same letter next time (assuming nothing is using that drive letter) ).
      My ComputerSystem Spec
  3.    14 May 2017 #3
    Join Date : May 2017
    Posts : 5
    Windows 10 Pro 64-bit (1703)
    Thread Starter

    Thanks. But as I said, all 5 options in the tutorial I referenced failed. That was Option #2.
      My ComputerSystem Spec
  4.    14 May 2017 #4
    Join Date : May 2017
    Posts : 95
    Windows 10 Pro

    Click image for larger version. 

Name:	rename external.jpg 
Views:	36 
Size:	42.9 KB 
ID:	134912

    Try the steps in the jpg. You will lose all data though so backup first if required.

    also could try here How to a Flash Drive, SD Card, or Internal Drive to Fix Partition and Capacity Problems

    HTH
      My ComputerSystem Spec
  5.    14 May 2017 #5
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,992
    Win 10 Pro (1703)

    You can of course try uninstalling all the controllers under Universal Serial Bus controllers in Device Manager as you say. Whether that will help is trial and error of course. Good luck.

    Basic question- were you previously able to assign labels to these drives, but now find you can't?

    Note some had this problem in earlier builds of Win 10, and I found this comment: (Dec 16)
    Have you tried other drives? I only had this problem with Seagate USB Drives. I have had no difficulty changing names in File Explorer on drives by other makers (such as WD). Possibly a compatibility issue exists with Seagate and Windows 10.
    2014:
    It could be SanDisk's fault too. After Win 8 came out their new flash drives showed up as a fixed drive in Explorer. They have since corrected that. Their claim was to certify them for Win 8, they were wrong.
    Last edited by dalchina; 14 May 2017 at 02:56.
      My ComputerSystem Spec
  6.    14 May 2017 #6
    Join Date : Aug 2015
    Raleigh, NC, USA
    Posts : 1,589
    Windows 10 Pro x64

    Have you tried a third party utility such as MiniTool Partition Wizard (free)?
      My ComputersSystem Spec
  7.    15 May 2017 #7
    Join Date : May 2017
    Posts : 5
    Windows 10 Pro 64-bit (1703)
    Thread Starter

    Problem Resolved


    I ran diskpart as suggested by @jl2509. This allowed me to name my removable USB drives via ThisPC Rename & Properties, Command Prompt, PowerShell and autorun.inf file. I elected to go with the autorun.inf file and created an icon for each drive. I formatted one drive NTFS and the other FAT32.

    Click image for larger version. 

Name:	Windows10Diskpart.jpg 
Views:	29 
Size:	44.0 KB 
ID:	135067

    Click image for larger version. 

Name:	Windows10DiskManagement2.jpg 
Views:	1 
Size:	109.9 KB 
ID:	135068

    Click image for larger version. 

Name:	Windows10Autorun.jpg 
Views:	29 
Size:	18.4 KB 
ID:	135069

    Click image for larger version. 

Name:	Windows10ThisPC.jpg 
Views:	1 
Size:	61.4 KB 
ID:	135070

    Just what I wanted, until ... I restarted my laptop. Got the following error on restart: "An operating system wasn't found. Try disconnecting any drives that don't contain an operating system. Press any key to restart".

    I removed the 2 USB drives and was able to restart the laptop. Pressing any key didn't work ... the only "key" that worked was the power button.

    Did a little research and discovered what setting a partition as active means. So I inactivated them with the following diskpart commands:

    list disk
    select disk 1
    list partition
    select partition 1
    inactive

    All is good now. Thanks jl2509
      My ComputerSystem Spec
  8.    15 May 2017 #8
    Join Date : May 2017
    Posts : 95
    Windows 10 Pro

    Ah, sorry about that.
    The active partition is for running windows from the USB drive. Thinks they are bootable
    Just for reference, omit the line "Active" from the process supplied.

    Good you are all fixed.

    Cheers
      My ComputerSystem Spec
  9.    15 May 2017 #9
    Join Date : May 2017
    Posts : 5
    Windows 10 Pro 64-bit (1703)
    Thread Starter

    Update: How the original problem occurred


    I have a stand-alone offline Windows XP SP3 system. Occasionally I move data between my laptop and that system with a USB flash drive. I did this today with my newly formatted FAT32 drive. I could not eject the drive from the WinXP system (device busy), so I just removed the flash drive. When I inserted it back into the laptop, the original problem reoccurred. The drive was unnamed and the autorun.inf file was gone, at least not visible. When I tried to recreate the file, I got a dialog box saying the file already existed and asked if I wanted to replace it. But, no matter how many times I clicked [Yes], the same dialog box was re-displayed.

    Any idea what's going on with my WinXP system?
      My ComputerSystem Spec
  10.    16 May 2017 #10
    Join Date : May 2017
    Posts : 95
    Windows 10 Pro

    Hi,

    Sounds like a handle process is still accessing the usb drive, probably due to cache information that was not yet written to the disk. Try terminating the explorer process in the task manager or run powershell in admin mode and type taskkill /f /im explorer.exe

    See then if you can eject the hardware
    This may be a driver compatibility issue or just plain old process handler not releasing.

    Back in the day, people rebooted the XP system to release as all handlig process were completed prior to shutdown/restart then remove before reboot.
    Bit of a pain though....

    Sorry i'm not that familiar with Windows XP now.
    Difficult to say if the USB drive is actually 100% compatible with Windows XP too!


      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved Dymo Label Manager PnP Label printer
Hi. Just bought on of these Dymo Label Manager PnP Label printer Dymo S0915390 Label Manager PnP Plug and Play Label Maker: Amazon.co.uk: Office Products It states plug and play.When I connected it to my windows 10 upon opening the auto run I get...
Drivers and Hardware
Hardware & Drivers Rename Physical Drive in Storage Pool for Storage Spaces in Windows 10
How to Rename Physical Drive in Storage Pool for Storage Spaces in Windows 10 Storage Spaces helps protect your data from drive failures and extend storage over time as you add drives to your PC. You can use Storage Spaces to group two or more...
Tutorials
Windows 10 Updates Rename Folders And Will No Longer Let Me Rename
Every time I get one of these involuntary updates from Microsoft, my PHOTOGRAPHS folder is renamed MUSIC. The folder icon changes also. Up to now it has merely been a nuisance. But after the most recent update, the RENAME option disappeared from...
Windows Updates and Activation
2nd hard drive in CD bay has no volumn label but healthy @ WIndows 10
DELL E6410 CD bay hard drive, I used an used windows format 2.5" hard drive, at power on an option Intel menu can choose mirror or non-mirror and it remains in non mirror mode. Windows 10 computer management shows it as disk1 healthy, but no drive...
Drivers and Hardware
Hardware & Drivers Change Drive Label Name in Windows 10
How to Rename Drive Label in Windows 10 A drive name or drive label is a unique name of up to 32 (NTFS) or 11 (FAT) characters assigned to a drive, disc, or other media connected to the computer. Every drive and storage device on your computer...
Tutorials
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 23:38.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums