"Safe to remove" pop-up does not appear.

Page 3 of 3 FirstFirst 123

  1. Posts : 162
    Windows 10 Home
       #21

    Geosammy said:
    @Mcd73165

    You're welcome.
    Ever since I made this setting change. It has continued working, without any issues.
    Much appreciated!
    Mark
      My Computer


  2. Posts : 1
    Windows 10
       #22

    Fix for Windows 10 1809 USB "Safe to remove" Pop-up Missing


    I have tried the various recommended fixes to the USB "Safe to Remove" dialog not appearing after installing Windows 10 Version 1809 (October 2018 Update). Nothing worked. The true fix for this is to install Windows update KB4476976, which just came out on January 18th. This fix works even with background apps turned off.

    For details, see:

    https://techdows.com/2019/01/windows...kb4476976.html
      My Computer


  3. Posts : 162
    Windows 10 Home
       #23

    FrustWin10User said:
    I have tried the various recommended fixes to the USB "Safe to Remove" dialog not appearing after installing Windows 10 Version 1809 (October 2018 Update). Nothing worked. The true fix for this is to install Windows update KB4476976, which just came out on January 18th. This fix works even with background apps turned off.

    For details, see:

    https://techdows.com/2019/01/windows...kb4476976.html
    I don't have version 1809 yet. Still have version 1803. The info you gave will be helpful if I ever get the 1809 update delivered. Thanks for that.
    Mark
      My Computer


  4. Posts : 100
    Windows 10
       #24

    Geosammy said:
    I found a solution, which worked for me.
    For the 'Safe to remove' pop-up issue and for notifications not showing,
    within Windows 10, Build 1809's Action Center.

    It goes like this:

    Step 1. Go to > Settings > Privacy

    Step 2. App Permissions > Background Apps.
    Toggle ‘Let apps run in the background’ switch to off.
    Restart computer. (action center not showing previously or new notifications)

    Step 3. Go back to the settings page, previously mentioned in step 1 and 2.
    Toggle the ‘Let apps run in the background’ switch to on,
    as described in Step 2.
    Restart once again.

    Action Center is now showing notifications.
    As well as the "Safe to remove" pop-up for flash drives without issues.

    Attachment 212740
    Thanks for this...Fixed it for me running insider preview 19628.
      My Computer

  5. Geosammy's Avatar
    Posts : 668
    Win 10 1909 (OS Build 18363.836)
       #25

    imaddicted2u said:
    Thanks for this...Fixed it for me running insider preview 19628.
    I'm glad this helped to fix your issue.
    I'm also surprised that after nearly 3 years this fix still works.
      My Computer

  6. storageman's Avatar
    Posts : 907
    Windows 10 Pro 1909 18363.836
       #26

    Geosammy said:
    I'm glad this helped to fix your issue.
    I'm also surprised that after nearly 3 years this fix still works.
    George, don't be surprised, this problem is so common an its not like its a simple setting to just go fix it. It really works effectively. I hope it continues to fix this issue in the future.
      My Computers


  7. Geosammy's Avatar
    Posts : 668
    Win 10 1909 (OS Build 18363.836)
       #27

    storageman said:
    George, don't be surprised, this problem is so common an its not like its a simple setting to just go fix it. It really works effectively. I hope it continues to fix this issue in the future.
    I was reluctant to post, given that my post count was at 666.
    However, lets see how long this fix will continue to work.
      My Computer


  8. Posts : 100
    Windows 10
       #28

    Geosammy said:
    I'm glad this helped to fix your issue.
    I'm also surprised that after nearly 3 years this fix still works.
    I can't really say when the notification/popup stopped working, I just noticed it this morning. I wanted to come back and relay another oddity. After I posted it was fixed, I had only put a USB drive in once and then safely removed it. A few minutes later I put it back in but this time after removing it I got the notification...but no popup. I tried a couple of more drives and SD cards and all showed the notification but no popup. I restarted again and now the notification and popup are working right again. I must have put the drives and SD cards in 50 times to confirm it kept working. At least now I know what to do if the bits get mixed up again...lol
      My Computer

  9. Geosammy's Avatar
    Posts : 668
    Win 10 1909 (OS Build 18363.836)
       #29

    imaddicted2u said:
    I can't really say when the notification/popup stopped working, I just noticed it this morning. I wanted to come back and relay another oddity. After I posted it was fixed, I had only put a USB drive in once and then safely removed it. A few minutes later I put it back in but this time after removing it I got the notification...but no popup. I tried a couple of more drives and SD cards and all showed the notification but no popup. I restarted again and now the notification and popup are working right again. I must have put the drives and SD cards in 50 times to confirm it kept working. At least now I know what to do if the bits get mixed up again...lol
    That's interesting to know and thanks for the update.
      My Computer


  10. Posts : 162
    Windows 10 Home
       #30

    I have version 1909 now. The problem still happens on both of my pc's. Previously tried the Background Apps solution and it really didn't do anything. A reset of Windows Explorer fixes problem until it happens again. The only thing that is affected is the Safely Remove Hardware pop up not showing. All other notifications show up in the action list. The next time the problem happens I'll try the Background Apps solution again.
    Mark
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:21.
Find Us




Windows 10 Forums