1.    11 May 2017 #1
    Join Date : May 2017
    Posts : 2
    Win10

    Windows driver issue with Akai MPK49 Midi controller - Code 28


    Hi,

    I'm trying to get my Akai MPK49 midi controller working with Windows 10. The controller was working on my system around 6 months ago but for some reason, it's no longer being recognized correctly by Windows.

    The device is class compliant, so it should work with drivers that Windows 10 already has and does not require 3rd party drivers.

    When I go to the device manager, instead of appearing under Sound, video and game controllers, it appears under Other devices with a (!) symbol next to it. Here's a screenshot:
    Click image for larger version. 

Name:	9489b157109b24de2242a800741577a2.png 
Views:	2 
Size:	46.4 KB 
ID:	134605


    When I go to the Properties I see this:
    Click image for larger version. 

Name:	1f188ae6fefe6f687ba9bd3ab2b0885d.png 
Views:	16 
Size:	14.3 KB 
ID:	134606


    I've been in contact with the manufacturer of the device and they've helped me troubleshoot the issue as best they can, but it seems as if this is a Windows problem and not at all a problem with the device. I have tested the device with another computer running Windows 10 and it works perfectly. You can read the thread here to see some of the things I've already tried: Akai MPK49 not working anymore on Windows 10 / FL Studio



    Any ideas?

    I've put about 8 hours into trying to fix this The last resort is reformatting and reinstalling Windows, and I really don't want to do that.

    Thanks!
    Aaron
      My ComputerSystem Spec
  2.    13 May 2017 #2
    Join Date : May 2017
    Posts : 2
    Win10
    Thread Starter

    The latest Windows 10 update solved my problem!
    I think it was a corrupted Windows file perhaps.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Marvell 92XX SATA Controller 6GB Driver for Windows 10 1.2.0.1039-WHQL
Marvell 92XX SATA Controller 6GB Driver for Windows 10 (x64) 1.2.0.1039-WHQL (9/5/2013 a.k.a. 6/19/2014) In Windows 10, the driver for the Marvell SATA Controller may not get installed automatically which leads us on a wild goose chase as to...
Drivers and Hardware
This device cannot start. (Code 10) High definition audio controller
Macbook pro early 2011 bootcamp was not willing to let the SSD run in AHCI mode in windows 10, so I did EFI installation of windows 10. Everything seems to work but the audio card. This device cannot start. (Code 10) in the High definition...
Drivers and Hardware
USB xHCI Compliant Host Controller - This device cannot start. Code 10
Hello, i'm new here and also kinda newbie when it comes to computers and fixing the issues associated with them, I'm not sure if this is the correct forum for me to be, but I'm here in hopes of finding the solution for my problem. So what happened?...
Drivers and Hardware
usb xhci compliant host controller (code 10)
Hi all, I noticed today that my USB3 do not work any more, and after checking device manager, can see a code 10 error for usb xhci compliant host controller I have tried un-installing and reinstalling this, but still the error. Trying to...
Drivers and Hardware
Solved Windows 10 USB Controller installation issue
So this past weekend I upgraded to Windows 10 from 7 and it went very well. I have a USB Microsoft Digital Media Pro Keyboard and IntelliMouse 2.0 wireless mouse, both of which were prompted to install the software suit first thing after Win10...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:47.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums