HP Deskjet 3520 doesn't print on W10 CU update


  1. Posts : 11,233
    Windows / Linux : Arch Linux
       #1

    HP Deskjet 3520 doesn't print on W10 CU update


    Hi there

    HP Deskjet 3520 Fails to print --drivers OK , machine OK -- print goes OK put nothing appears in print queue until you power off and then power on printer -- then print mysteriously appears.

    It's fine on a W7 X-64 machine VM stuff but I have to connect the print to a Linux Host - then the CUPS system prints it fine.

    The same behaviour whether printer is USB or Wirelessly attached.

    Previous version of W10 (pre CU update) - no problem.

    I know it's only a cheap rubbishy printer but it still works so I'm not going to buy a new one --I don't print much these days anyway. I would have thought though HP is quite a popular brand so it's a surprise I have to use either a previous version of Windows or a Linux OS to get the wretched printer to print documents.

    Cheers
    jimbo
      My Computer


  2. Posts : 265
    Windows 10 Enterprise
       #2

    Well Jimbo, it is either the driver or the OS is corrupt...from my experience. I had a friend who just bought a brand new HP ENVY 4520 printer, took it home and could not get it to print from his desktop. His laptop would print to via wireless and or USB cable without an issue. I show up, download the latest driver from HP and it would not install. Downloaded troubleshooter from HP, it said it found problems, fixed them, and then would not install the driver. No matter what I would do, it would just not work. I kept trying all of the normal stuff, uninstall, deleted HP folders from the harddrive and the Registry and it would still not work. Then, as I was browsing through the event logs, I noticed it had an error on updating Windows. Noticed that Windows update hadn't been updated in a long while...decided that was more of an issue than the printer.

    Since he was going on vacation for a month or two, I had him drop his desktop and printer off at my house. I put his wireless printer on my network, my windows 10 saw it and installed the printer without any issues. So I knew for sure it was the OS.

    I reinstalled the OS, ran all the updates (they all installed fine), and the printer installed automatically without me having to do anything. So, somewhere along the line, Windows update had quit updating and therefore; the printer software would not install.

    AS you said, you don't print much anymore that tells me you have two options. One, reinstall the OS or TWO print it to a pdf file and then use your Linux VM or your Windows VM and then print the file.

    Anyway, that is how I solved my problem...by reinstalling the OS. I know this wasn't an answer you were hoping for but you like me have been around long enough to know...sometimes these computers just don't make sense.
      My Computer


  3. Posts : 11,233
    Windows / Linux : Arch Linux
    Thread Starter
       #3

    Hi there

    Installed it as a shared Network printer on the Linux VM. (True network printer rather than via Wireless - it's attached to the VM via a USB cable).

    Set the cups option (printer) for the printer as RAW so Windows will do the rendering e.g printing spreadsheets etc before sending the data to print.

    In your smb file for samba set as follows for the printer :

    in the global section

    load printers = yes
    cups options = raw

    ; printcap name = /etc/printcap
    # obtain a list of printers automatically on UNIX System V systems:
    ; printcap name = lpstat
    ; printing = cups


    In the shares section
    [printers]
    comment = All Printers
    path = /var/spool/samba
    browseable = no
    guest ok = no
    writable = no
    printable = yes


    Now working perfectly from Windows as well !!!!!! - the only drawback is the VM needs to be up -- but it's a tiny overhead.

    HP Deskjet 3520 doesn't print on W10 CU update-networkpr.png

    I don't want to re-install the OS - I'll wait for the next Windows major build update so I'm marking this as Solved -- well at least a useable solution !!!.

    Cheers
    jimbo
    Last edited by jimbo45; 11 May 2017 at 06:38.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:50.
Find Us




Windows 10 Forums