Page 1 of 2 12 LastLast
  1.    08 May 2017 #1
    Join Date : Feb 2017
    Home
    Posts : 479
    Windows 10 Home x64, V1709 (16299.64)

    WD Elements 2 TB Drive Problem


    Another thread (External Hard Drive (WD Elements) is visible in PW but not in explorer) prompted me to post this.

    I've got the WD Elements External drive connected with a USB cable. Love it, works great. Until I burn a DVD with the OEM burner in the pc. At which point Windows disables the WD drive, with the message "Windows detected a problem & disabled the device". My only remedy has been physically disconnect, power down everything, reconnect and power up (WD Elements first) then the system. Everything works properly until the next DVD burn. I don't make many DVDs anymore.

    Device Manager lists it as Mass Storage. It requires no driver, however Windows uses a Microsoft driver for it. I've checked on updating that one with no success.

    I just ran the WD Data Lifeguard Diagnostics and the drive passed. Anyone got any ideas here.
      My ComputersSystem Spec
  2.    08 May 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,963
    Windows 10 Pro Build 1703

    Hi Clayton

    When this happens what kind of events are being log? I would hope the event manager may have better detail.

    When you connect your external drive is this through a port on front of machine or one integrated to Motherboard at rear. Where I'm heading, USB power output.

    Ken
      My ComputerSystem Spec
  3.    08 May 2017 #3
    Join Date : Aug 2014
    Forever West
    Posts : 3,921
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    I don't see such an issue with my 3 WDC MyBook drives. Are you burning data directly from the USB drives? Do you have the issue if first copying the data to the internal drive? Does the drive have its own power supply? Is it plugged into a USB 2.0 or USB 3.0 port? Of the 3 MyBook drives I have 2 are USB 2.0 and 1 is USB 3.0. I have to agree with Caledon Ken about power from the USB ports relating to Windows controlling the ports.
      My ComputerSystem Spec
  4.    08 May 2017 #4
    Join Date : Apr 2015
    Posts : 12,811
    W10Prox64

    I think Ken may be on to something here. I had an optical drive once that was doing all sorts of crazy things to a system. Turned out to be an internal cable "going" bad. Once I replaced the data cable, all was well.
      My ComputerSystem Spec
  5.    08 May 2017 #5
    Join Date : Feb 2017
    Home
    Posts : 479
    Windows 10 Home x64, V1709 (16299.64)
    Thread Starter

    This started with the first disc I burned a couple of days after initial installation of the WD External drive. Took me a few minutes to figure it out. But it is repeatable. Every time.

    USB 3.0 Controller, 2 front ports are 3.0 and the rear ones 2.0. WD drive has it's own power supply and connected in the rear. Says it's good for 2.0 or 3.0.

    Looking at Event Logs, I found nothing that I could identify. But bear in mind, I don't know much about what I'm looking at there anyway.

    Burning the DVDs is done with files from the HDD and no involvement from the WD external. It's only used for a backup device. And written to several times a day following whatever I may work on. FWIW, write caching is not enabled on any of the ports.
      My ComputersSystem Spec
  6.    08 May 2017 #6
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,963
    Windows 10 Pro Build 1703

    When error occurs click on clock and get exact system time. You should be able to match against a couple of events in System and Application logs. The event or surrounding events should have some of the same words of the error message you reported.

    Since device has it own power that pretty much rules out USB port power.
      My ComputerSystem Spec
  7.    08 May 2017 #7
    Join Date : Apr 2015
    Posts : 12,811
    W10Prox64

    Is there any clue in Reliability History?
    Maybe an IRQ conflict?
      My ComputerSystem Spec
  8.    08 May 2017 #8
    Join Date : Jan 2015
    Posts : 672

    One wild thing to try: assign the CD/DVD reader/writer/burner drive letter I (i); assign that WD HD whatever drive letter you want, it uses the same usb port each time, correct? I'm probably sawing off my own tree limb in this thread for this situation, however, after I assigned a few drive letters to internal and external devices, they seemed to not disappear so much, stayed around much more.
      My ComputerSystem Spec
  9.    08 May 2017 #9
    Join Date : Feb 2017
    Home
    Posts : 479
    Windows 10 Home x64, V1709 (16299.64)
    Thread Starter

    These are from the last DVD event:

    Click image for larger version. 

Name:	$CDROM.PNG 
Views:	39 
Size:	13.2 KB 
ID:	134176
    Burning the DVD

    Click image for larger version. 

Name:	$ERROR.PNG 
Views:	5 
Size:	81.0 KB 
ID:	134177
    Attempting to access the WD External Drive

    Click image for larger version. 

Name:	$EVENT.PNG 
Views:	39 
Size:	13.2 KB 
ID:	134179
    That discovery of the disabled drive?

    Edit:
    From the date I wrote on that last DVD, these are the only events I could find for that time frame.
    Last edited by CWGilley; 09 May 2017 at 08:44.
      My ComputersSystem Spec
  10.    09 May 2017 #10
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 3,963
    Windows 10 Pro Build 1703

    I looked up this error and added the words Western Digital.

    In most articles I read it pointed to updating driver or an issue with device.

    You could run WD tools against drive but I doubt that any failure would be detected, you yourself said it runs great until you try to burn DVD. This would leave you with a driver issue or one of the issues previously mentioned like cables or conflicting IRQ.

    Not sure on how you track down IRQ conflict. Other members?


    Edit 1:

    You might also head into device manager and look at the properties for your WD drive. There should be a "Policy" tab. You could change to "Better Performance" to see if that stabilizes.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved External Hard Drive (WD Elements) is visible in PW but not in explorer
My WD Element HDD is not working after I plug it in to my WDTV unit. I tried to recover my files using PW but I'm unable recover it can anyone please help me.. How it shows in Explorer 130854 but it does not appear in Disk Management ...
Drivers and Hardware
Solved Photoshop elements 9 not compatible with windows 10?
I had an hp computer that ran windows 7. I went ahead and upgraded it to windows 10. This computer also ran Adobe Photoshop Elements 9 that I received free with an Epson scanner. I recently upgraded to a new computer. Still hp. Came with Windows...
General Support
Exporting in Adobe Prem 11 Elements causes WHEA_UNCORRECTABLE_ERROR
This could be anything, but I wonder if it can be caused by C: being overly-full ... (only 18GB left on a 250 GB SSD). Regardless, I suspect that there is a hardware problem somewhere, since I am able to render the Adobe video on my laptop running...
BSOD Crashes and Debugging
one drive problem
since updating to 10159 and then 10162 every time I click on photo in menu it starts up for about 5 seconds and then shuts down with no error message
General Support
Microsoft overhauls its homepage with larger images, modern elements
Source
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:40.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums