WD Elements 2 TB Drive Problem

Page 2 of 2 FirstFirst 12

  1. Posts : 1,097
    Windows 10 Home x64 Version 1809 (OS Build 17763.437)
    Thread Starter
       #11

    Hey Ken. I did run WD Lifeguard Diagnostics on it and it passed. Hadn't thought about changing performance. I'll look at it. WD says it doesn't use a driver, however Windows assigns a Microsoft Driver and it's the latest. Who knows? Things do go bump in the night.

    Just updated to CU, soon as I finish rummaging around I'll see if maybe it works now.
      My Computer


  2. Posts : 9,762
    Windows 10 Home 64bit Version 21H2
       #12

    Just a thought. What burning software are you using to burn your DVD? Uninstall it and burn your DVD with some other program. Check whether the problem goes away.

    The other suggestion you can try: Connect your optical drive to some other slot on your motherboard. Give a drive letter like X,Y,Z etc., so that your external drive does not come into drive letter conflicts.
      My Computer


  3. Posts : 1,097
    Windows 10 Home x64 Version 1809 (OS Build 17763.437)
    Thread Starter
       #13

    Good morning jumanji. I have no idea about the software, hadn't given it a thought. It's whatever Dell uses as a PnP burner. The CU install yesterday fixed a couple of minor glitches that I had and I'm hoping the same can be said about this one. I'm going to test it out this morning and will report back. And I may open it up and try your suggestion about moving the connection on the m-board.
      My Computer


  4. Posts : 1,097
    Windows 10 Home x64 Version 1809 (OS Build 17763.437)
    Thread Starter
       #14

    OK, I've been holding off on ending this one. Since Creators Update, DVD burner AND Elements External HD both work like they're supposed to.

    Thanks to everyone that contributed trying to help. I do appreciate it.
      My Computer


  5. Posts : 27,447
    Windows 10 Pro x64 Version 21H1
       #15

    That's good news.
      My Computer


  6. Posts : 1,097
    Windows 10 Home x64 Version 1809 (OS Build 17763.437)
    Thread Starter
       #16

    Thanks Ken. Actually CU "fixed" several what I'll call minor issues.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:19.
Find Us




Windows 10 Forums