Kingston 4GB Pendrive do not work any more.


  1. Posts : 99
    Windows 10
       #1

    Kingston 4GB Pendrive do not work any more.


    When I insert my pendrive in Laptop or Desktop PC, it shows on in My Computer but when I try to open it, it says " Please insert disk into USB Drive". When I right click on the drive and want to format, it says there is no disk in the drive. When I go into Disk Management- it shows no media and Change Drive Letter and Eject are greyed out. Properties shows as 0 space.
    Tried using third party Partitioning Softwares but they do not show the drive at all.
    Also tried Diskpart to clean the drive but it shows- no disk.
    Please help me repairing this pendrive. Please advise step by step method.
    Thanking you in anticipation
    Ashok
      My Computer


  2. Posts : 19,241
    W11+W11 Developer Insider + Linux
       #2

    It's seams it's dead. Only it's controller is working.
      My Computers


  3. Posts : 14,604
    Windows 10 IoT
       #3

    0 space usually means its failed.
      My Computer


  4. Posts : 1,366
    Windows 10 Pro x64
       #4

    These are incredibly convenient to use, but are also unreliable. Even ones from a quality brand like Kingston will can die.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:42.
Find Us




Windows 10 Forums