1.    16 Apr 2017 #1
    Join Date : Jul 2015
    Posts : 25
    Insider Preview 10130

    (W10 AU)Asmedia USB3.0 Drivers failing to verify


    i've had to disable driver signing before to get USB Support back when i switche dto this new ASUS Crosshair V Formula gaming motherboard, seems windows randomly on it's own re-enabled it. even after uninstalling the devices from device manager and the drivers thru the installer and restarting (its weird even the Default drivers by windows throw the Same Error O-o.) does not fix it i HAVETO disable driver signing :/

    not looking forward to haveto do this everyso often. anyone else encounter this and have been able to solve it?

    edit: should mention when i swapped boards i did NOT clean install/"Reset This PC"
      My ComputerSystem Spec
  2.    16 Apr 2017 #2
    Join Date : Apr 2015
    Posts : 229
    Windows 10 x64 v1703

    I think the problem might be the ASUS driver itself. When i look at the the digital certificate from Microsoft for the driver files, it just expired 10 days ago! Apr 6, 2017. Not sure how smart the digital sig checks are. Try back dating the date on your computer before you try installing again.

    just my best guess
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Asmedia 1074 USB hub drivers
My Asrock X99 OC Formula uses Asmedia 1074 USB hubs to add USB3 ports. (These aren't USB3 controllers; they're simply hubs.) I believe that these include the USB3 front panel ports. I think that I have a problem with those. My Seagate external...
Drivers and Hardware
BIOS not detecting USB3 pen drives in USB3 Hub
When I open the BIOS the pen drives plugged into the USB3 hub are not listed in the "Boot priority settings", however, if a pen drive is plugged directly into the PC USB3 or USB2 port it appears in the "Boot priority settings". Once booted into...
Drivers and Hardware
Failing to replace failing laptop hard drive
Toshiba C55 series with a failing hard drive. My first attempt was to clone the drives using my Acronis True Image 2015. Formatted the new drive and placed in the PC. Old HD in a USB drive enclosure. Booted from the TI "Bootable Rescue Media.."...
Performance & Maintenance
USB3 HDD slower in USB3 socket than powered USB2 socket
Hi there crazy --I have a laptop with 1 USB3 socket and 2 USB2 sockets. The USB3 socket is also a "charging" usb socket. Now if I plug a USB3 HDD (Toshiba) into a USB2 socket where I've connected a powered USB2 hub I'm getting copy speeds of...
General Support
Gigabyte GA-78LMT-USB3 rev. 6.0 USB 3.0 drivers not detecting hardware
Essentially, I want windows default usb 3.0 drivers again, as they worked, and the gigabyte ones currently don't for windows 10, Where can i find the generic usb 3.0 drivers? I have already troubleshooted by looking in Device Manager (It cannot find...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:51.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums