1.    15 Apr 2017 #1
    Join Date : Mar 2017
    Posts : 42
    win10

    For long, the problem of safely eject never solved


    I have been researching on web and trying different third party tool but none of them actually works.

    A lot of time, not always though, I can't safely eject USB portable hard drive. However, I am 100% sure that no files on that drive is running. It's probably the hard drive being occupied by
    something in the background that I don't know.

    The problem of not safely ejecting is that the hard drive keeps spinning vigorously (I can feel) unless it's safely ejected. Every time if the hard drive can be safely ejected , I can feel by touch that the spinning stops immediately and I can feel safe to unplug the USB cable.

    What is the real solution ? Or if there is actually no real solution to this problem?
      My ComputerSystem Spec
  2.    15 Apr 2017 #2
    Join Date : May 2014
    Cross Plains, WI
    Posts : 315
    Windows 10 Pro x64

    Try using Unlocker to release the drive. Point it to the root of the drive and see if it finds anything to unlock. The drive may have some handles to it open yet even if nothing else is going on with it.
      My ComputersSystem Spec
  3.    15 Apr 2017 #3
    Join Date : Jul 2015
    Posts : 873
    Windows 10 Home

    Yes, annoying problem. Few things you can try. Device may be suspended. Here's how to disable (ignore last part if icon always appears) -
    USB Devices Not Staying Connected

    For current device eject - Win+R; rundll32 shell32.dll,Control_RunDLL hotplug.dll ,Enter

    You can also create a shortcut by r-click on desktop>New>Shortcut.
    Put rundll32 shell32.dll,Control_RunDLL hotplug.dll in 'Type the location of the items>Next and name it, like 'Safely eject' and you have a backup method if nothing else works. Good Luck
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Cannot eject safely usb external drive
Hello, The problem of beeing unable to eject the usb drive safely still exists, the only way I found (temporarily) is to disable it in the device manager, but then the change asks to restart the computer, if I do not restart, the drive is unabled....
Drivers and Hardware
Cannot eject safely an external USB drive
Hello, Recently I bought one "WD Elements" 1TB external drive for data storage. When attachet it to the pc, it was found by the file explorer, it is already NTFS formated, one whole partition. On it found "WD Smartware pro trial" installer and an...
Drivers and Hardware
Solved Cannot safely eject Seagate usb Expansion Drive
I got my new Seagate 2 TB Expansion Drive and made the first image of my new laptop (running Win 10 anniversary build) using Macrium Reflect. All went well, and I closed Macrium, then attempted to eject the external drive from the notification area....
Drivers and Hardware
Have to safely eject thumb drive exactly twice every time
This amounts to an annoyance only, but I thought I'd ask in case someone has a solution. I find I always have to eject my thumb drive exactly twice. This happens on at least two laptops: A Toshiba Satellite with Windows 10 Home 10586.545 ...
Drivers and Hardware
Solved Safely Remove Hardware and Eject Media won't go away
My Hard Drive crapped the bed recently, it was 4 and a half years past warranty so it served more than its fair share of time :p But I grabbed a nice new Samsung 850 Evo SSD, reinstalled windows and all of my stuff (since the disk was in REALLY...
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:40.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums