Page 3 of 6 FirstFirst 12345 ... LastLast
  1.    18 Apr 2017 #21
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    Yikes!
    Another Seagate saga? Et Tu Gigabyte?
      My ComputerSystem Spec
  2.    19 Apr 2017 #22
    Join Date : Apr 2017
    Posts : 11
    Windows 10
    Thread Starter

    Ok after flashing my BIOS back to F5 version, btw really worry about it because maybe it could break my BIOS, now except for the USB issue everything is working properly, no more bsod or instabilities, but not USB 3.1 either.
    Now after flashing my BIOS back I lost my Mac address in the BIOS(out off topic if anyone knows how to fix this)
    Gigabyte state I need BIOS version F21 to be able to install USB 3.1 drivers, but I can't use this one because It gives me issues to boot into window
    Do you think flashing the BIOS up and back can be safe?
    I tried all the solutions provided here, none of them have worked. Thanks very much for all your help anyway.
    By the way between those BIOS flashing I was able to install thunderbolt but when I started the computer say I need an update and open a web site to download it but my motherboad is not listed there.
    Identify your product, then click on the link below to go to the product page. Click on “Support and Downloads”. Choose “Utility” under Download Type and follow all directions. Remember to install the Thunderbolt driver before installing the Thunderbolt FW Update Tool.

    GIGABYTE - GA-Z170X-Gaming G1
    GIGABYTE - GA-Z170X-Gaming GT
    GIGABYTE - GA-Z170X-Gaming 7
    GIGABYTE - GA-Z170X-Gaming 7-EU
    GIGABYTE - GA-Z170X-UD5 TH
    GIGABYTE - GA-X99P-SLI

    - See more at: https://thunderbolttechnology.net/updates#sthash.XPcfQCgo.dpuf
    Last edited by devyeah; 19 Apr 2017 at 05:58.
      My ComputerSystem Spec
  3.    19 Apr 2017 #23

    Try grabbing the modded USB 3.1 drivers from Fernando's exellent Win-Raid Forum: USB 3.0/3.1 Drivers (original and modded). I've found them to be uncommonly helpful in dealing with odd or interesting USB 3.0 and 3.1 driver issues on Windows PCs.
    HTH,
    --Ed--
      My ComputersSystem Spec
  4.    19 Apr 2017 #24
    Join Date : Jun 2014
    USA
    Posts : 1,570
    Windows 10 Pro x64

    Quote Originally Posted by devyeah View Post
    Ok after flashing my BIOS back to F5 version, btw really worry about it because maybe it could break my BIOS, now except for the USB issue everything is working properly, no more bsod or instabilities, but not USB 3.1 either.
    Now after flashing my BIOS back I lost my Mac address in the BIOS(out off topic if anyone knows how to fix this)

    See the next 3 posts starting here. Download the files then go here. Haven't actually done this myself, so If you do, let us know how it went. BTW it was stated that downgrading your BIOS using the ftp DOS method (which I assume you used) would overwrite the MAC address, which is why I'm hesitant to use it. .

    Gigabyte state I need BIOS version F21 to be able to install USB 3.1 drivers, but I can't use this one because It gives me issues to boot into window

    Not sure where you see you need the F21 BIOS to "install USB 3.1 drivers" but that's false. If that were the case, you wouldn't have been able to use the feature when the boards first came out.

    As for Secure Boot - Were you using Secure Boot before the BIOS update? Did you remember to reset you the BIOS for it. See my post here on properly setting up Secure Boot.

    Do you think flashing the BIOS up and back can be safe?

    Knowing what I know now, unless you plan on running a Kaby Lake Processor, I'd stay away from these updates. Too many weird issues happening. And I'm one to NEVER say don't update a BIOS.

    Remember to install the Thunderbolt driver before installing the Thunderbolt FW Update Tool.

    Definitely!!!
    My reply replies in red. The links are to the Gigabyte forums over at overclock.net.

    Peace
      My ComputersSystem Spec
  5.    19 Apr 2017 #25
    Join Date : Aug 2015
    Posts : 611
    W10 Home 1703

    It still would be nice to see what hardware we are dealing with.
      My ComputerSystem Spec
  6.    20 Apr 2017 #26
    Join Date : Apr 2017
    Posts : 6
    10

    Quote Originally Posted by EdTittel View Post
    Try grabbing the modded USB 3.1 drivers from Fernando's exellent Win-Raid Forum: USB 3.0/3.1 Drivers (original and modded). I've found them to be uncommonly helpful in dealing with odd or interesting USB 3.0 and 3.1 driver issues on Windows PCs.
    HTH,
    --Ed--
    anyone test it ?
      My ComputerSystem Spec
  7.    20 Apr 2017 #27
    Join Date : Jun 2014
    USA
    Posts : 1,570
    Windows 10 Pro x64

    What's wrong with the drivers that comes with the boards???
      My ComputersSystem Spec
  8.    20 Apr 2017 #28

    I've modded my own high-end desktops with these win-raid drivers and they work better than the stock MS drivers supplied by default.
    HTH,
    --Ed--
      My ComputersSystem Spec
  9.    20 Apr 2017 #29
    Join Date : Jun 2014
    USA
    Posts : 1,570
    Windows 10 Pro x64

    Quote Originally Posted by EdTittel View Post
    I've modded my own high-end desktops with these win-raid drivers and they work better than the stock MS drivers supplied by default.
    HTH,
    --Ed--
    How? Performance numbers to back that up?

    Anyway the issue is not the 3.1 drivers, but the flaky Gigabyte F21 BIOS update hosing stuff. It has noting to do with 3.1 drivers. And I know the OP mentioned he couldn't install the 3.1 driver until the update, but that's highly questionable stated in my reply to that statement.

    And yes, I run a Z170 gigabyte board supporting USB 3.1. And though I don't have any 3.1 devices, the port did work as advertised with both USB 2 and 3 devices... before the F21 BIOS was even a thought.
      My ComputersSystem Spec
  10.    21 Apr 2017 #30
    Join Date : Apr 2017
    Posts : 11
    Windows 10
    Thread Starter

    After flashing my BIOS again today to version F21 and even trying their more recent beta F21c I have to go back to version F5, I was able to install properly the thunderbolt driver and the USB 3.1 update tool, even if everything ran ok it didn't work, I turned off the computer for more than one hour (they suggest 30 sec) unplugged. I even remove the battery. When I got back into window now I had 2 unspecified devices to safety remove. Important to mention that Everytime I log into window a window showed up telling me that thuntherbolt need an update with a link to gigabyte website, the same place I downloaded the same driver, crazy.
    I ended turning off Thunderbolt in the BIOS and the 3.1 in device manager, now I have a motherboard that supposed to support USB 3.1 but seems not.
    I give up, the computer is running ok despite the USB issue, I learned the lesson with gigabyte and I hope soon be able to upgrade to an Asus and i7 7700k.
    Btw I was able to modify my Mac address with guide provided here, just read carefully because you can use that guide to upgrade your nic firmware but you don't need to touch that just the hex editor and the Intel tool, it worked like a charm.
      My ComputerSystem Spec

 
Page 3 of 6 FirstFirst 12345 ... LastLast


Similar Threads
Thread Forum
Windows Update with Metered connection fails: Creators Update 15063.0
It's dejá vu all over again. :doh: The correct behaviour of windows update over a metered connection is to offer the choice to download, or wait until on a non-metered connection. 128460 The initial build of the Anniversary Update broke...
Windows Updates and Activation
Windows 10 Creators Update and Creators Update SDK are Released
Source: Windows 10 Creators Update and Creators Update SDK are Released - Building Apps for WindowsBuilding Apps for Windows :arrow: Windows 10 Creators Update version 1703 (build 15063) now available from Windows 10 Update Assistant. ...
Windows 10 News
Visual Studio 2017 Update Preview and Windows 10 Creators Update SDK
Source: https://blogs.msdn.microsoft.com/visualstudio/2017/03/16/visual-studio-2017-update-preview-and-windows-10-creators-update-sdk/
Windows 10 News
Solved iPhone shown as Unspecified in Devices and Printers
I have a problem with my iPhone 5s/iOS 9.2.1 in Windows 10 Pro x64 Build 10586.71, as shown in the pictures: Although everything works OK, i.e. • iTunes v.12.3.2.35 recognizes it, backs it up and syncs it • I can see its content from Windows...
Drivers and Hardware
Windows 10 Anniversary Update Lock Screen Personal Pictures Not Shown
The personal picture in the circle or a local picture selected for the lock screen does not show up after the anniversary update. This only happens if the no-password option has been set. If you log out then the selected pictures are shown when you...
User Accounts and Family Safety
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:54.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums