1.    11 Jul 2015 #1
    Join Date : Feb 2014
    Scottsdale, AZ USA, 85254
    Posts : 315
    windows 10

    sound blaster in build 10166


    I can not get my sound blaster x-fi titanium pci express sound card to give me sound through the right channels even though Ive uninstalled the support pack for 5.1 surround audio that was compiled from another sb user that did work in the last build; and then reinstalled it. however; now under 10166; I cant get 5.1 surround audio and i cant get into the enhancements for my sound card. again it did work for a short time when I was running it under build 10162; but now that Ive switched to 10166; I dont have jack for audio and to add to it; I keep getting the message that says "the audio device supported by this application is not detected; setup will now close" or something to that extent. Anyone have any idea how to resolve this and whether or not ms will finally once and for all resolve these issues?
      My ComputerSystem Spec
  2.    11 Jul 2015 #2
    Join Date : Sep 2014
    Nashville, TN
    Posts : 3,143
    Windows 10 Pro

    Did you re-install the drivers under 10166? Soundblasters are notorious for needing to have their drivers re-installed for each new build.. it's been that way since Windows 98.. SB drivers have always been crap when upgrading.
      My ComputerSystem Spec
  3.    12 Jul 2015 #3
    Join Date : Feb 2014
    Scottsdale, AZ USA, 85254
    Posts : 315
    windows 10
    Thread Starter

    Quote Originally Posted by Mystere View Post
    Did you re-install the drivers under 10166? Soundblasters are notorious for needing to have their drivers re-installed for each new build.. it's been that way since Windows 98.. SB drivers have always been crap when upgrading.
    yes. I have re-installed the drivers and software and it still did nothing. Again; it did work under build 10162; but now i only get 2.1 sound only through 2 speakers.
      My ComputerSystem Spec
  4.    14 Jul 2015 #4
    Join Date : Feb 2014
    Scottsdale, AZ USA, 85254
    Posts : 315
    windows 10
    Thread Starter

    anyone?
      My ComputerSystem Spec
  5.    14 Jul 2015 #5

    Try this.
      My ComputersSystem Spec
  6.    15 Jul 2015 #6
    Join Date : Feb 2014
    Scottsdale, AZ USA, 85254
    Posts : 315
    windows 10
    Thread Starter

    I tried the above steps in the above link however; I am still not getting 5.1 surround audio under this latest build of 10166 even though Ive installed and uninstalled the newest drivers etc. compiled by a member on the sound blaster forums which apparently have worked for a lot of people except for me it seems.
      My ComputerSystem Spec
  7.    18 Jul 2015 #7
    Join Date : Feb 2014
    Scottsdale, AZ USA, 85254
    Posts : 315
    windows 10
    Thread Starter

    Well i seemed to have solved the enhancements not working issue and the surround sound issue. It was because I mistakenly installed the 3.4 support pack when that one was not designed for my sound card by daniel. So i went back, uninstalled that one and reinstalled the 3.3 support back and voila!; the sound was back to the way i was looking for. So this one is solved for now.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved No sound from sound blaster
I just installed the most recent windows 10 tech preview last night; but my sound blaster pci express sound card did not get installed correctly or something because i am getting no sound at all. Please help me fix this before I roll everything back...
Drivers and Hardware
sound blaster on build 10240
I cannot get my surround 5.1 audio to work with this most recent build of 10240; and i cannot get into the enhancements that are supposed to be available for my card which is the x-fi titanium pci express sound card from creative. Is there any way...
Drivers and Hardware
What is the next build? 10166 runs too well
Seeking for the latest release? If 10176 is illegal then give me another release to test....
Installation and Upgrade
Build 10166. Taskbar bug? Help anyone?
Got a weird problem hope someone can help. I open up Battlenet launcher and it gives me a list of games. In my case it's World of Warcraft, Diablo 3 and Hearthstone. I click on WoW and the program icon goes to the taskbar showing that the...
Windows Insider
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:58.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums