1.    09 Apr 2017 #1
    Join Date : Jan 2016
    Not telling
    Posts : 17
    Windows 10 Pro 64-bit

    CanoScan LiDE 50 not working with Windows 10


    Hi,

    I'm trying to scan a test document with my CanoScan LiDE 50 and when I try to click Scan a message box pops up that says "Sources" with nothing in it. The buttons on my CanoScan also don't work.

    Please help.

    Thanks!

    Edit: I'm on the Windows 10 Creators Update if that helps
      My ComputerSystem Spec
  2.    09 Apr 2017 #2
    Join Date : Jan 2014
    Inverness
    Posts : 1,183
    Win 10

    Has this ever worked in Win 10?

    According to the Canon site this is the OS compatibility list
    OS Compatibility
    Windows® XP, 2000, Me, 98, Mac® OS 9.0 - 9.x, OS X v 10.1.x - 10.2.x
      My ComputersSystem Spec
  3.    09 Apr 2017 #3
    Join Date : Jul 2015
    Posts : 870
    Windows 10 Home

    I would uninstall and try to reinstall the software but this time, r-click the setup.exe, then 'Troubleshoot compatibility' and run in a prev Windows OS emulation, if needed.
      My ComputerSystem Spec
  4.    09 Apr 2017 #4
    Join Date : Aug 2014
    Forever West
    Posts : 3,921
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    I recently advised a client to get a new printer. Turned out their older HP unit worked fine in wife's Win10 Desktop but wouldn't in husband's new Win10 Notebook. Investigation of the problem revealed her Desktop had been Upgraded to Win10 from Win7 and was using the previously-installed Win7 drivers but the drivers for the new Notebook weren't available from either HP or Windows Update. HP didn't list newer drivers.
      My ComputerSystem Spec
  5.    09 Apr 2017 #5
    Join Date : Apr 2016
    Manchester, U.K.
    Posts : 549
    Windows 10 Pro 64bit

    Quote Originally Posted by TheAmazingGuy View Post
    Hi,

    I'm trying to scan a test document with my CanoScan LiDE 50 and when I try to click Scan a message box pops up that says "Sources" with nothing in it. The buttons on my CanoScan also don't work.

    Please help.

    Thanks!

    Edit: I'm on the Windows 10 Creators Update if that helps
    I suspect that it's no longer compatible. I had an HP 2400 scanner which worked until I clean installed the creators update, I found that although the driver installed the scanning software would fail, HP's website stated the scanner wasn't recommended for Windows 10. I tried compatibility mode which didn't work no matter which windows version I tried.
      My ComputerSystem Spec
  6.    6 Days Ago #6
    Join Date : Nov 2017
    Posts : 1
    win 10

    It is really annoying that canon won't come up with a working driver already, for all those scanners that are still working.

    I have solution for you but it is a bit tricky
    if you have a canon lide 50 this is another way of making it work on windows 10 64bit

    boot in advanced mode that requires no signatures for drivers (look elsewhere on how to do this)

    DONT PLUGIN THE SCANNER yet

    1. download lide #60# win7 64bit drivers [ lide60vst6411111a_64en- ]
    2. extract in folder you get a setupsg.exe file
    3. extract .exe file to a folder
    4. now you have a) cnql60 folder b) setupsg.exe
    5. run setupsg.exe as administrator (might help if it works in compatibility mode for win7)

    add windows>Twain_32>CNQL60 to your %PATH%

    after a lot of installing and uninstalling i got it to work, even with scangear 4.9 but i dont think you need SG4.9

    Sure it says canon lide 60 instead of 50 - but seriously, after 5 hours of trying to workaround this, who cares? =)

    I hope it will work for you, too.

    J
      My ComputerSystem Spec
  7.    6 Days Ago #7
    Join Date : Dec 2015
    Posts : 5,849
    Windows10

    In the end, canon will not support old devices. Frankly printer scanners are so cheap with faster scanning and probably better resolution, it is just better to scrap old scanner and move on.
      My ComputerSystem Spec
  8.    6 Days Ago #8
    Join Date : Jul 2014
    Serbia
    Posts : 10,415
    W10 Insider + Linux

    Try with drivers for Lide 100.
      My ComputersSystem Spec

 


Similar Threads
Thread Forum
Windows 10 copy and paste is not working. It stopped working
Hi, I am using Windows 10 with all the latest updates. Copy and Paste has stopped working. I am not able to copy and paste from anywhere e.g. In Notepad highlight a line and copy it and paste it. It will not paste anymore. In PyCharm as well,...
General Support
CanoScan LiDE 35 on Windows 10 x64
Got most of this info from the sevenforums.com, but thought I'd repost here. I was so happy to get this trusty old scanner working, I thought I'd share what worked for me. Original post for getting it working on Windows 8.x: Canoscan LiDE 35...
Drivers and Hardware
CANON LIDE 210 - problem with WIA/TWAIN
I own a Canon Lide 210 scanner since about 2011 which worked fine using WIndows 7 since then and still does. But after I upgraded all my computers (2 laptops and one desktop) to WIndows 10 it does not work anymore on the desktop to which it is...
Drivers and Hardware
Windows Spotlight not working, Weather live tile not working
Windows Spotlight isn't working, I've tried like all steps found in the Internet to fix it but I just can't get it to work. It was working great on TH2 but since I clean installed RS1 it hasn't worked not once! Anyone got any solutions I could try?...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:30.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums