Windows 10: USB Printing Support Missing From Device Manager

Page 1 of 2 12 LastLast
  1.    05 Apr 2017 #1

    USB Printing Support Missing From Device Manager


    A problem has just occurred when I can no longer use my Epson XP-520 printer, as the USB Printer Support is no longer showing in the Device Manager and therefore, unable to install the driver. The only way I can user printer is
    via the network driver.
    How do I correct this problem?
    Last edited by RogHil43; 07 Apr 2017 at 17:09.
      My ComputerSystem Spec

  2.    07 Apr 2017 #2

    Can anyone help me with this problem?
      My ComputerSystem Spec


  3. Posts : 318
    Windows 10 Pro x64
       07 Apr 2017 #3

    Is the printer still connected via USB? Have you checked the connections to make sure they are tight and secure? Have you tried a different USB port on the computer its connected to?

    If none of these work, remove the printer from the Devices and Printers window.

    Then go to the Device Manager and click on view, and select Show Hidden Devices.

    First disconnect the USB cord for the printer from the computer, then expand the Universal Serial Bus controllers field and find any USB Printing Support entries that are greyed out. If this is the only printer, this should be easy. Right click on the one that is greyed out and click Uninstall Device, then click uninstall.

    Make sure the printer is turned on and in ready state, then reconnect the USB cord for the printer to the same USB port on the computer that you had it connected to.
      My ComputersSystem Spec

  4.    07 Apr 2017 #4

    Could you be more specific to the actual sequence of events / what's going on when you try to install?
    • What happens when you try installing the driver? Is it the software install that fails with an error? What are the actual error message(s) that appear
    • I see several different drivers listed on the Epson site for your model. Could you give me a link to the one you're trying to install?
    • If it's the driver install that's failing, could you run it one more time? Then zip file C:\Winodows\inf\setupapi.dev.log and attach it to your next post
      My ComputerSystem Spec

  5.    07 Apr 2017 #5

    All I have on Universal Serial Bus is WSD Print=Epson 06F01E Epson XP-520 Series printer which I had to install to be able to
    use my printer again. There is definately no Printer Support showing but the in View Devices and Printers, it shows both the local printer and the network printer.
    When I try installing the local printer driver, it just hangs and nothing happens, I guess this is because it cannot find the Printer Support.
      My ComputerSystem Spec

  6.    08 Apr 2017 #6

    RogHil43 said: View Post
    There is definately no Printer Support showing but the in View Devices and Printers, it shows both the local printer and the network printer.
    When I try installing the local printer driver, it just hangs and nothing happens, I guess this is because it cannot find the Printer Support.
    Are you saying you see two different Epson printer icons in Devices and Printers?? One for the network, the other the local USB Epson printer? Is the local printer icon greyed out??

    That would imply the driver is installed but, if greyed out, the printer isn't detected. Is the USB cable securely attached? Try a different port. And the printer turned on.

    btw By default, Device Manager only displays detected devices (cabled and powered on). USB Printer Support won't appear in Device Manager until the local printer is installed and detected.

    If USB Printer Support driver were missing i'd expect the installation would error with "Driver not found". I believe hanging is a different issue. I saw several different downloads on the Epson site for your model.

    Are you installing a "driver only" download? (Not one that includes Epson utilities). And are you 32 or 64 bit Windows (doesn't say in your specs)
      My ComputerSystem Spec

  7.    08 Apr 2017 #7

    Currently,the network printer is greyed out but has the default tick. The local printer isn't greyed out.
    Changing ports doesn't make any difference, all connections are secure and that was one of the first things I checked.

    No, there is no message when installing driver, it just hangs halfway and doesn't do anything.

    I am using the 64 bit driver but will have a look at the download site. However, the installation disc downloads the latest drives and software, which I have already tried, but still with the same result.
      My ComputerSystem Spec

  8.    08 Apr 2017 #8

    Please run the following tool. It'll display info about all device drivers installed and might include info on the usb printer as well.

    • Download DevManview for x64
    • Extract the files to your Desktop. Double click the file to run DevManview.exe
    • Now Ctrl-A to select all then Ctrl-S to Save
    • Be sure to change Save as type to Tab Delimited Text (.txt) and save the file to your Desktop

    Attach the file to your next post

    Click image for larger version. 

Name:	Save As.jpg 
Views:	3 
Size:	61.3 KB 
ID:	129064
      My ComputerSystem Spec

  9.    09 Apr 2017 #9

    Attached is data from DevManview.
    USB Printing Support Missing From Device Manager Attached Files
      My ComputerSystem Spec

  10.    09 Apr 2017 #10

    I took a snapshot of and highlighted the rows of interest in DevManView

    It shows Epson drivers installed. It also shows USB Printing Support drivers installed (the second of the two USB Print Support rows is for your Epson printer). But it also says the printer wasn't detected at the time you ran the tool. Sorry, I forgot to have you turn on printer on before running the report. Sorry.
    Could you please run again with printer turned on?
    1. When you turn printer on/off are you hearing the USB connect/disconnect "ding-dong" sounds?
    2. Open Device Manager. Show hidden devices.
      • Anything change under the Printer or USB Categories as you turn printer on/off
      • When you turn the printer on, do you see an Unknown Device under USB?

      Click image for larger version. 

Name:	2017-04-09_230630.jpg 
Views:	4 
Size:	174.3 KB 
ID:	129243
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hey everyone, I'm using Windows 10 N Anniversary Update, the one with no media bloatware like WMP. However I wish my iPhone was accessible with File Explorer to copy photos. It turns out you have to install Media Feature Pack for Windows 10 N...
And so I cannot use a LAN connection, I can use wi-fi though. I've tried another LAN cable although I since found there is no LAN driver anyway. Windows 10 Anniversary Build, latest (I think). I can get LAN connection working OK on another...
Hi, title says it all. I'm having problems with my computer CD/DvD drive where its not shown in File Explorer As (D: ) or even shown in Device Manager. I have tried inserting a disk and ejecting it out and it works fine. However the drive is just...
Just installed this which I had on windows 7. I think it was this that slowed Win10 to a crawl. Black desktop, no task bar etc. Only way out was task manager to restart. Then found that windows 10 is not creating restore points for...
I basically just have a lot of random questions to be honest.. Probably easy for a lot of you! If you could work with me just a little bit that would be so much appreciated! For example: -BIOS help (x4,x1,auto for PCi) (Do I disable anything...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:38.
Find Us