Windows 10: USB 2.0 printer won't work in Win 10/USB 3.0

Page 1 of 2 12 LastLast

  1. Posts : 10
    windows 10 64 bit
       31 Mar 2017 #1

    USB 2.0 printer won't work in Win 10/USB 3.0


    For a couple of years I've been happily running a Seiko SLP 650 label printer with a USB 2.0 connection to my Win 10 USB 3.0 machine (maybe it's USB 3.1) and after the last update the printer will no longer work. The error message I get says something like 2.0 will not run in this 3.0 environment. Usually I just get "not working" messages but trouble shooting message says incompatible. I thought 3.0 was backward compatible. How can I fix this? Many thanks.
      My ComputerSystem Spec


  2. Posts : 3,922
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint
       31 Mar 2017 #2

    In theory USB 3.0 should be backward compatible but a lot depends upon the age of the printer, I have a client who tried an all-in-one older HP unit plugged into a USB 3.0 port that would lose communication with the computer after about half a page printed, no problem with a USB 2.0 port. I have a couple of older 8GB Thumb drives that can't be recognized in USB 3.0 ports, work fine in USB 2.0.

    As for fixing, since it's probably more of a hardware issue one can't do much about it. Might try a USB 2.0 Hub plugged into the USB 3.0 port, cheaper than a new printer or computer.
      My ComputerSystem Spec

  3.    01 Apr 2017 #3

    I've been through this with several USB 2.0 devices. The ONLY option I found was to install a PCIe USB 2.0 expansion card so I have USB 2.0 ports. I have an MOTU 896Mk3 Hybrid (USB 2.0 and Firewire interfaces), recording studio interface unit and it will work on a USB 3.0 port but has dropouts and will ONLY fully work on a USB 2.0 Port. It will not work on a USB 2.0 hub connected to a USB 3.0 port. I have a 3 1/2" Floppy diskette drive and it too will ONLY work on a USB 2.0 port, the same as the MOTU unit.
    Last edited by fireberd; 01 Apr 2017 at 08:19.
      My ComputersSystem Spec

  4.    01 Apr 2017 #4

    You may need to go into your UEFI/Bios settings and check to be sure that "USB Legacy Support" (or similar wording) is Enabled for both controllers (Standard and USB3.0).
    The setting is normally found under the Advanced Tab.

    Also you can try going into Device Manager > USB Serial Device Controllers > and for each USB Root Hub, right click > Properties > Power Management Tab > and uncheck the box to allow Windows to turn off the device to save power.
      My ComputerSystem Spec

  5.    01 Apr 2017 #5

    Interesting advice, but I wonder why the printer functioned under Windows 10 until a recent update.
      My ComputerSystem Spec

  6.    01 Apr 2017 #6

    If either of the procedures were to fix the problem, it would mean the update changed the settings.
    This shouldn't happen in a normal security update, but if it is an upgrade update, like the Anniversary Update, then a lot of settings go back to defaults.
      My ComputerSystem Spec


  7. Posts : 10
    windows 10 64 bit
    Thread Starter
       01 Apr 2017 #7

    bobkn said: View Post
    Interesting advice, but I wonder why the printer functioned under Windows 10 until a recent update.
    This is sure my question. I checked my UEFI/Bios Settings and they are normal.
    And TV2's suggestion of unchecking the power management settings has been done.....still a problem.
    Many thanks for the good suggestions and thoughts!
    I guess Fireberds suggestion of a dedicated usb 2.0 card is probably the best answer. But before I do that I'm going to open up my case and check the motherboard. I'm running an ASUS Z-97A MB which has only 3.0 connectors on the outside but it has a header on the board for 2.0 which I'm guessing is not connected anywhere (probably). But the simplest thing is to just add a 2.0 card. I've got a powered extension cable running to my Canon inkjet 4920 (a 2.0 device) and my Seiko SLP label printer and I'm almost positive I've got that extension cable plugged into the 3.0 jack figuring a 2.0 legacy device would be backward compatible...........but I guess not.
      My ComputerSystem Spec


  8. Posts : 3,922
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint
       01 Apr 2017 #8

    The USB headers on a motherboard are for adding just the sockets to the back of the case, don't need a card. But many motherboards have a short PCIe X1 slot for adding a card which usually is faster than the older PCI cards. The longer PCIe slot is usually X16 for video cards.
      My ComputerSystem Spec

  9.    01 Apr 2017 #9

    The problem remains.
    It was working in Windows 10, an update was installed, now it does not.
    It should be reversible.
      My ComputerSystem Spec

  10.    01 Apr 2017 #10

    A couple more suggestions:
    First, check to see if your motherboard manufacturer has a newer USB controller driver to install. If so, install it.

    Second, try reinstalling all the USB devices:
    Device Manager > Universal Serial Bus Controllers > Right click on each device listed underneath and choose Uninstall (you could leave anything related to USB 3.0 alone) > after you've cleared the list, restart Windows and they will all be reinstalled again.

    See if the printer will work after either of those.

    Also: unplug the USB cable to that printer before doing any procedures, then plug it in after Windows is back up running.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Hi Guys, I'm getting quite frustrated with this issue and wondering if anyone has seen it, and able to resolve the issue. The issue is I have a network printer selected as the default in Windows 10. I have the option "Let Windows manage my...
active directory domain service unavailable - Cant get printer to work My printer worked fine previously, then suddenly it failed to print, cant add as hardware, tried reinstalling driver and told cant get info from server... this is as simple...
printer spooler dont work! in Drivers and Hardware
i was trying to add a printer and i had the message that the printer spooler dont work! i tried 3 different ways manually via command prompt and via windows devices system and force start automatically but nothing. it cant start. some messages i got...
I've searched everywhere, uninstalled and reinstalled and it won't work. I've got my laptop networked to printer but it won't work either. I need help figuring out how to do that
I upgrades to Win 10 the the above network/wireless printer worked fine. I've now done a fresh install and it doesn't! The scanning function works but trying to print produces an error. I've been advised by Samsung support that their driver...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:15.
Find Us