Windows 10: Drivers needed for a Samsung mSATA 512GB SSD (PM841 ??)

Page 2 of 7 FirstFirst 1234 ... LastLast
  1.    30 Mar 2017 #11

    alphanumeric said: View Post
    Its an mSATA drive, he's getting a "no signed device drivers were found" message when trying to do a clean install. I think he needs the motherboard mSATA interface driver? He is trying to install from a USB connected optical drive. Help! Login has disappeared when I boot
    Yes. I am at the limits of my knowledge but I think I just need the correct drivers for my SSD. Annoyingly Samsung are refusing to help.
      My ComputerSystem Spec

  2.    30 Mar 2017 #12

    It's the driver for the storage controller on the motherboard you would need.
      My ComputerSystem Spec

  3.    30 Mar 2017 #13

    spunk said: View Post
    On which SATA port do you have the SSD plugged into on the Motherboard?
    If it is SATA port 1, the Bios is reporting that there is nothing installed on that port.
    Check the SATA cable is plugged into the back of the SSD and into SATA port 1 on the motherboard, And that a power plug from the PSU is plugged into the SSD.
    If that still doesn't work, try a different SATA Data cable a different Power Plug and or a Different SATA port on the motherboard.
    Be sure to set the Hard Drive Mode to AHCI as stated.
    Yes it is definitely an mSATA SSD drive.
    I don't know how to open up the laptop and am reluctant to do so in any case, because everything WAS working until a couple of days ago, it's just that the drive got corrupted.

    OK, In the BIOS under Advanced, I have changed AHCI Mode Control to "manual" and Set AHCI mode to "On".

    But still the laptop is failing to load windows on its SSD, and just says "All boot options are tried". It is failing to see the memory stick too. However I can get it to see USB DVD with Windows 10 on it - but it may take a couple of attempts in a row.

    How can I find out what drivers I need for my PC to see my SSD?
      My ComputerSystem Spec

  4.    31 Mar 2017 #14

    pparks1 said: View Post
    It's the driver for the storage controller on the motherboard you would need.
    OK so I need a storage controller for my motherboard.

    So where would I get that from?

    My laptop is on this link:
    13.3 Series 7 Ultra Notebook 128GB SSD NP740U3E | Samsung UK

    The documentation is here:
    http://downloadcenter.samsung.com/co...Manual_eng.pdf
    Unfortunately it fails to mention the word "motherboard"
    But the "main chipset" is Intel HM76 - is that the same thing?

    If so is that something I need to download from Intel?
      My ComputerSystem Spec

  5.    01 Apr 2017 #15

    pparks1 said: View Post
    It's the driver for the storage controller on the motherboard you would need.
    Would I get that from Intel or from Samsung? (Or Microsoft?!)
      My ComputerSystem Spec

  6.    01 Apr 2017 #16

    Samsung, under your Notebook drivers, if its available. It may be part of the chip-set (motherboard) drivers.
      My ComputerSystem Spec

  7.    01 Apr 2017 #17

    alphanumeric said: View Post
    Samsung, under your Notebook drivers, if its available. It may be part of the chip-set (motherboard) drivers.
    To get clear I would need special drivers for my exact model of PC, rather than find the correct chipset drivers on Intel.com, yes?

    If so I have a problem because there don't seem to be any drivers or downloads for my model (NP740U3E-S04UK) on 13.3 Series 7 Ultra Notebook 128GB SSD NP740U3E | Samsung UK...
      My ComputerSystem Spec

  8.    02 Apr 2017 #18

    If you boot from your USB thumb drive, and don't get that message, that changes things. To me it means its looking for drivers for the external optical drive, not the mSATA drive.
    Those messages just tell you enough to start scratching your head wondering why? Not nearly enough info to nail down what it wants.
      My ComputerSystem Spec

  9.    02 Apr 2017 #19

    1. Which model do I have?I have opened the back of my Samsung laptop to look at the SSD. I still can't work out what the "model" should be that I need to use to identify on the Samsung site.

    I took the back off the Samsung laptop in any case.Here is what the label on the 512GB SSD says:

    P/N: MZMTD512HAGL-00000
    S/N: S155NEAD602062
    Model: MZ-MTD5120/000 KCC-REM-SEC-MZ-MTD5120
    WWN:50025385503B7D35 1313 REV 0 F/W DXT4200Q
    Rated: DC+3.3v = 1.9A Samsung Electronics Co., LTD
    Product of Korea

    However, from my previous notes I have
    "PM841 Series MZMTD512HAGL-00000 mSATA 512GB SATA III MLC Internal SSD"
    Click image for larger version. 

Name:	delme-512GB-SSD.jpg 
Views:	1 
Size:	132.3 KB 
ID:	127771


    The problem is that Samsung talks about models like:

    Click image for larger version. 

Name:	delme-Samsung-Models.jpg 
Views:	16 
Size:	213.6 KB 
ID:	127770

    2. How do I run Samsung's software?Also, it looks like I need to run Samsung's "Magician" software.From what I can see I need to run it from DOS.- How do I boot the PC into DOS? - Can I just use the Windows 10 recovery memory stick I created with MediaCreationTool.exe, and use the Command Prompt that it creates?

    Is it "MZ-MTD5120/000" or "PM841 Series"

    Or do I need to create a special bootable DOS memory stick?

    I have tried getting Rufus (v2.12) to turn a memory stick into a bootable drive, but that doesn't seem to work either (i.e. I keep getting back to the screen called "All boot options are tried. Press <f4> " etc)

    With thanks

    J
    Last edited by ship69; 02 Apr 2017 at 12:54.
      My ComputerSystem Spec

  10.    02 Apr 2017 #20

    Microsoft Support pointed me to these links:
    http://www.samsung.com/semiconductor.../consumer.html

    1.
    I was trying to run Samsung's Magician Software. (on Tool & Software | Download | Samsung V-NAND SSD )
    ...And from what I could see it looked like it needed to be run from a DOS window.
    I managed to create a bootable memory stick using FreeDOS (with Balder)
    But when I tried to run Magician it, it says it needs a win32 enviroment. Does that mean *not* DOS?
    Or a different version of DOS?

    2. So I tried to run Magician from the Command Window that the Windows 10 recovery DVD gives you during setup.
    But it says that the file is "not compatible with the version of Windows you're running"
    Fwiw, if I type VER from that command prompt I get: "Microsoft Windows [Version 10.0.14393]"

    If I could only find the actual driver I need for that SSD... :^(
      My ComputerSystem Spec


 
Page 2 of 7 FirstFirst 1234 ... LastLast

Related Threads
Samsung SSD 850 PRO 512 GB DRIVERS ?? in Drivers and Hardware
Samsung Magician 5.0 claims System NOT Compatible. Drivers need update. Went to URL they said to go, tried several drivers, but almost all are for RAID !! 125372
I'm trying to install Windows on a new machine. The motherboard is ASUS Z170 Pro Gaming. The EUFI BIOS sees the SSD drive (Samsung EVO 750 250 GB) but Windows does not. There is the option to load drivers but i can't find any drivers for the EVO 750...
Hello everyone, I have encountered a problem with Samsung 950 PRO 512GB M.2 NVMe. I would appreciate your help as my knowledge in hardware and software is minimal. So thank you in advance. I have just finished installing windows 10 in a new pc...
As the thread title states, my SSD is mysteriously missing a ton of space.. It is my C: drive with Windows 10 Pro installed on it. I put the SSD in, while using Windows7, anyway, I got Win 10 (clean install from scratch), Cloned from HDD to...
I cannot get my Samsung galaxy to work with windows 10 on my HP Laptop Pavilion dv7-4267cl AMD Phenom II Triple-Core N870 (2.3GHz) 6GB Memory 640GB HDD AMD Radeon HD 6370M 17.3" Windows 7 Home Premium 64-bit the USB drivers...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:03.
Find Us