1.    27 Mar 2017 #1
    Join Date : Mar 2016
    Posts : 64
    Win 10 Pro x64

    Keyboard dead during bootup


    I'm trying to replace my old Dell keyboard with a G.Skill Ripjaws gaming keyboard.

    Unfortunately, it only works after the system boots up, which means I can't use function keys at bootup.

    I've written to G.Skill already. But just in case this problem is not a glitch in my particular keyboard, can anyone suggest a cause and cure?
      My ComputerSystem Spec
  2.    27 Mar 2017 #2
    Join Date : Sep 2015
    Staffordshire
    Posts : 364
    Windows 10 Pro

    Legacy USB enabled in the bios?
      My ComputersSystem Spec
  3.    27 Mar 2017 #3
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,043
    Windows 10 Pro

    As stated, boot into Setup (Bios) go to Integrated Peripherals, look for Legacy USB or Keyboard, if it is Disabled, using your Arrow and Enter keys, Enable it. Save and Exit.
      My ComputerSystem Spec
  4.    27 Mar 2017 #4
    Join Date : Aug 2014
    Forever West
    Posts : 3,926
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    Also, haven't yet seen a motherboard that has built-in support for the USB 3.0 ports, have to wait until the OS loads to get that. Legacy USB is usually version 2.0, may have to assure plugging into the black ports instead of the blue ones.
      My ComputerSystem Spec
  5.    27 Mar 2017 #5
    Join Date : Mar 2016
    Posts : 64
    Win 10 Pro x64
    Thread Starter

    I heard back from G.Skill -- they suspect a problem with the KB's firmware. However, I had a problem fixing that per their instructions. Will try your solution, too.

    (I was using USB 2.0 ports, though I have added a board for USB 3.0)
      My ComputerSystem Spec
  6.    14 May 2017 #6
    Join Date : Mar 2016
    Posts : 64
    Win 10 Pro x64
    Thread Starter

    G.Skill tech support guided me to software and switch settings that solved the problem. I did connect it to a pair of USB 2.0 jacks; this may also have helped because I suspect my USB 3.0 jacks (on an add-in board) might not be activated till Windows kicks in.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
My Laptop keep going in to F2 Password on bootup?
Hi have an problem with bootup as it enters F2 Setup when I have not press F2 and every now and then. Has a spark of life till I restart it. How can I stop it entering F2 Setup and asking for the admistrative password in a blue box? I am using...
General Support
Keyboard Not Registering Some Keystrokes in Bootup Login Screen
My keyboard has never had this problem in the past but lately I've been forced to use the on screen keyboard as mine will not work well at all to type in my password in the login screen. It is extremely laggy and won't even register some keystrokes...
Drivers and Hardware
Solved Bootup Takes Two Tries
I have a strange anomaly with my HP Pavilion dv7-1245dx Entertainment Notebook that had Windows 8.1installed. When I started bootup, it got so far and froze up. I had to do a hard shutdown. On the second try, the laptop starts, but takes an...
General Support
BSOD 10 - 30 seconds after bootup
Hello. I recently updated my HP to Windows 10. During setup after I logged in, I got the BSOD. I thought there was nothing wrong until I logged in and found out that I didn't have Start Menu access. About 10 seconds later, the BSOD came up again....
BSOD Crashes and Debugging
Windows 10: The Charms bar is dead; Start screen dead...
More
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:08.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums