Sabrent USB 2.0 IDE/SATA Hard Disk Drive to USB not detected.


  1. Posts : 1
    Windows 10
       #1

    Sabrent USB 2.0 IDE/SATA Hard Disk Drive to USB not detected.


    It has its own power supply, and I've tried the front and back USB ports on my tower. The lights are all on, and I can hear the hard drive itself running, and yet the computer doesn't detect it in any way.

    The hard drive is a 250GB Maxtor IDE HDD. I've tried these jumper settings: Master, Slave, and Cable Select. And yet, nothing.
      My Computer


  2. Posts : 16,278
    W10Prox64
       #2

    Have you swapped with a known-working USB cable? How old is the box the drive is in? Some older IDE2USB boxes' drivers stopped working past XP. Also the PCB inside the box could be bad. Do you have any way to hook up the drive directly?
      My Computer


  3. Posts : 14,596
    Windows 10 IoT
       #3

    A link to the actual unit in question might help. I have a couple of Sabrent adapters here and all work fine in Windows 10. I have one for USB 2 IDE (laptop and desktop) SATA adapter with power supply that works fine. Plus a couple of Sabrent USB Drive enclosures.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:22.
Find Us




Windows 10 Forums