1.    17 Mar 2017 #1
    Join Date : Mar 2016
    Posts : 10
    Windows 10

    cannot install Dell Vault Host Control driver (broadcom USH)


    Hi,

    I have a Dell Latitude E6530 and I have the classical dell problem of windows not recognizing the "Broadcom USH" driver. Anyway, normally you solve the problem by installing Dell ControlVault, that installs the fingerprint driver.
    So I downloaded the driver from their site but when I try to install it I get the following error:
    Error 1923.Service Credential Vault Host Control Service (Credential Vault Host Control Service) could not be installed. Verify that you have sufficient privileges to install system services.

    Of course I'm trying to install it using an admin account.

    Any ideas?
      My ComputerSystem Spec
  2.    17 Mar 2017 #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,005
    Windows 10 Pro Build 1703

    Hi lethargos

    Found this article which was just updated in the last month.

    How to resolve a Dell ControlVault (Broadcom USH) upgrade failure | Dell Canada

    I also noticed one article that stated you get the same error message when the service is already installed. Did you check your service to see if it is there.

    I also see that these are Windows 7 articles. When you installing have you tried compatibility mode?


    Ken
      My ComputerSystem Spec
  3.    20 Mar 2017 #3
    Join Date : Mar 2016
    Posts : 10
    Windows 10
    Thread Starter

    Well, I checked your link, but I can't seem to be able to find the "Dell" directory under Program Files (or Program Files (x86), which should be of no interest for drivers, anyway, because this is a 64-bit OS), therefore I can't find the log file. It might also be related to the fact that the error shown in the article is different from the one I'm reporting.
    The only folder related to Dell that I can find in Program Files is "DellTPad".

    I can also go on with the installer as I have the 'ignore' option, but that doesn't solve too much. The 'best' thing I got was seeing the yellow exclamation mark in device management for the fingerprint device. When I tried to reinstall it, it went back to the unknown state, so it just alternates like that.

    I also checked the "show log" when the installer finished, but it lead me to a log in Windows\SysWOW64 and there was no "###### BROADCOM USH FAILURE" line in there and I'm pretty sure it was different altogether. Maybe I need to get some other driver?
      My ComputerSystem Spec
  4.    20 Mar 2017 #4
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,005
    Windows 10 Pro Build 1703

    If you go to device manager, properties of driver, details tab, then in the first box (drop down menu) set it to hardware ids.

    This will bring up the ids. I usually search the first line on google.


    Ken
      My ComputerSystem Spec
  5.    20 Mar 2017 #5
    Join Date : Mar 2016
    Posts : 10
    Windows 10
    Thread Starter

    Listen, this is not a usual problem, as it were. The device has been identified. The driver I'm using should normally work. I downloaded from the dell site for my laptop model. I normally read the hardware IDs and type it on pcidatabase.com. But this time this is not the case. It's a particular case. Anyway, in case you can help me with something, the hw IDs says: USB\VID_0A5C&PID_5801&REV_0101&MI_03
    I searched for the PID and the VID on the internet, but nothing relevant for me has come up.
      My ComputerSystem Spec
  6.    20 Mar 2017 #6
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,005
    Windows 10 Pro Build 1703

    Well of course when you search all the driver places say they have the driver. Never sure if that is a scam or not.

    I did find this link for a laptop similar to yours. Likely you've seen this before. Seems they used some files from Win 8.

    E6520 Windows 10? - General Hardware - Laptop - Dell Community

    Problem with these older devices.

    Good luck.


    Ken
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Is Dell Wireless Driver install needed
Noticed in control panel that Dell wireless driver progam is installed on my Dell 660. I use wired connections for the pc to my modem and don't know if it is necessary as I do not have any wireless items connected. A wifi finder program shows...
Drivers and Hardware
Unable to install Broadcom GPS driver (BCM4752)
Hi guys, I did a clean install of Windows 10 on my Lenovo Miix 2 8 tablet. Everything went fine. But, I wasn't able to install the driver for the internal GPS. It's a Broadcom BCM4752. The installation of all drivers I found (including...
Drivers and Hardware
BSOD on Windows 10 [Broadcom 802.11 Wireless Driver, bcmwl63a.sys]
Hey Guys, ~Per a moderator's request, I have created a new thread. I had initially commented this post in another thread. ~ I did a bare metal install of Windows 10 on a Dell E7250 (touch). While docked at work, no issues at all. As soon I...
BSOD Crashes and Debugging
Broadcom Bluetooth 3.0 driver fail in Windows 10
Hello, I have a question I hope you guys can help me, I have a keyboard Logitech MX 5000 and once I Upgrade Windows to Window 10 it stop working, problem is Broadcom driver is not ok, I saw in other forums, install, uninstall, update driver, delete...
Drivers and Hardware
Broadcom Virtual Wireless adapter driver needed to download W10
I have a dell inspiron N4010 W7 SP1. I am trying to download W10 and message from W10 indicates that I need to download a driver for this adapter; opened the device manager and located the adapter and then tried to update the driver and...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:15.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums