1.    05 Mar 2017 #1
    Join Date : Mar 2016
    Posts : 64
    Win 10 Pro x64

    Invisible external drive


    I have an old Mojopac external HD, ca. 2006, that I'd like to use for portable storage. (This was a Windows environment on a drive.) When I plug it in, it lights up and I can feel the motor running, but I don't see it in This PC or under Devices in Control Panel.

    How can I access and reformat it?
      My ComputerSystem Spec
  2.    05 Mar 2017 #2
    Join Date : Aug 2015
    Posts : 22
    windows 10

    Do you see the drive in disk management?
      My ComputerSystem Spec
  3.    05 Mar 2017 #3

    Have you tried running something like Minitool Partition Wizard MiniTool Partition Wizard | Best partition magic alternative for Windows PC and Server

    See if the drive shows , (probably without a drive letter) , you can then format and allocate a drive letter.
      My ComputerSystem Spec
  4.    05 Mar 2017 #4
    Join Date : Aug 2014
    Forever West
    Posts : 3,922
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    You usually can assign a drive letter without having to re-format since it appears to have been formatted for use previously. If it does not have a partition on it you can create as desired followed by formatting. Or re-format to remove any data but I like to really clean one by deleting the partition/partitions first then recreate as desired, quite fast.
      My ComputerSystem Spec
  5.    05 Mar 2017 #5
    Join Date : Mar 2016
    Posts : 64
    Win 10 Pro x64
    Thread Starter

    Tried Acronis Disk Director, which I have on hand, and no trace of it (don't know what Drive 6 is, but 512 bytes seems oddd)Click image for larger version. 

Name:	Drives per Acronis.png 
Views:	9 
Size:	62.2 KB 
ID:	123890
      My ComputerSystem Spec
  6.    05 Mar 2017 #6
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,040
    Windows 10 Pro

    Go to Start/Search and type diskmgmt.msc, right click the diskmgmt results and Run As Administrator. In the Elevated Disk Management window in the lower pane, is your drive showing up here? What does it say about Disk 6? If you unplug the external drive, does Disk 6 disappear in Disk Management or Acronis?
      My ComputerSystem Spec
  7.    05 Mar 2017 #7
    Join Date : Mar 2016
    Posts : 64
    Win 10 Pro x64
    Thread Starter

    This time, the mystery is Disk 5, shown as healthy and without content, no file system. Clicking it brings up the Initialize dialog:Click image for larger version. 

Name:	Initialize.png 
Views:	13 
Size:	5.1 KB 
ID:	123917

    I guess I should use MBR, so as not to limit the PCs I can use it with.
      My ComputerSystem Spec
  8.    05 Mar 2017 #8
    Join Date : Aug 2014
    Forever West
    Posts : 3,922
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint

    Yes.
      My ComputerSystem Spec
  9.    06 Mar 2017 #9
    Join Date : Mar 2016
    Posts : 64
    Win 10 Pro x64
    Thread Starter

    I clicked MBR and OK, but the readings I get from Device Manager and Disk Management are unchanged. tried it again on a USB 2 outlet (originally tried on a USB 3.0), but still no change.
      My ComputerSystem Spec
  10.    06 Mar 2017 #10
    Join Date : Jun 2016
    Los Angeles
    Posts : 1,040
    Windows 10 Pro

    The USB controller inside the enclosure may be failing.
    Does this external HDD have its own power adapter? If so, be sure you are using the right one, and it is plugged directly into the wall and not through a power strip. And you are plugging the USB cable into the Back USB ports (desktop) not the front as these ports are weaker. Also, try it on a different computer.
    If it fails on all computers, you can disassemble the enclosure and remove the HDD and attach it internally to a Desktop computer, or via a USB adapter, Dock or another Enclosure with a power adapter.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Was moving files to external drive, drive not recognized and lost all
Dear Sir/Madame, I was moving video files (AVI) from an external backup drive (WD Element) to another external backup drive (Seagate expansion) after having moved another video file from my laptop (Acer) to that Seagate external drive. The night...
Drivers and Hardware
Pen Drive and external hard drive keep getting errors!
Pen Drive and external hard drive keep getting errors! So I select to fix the problem scandrive recommended scan and repair. But there's never anything wrong with them it reports! And it takes ages to scan it takes 10-15 minutes for 32GB pen drive....
Drivers and Hardware
External Drive.
Hi, I have a Seagate Barracuda ATA Mod.ST3120023A hard drive with XP installed. Is it possible to insert it in an external caddy with a usb connection and then boot into win xp from my Win10 64 bit PC to recover some files. And then I...
Drivers and Hardware
Got a dead external USB drive? Drive may still be good!
So, I have this WD 2gb external USB drive that would not power up. I checked the power supply and it was fine. Decided to open it up and low and behold (I should have known this) an internal drive with a little circuit board attached for the...
Drivers and Hardware
External 1TB hard drive(Iomega - seagate inside) RAW drive - HELP
I recently upgraded to Windows 10 and post that It was working fine without any issues. I have two external drive connected to it. 1. 1 TB Iomega powered drive. - now RAW 2. 2TB seagate external drive. The 1tb drive suddenly became RAW and I...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:42.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums