Let me preface this with the fact that this is my first post and that I am new. I've scoured the WWW for fixes to this issue and nothing has worked. I'm hoping to find something that will, and I'm willing to retry what I've already done at others' suggestion; sometimes it works better the second (or third, or fourth, or seventy-second) time.

Alright, so basically, I have an out-dated but wonderful tablet I purchased from MonoPrice a year or two ago. It's based on a Huion design, if I'm not mistaken, and worked great with the drivers I picked up from the MonoPrice website when I purchased the product... on Windows 7.

Those drivers have since been taken down; evidently MonoPrice decided to get rid of a lot of their legacy driver support.

Now, on my updated Windows 10 PC, I plug the device in, it loads up its driver, and the thing works alright for general use as a Mouse and works phenomenally in Windows Ink Sketchpad and stickies and whatever else (full pressure sensitivity, pixel recognition, etc.).. but as soon as I open Photoshop or Paint Tool SAI or any other actually useful art software, it either works as though I'm using just a standard mouse or completely bugs my pointer out.

The Tablet is a WA60 Pen Tablet.

I'm running Windows 10 Pro.